Rapid Storage Technology
Intel® RST, RAID
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
1808 Discussions

C600 Chipset SAS Raid not compatible with Windows 10 update

Community Manager

Has anyone received an error message when trying to run the Windows 10 Update?

Message: This device isn't compatible in Windows 10. Contact the manufacturer for more info.

Intel C600 Chipset SAS RAID Controller (Intel Corporation).

0 Kudos
15 Replies
Community Manager

Hello artdude12,

Thank you for joining the Rapid Storage Technology Community. I am sorry to hear you are having issues with this matter.

Could you please let us know your computer model?


Amy C.

Community Manager

The computer is a DIY with a Gigabyte X79S-UP5 motherboard.

I also tried disabling the C600 Chipset SAS RAID driver, since I'm not using a RAID, but the update/install still didn't work.

I'm also reaching out to Gigabyte to see if there are any issues with this MB and the Windows 10 Update.

Community Manager

/thread/119463 artdude12, thank you for that information.

Since this is related to the update itself I would also recommend reaching Microsoft, and please let me know what is Gigabyte stand regarding this matter.

Did you try to uninstall RAID driver and then run the update?


Amy C.

Community Manager

/thread/119463 artdude12,

If you need further assistance let us know.


Amy C.


Hi, I have the same motherboard and the same problem. I am not using RAID, but WIN 10 can't update because C600 SAS is not compatible.


I tried everything, uninstalling drivers and updating them. Problem still there.
Community Manager

Hello VVerden,



Thank you for contacting us regarding the issue that you have been experiencing with the Windows 10 update error (C600 Chipset).


In this specific matter we recommend you to contact directly your OEM motherboard manufacturer so they can provide you with the assistance required in order to get the issue.


Hope this helps,




Best Regards,


Diego S.





New Contributor I

Based on my experience with an even older chip set (see thread at particularly the last post - it is on the second page), what I'd suggest is that you install RST driver level13.6.0.1012 . Hopefully that will work for you as it did for me. (And in your case, the driver readme specifically mentions your C600 chipset). (I don't work for Intel)

You may need to do it in steps:

Download link: https://downloadcenter.intel.com/download/24779/Intel-Rapid-Storage-Technology-Intel-RST-User-Interf... Download Intel® Rapid Storage Technology (Intel® RST) User Interface and Driver

1. SetupRST -Noservice [To install just the drivers] (If you don;t do this, you *may* get a "Fatal Error" during the driver install because it cannot install the service - at least I did.

2. Reboot

3. SetupRST -Nodrv [To install the monitoring service and user interface]

Although those drivers are not formally supported under Windows 10, in my experience (again, with an older chipset) they work fine.

See also:


Thanks for your response.


I've sorted this by:


1) Uninstalling driver and restarted (windows had error on loading driveso I...)

2) Loaded Win in safe mode

3) Lunched latest driver

4) restarted

5)Win updated succesfully

Its strange as with simple driver update Win still have problem.

Thanks for your help anyway.


Solution For Windows 10 Update | Intel C600 Chipset SAS Raid Incompatibility


Hello everyone,


I have found a workaround that allows Windows 10 Update to work on motherboards with an Intel C600 Chipset SAS RAID Controller. This method simply bypasses the RAID Controller on the motherboard. If your motherboard has a SATA port, please read on.


My motherboard contains two SAS headers: SAS_0 and SAS_1. SAS_0 is used to control the 4 built-in hard drive bays in the computer case [using a RAID array, which is optional]. My system was not using a RAID array, both of my hard drives were configured as "Non-Raid". If your system is setup with the "Non-Raid" configuration, please read on.


My motherboard also contains two SATA headers: SATA_0 and SATA_1. The SATA ports are not part of the SAS/RAID controller. The primary OS drive can be unplugged from the SAS/RAID bay and plugged into one of the two SATA ports. In my case, there was an extra SATA data and power cable available. Before you remove hard drives, some configuration work must be performed. Again I want to stress if you are configured in a RAID array, do NOT perform the following procedure, you will lose data. Only perform the following if you are in a Non-Raid configuration.


As always, make backups, clone your hard drive, etc., before attempting the following:


  1. Boot into Windows. Open Device Manager and Uninstall the Intel C600 Chipset SAS RAID Controller which can be found in the "Storage Controllers" tree. Right Click on the device and select Uninstall device. When asked to uninstall the drivers, you can select "No". (This worked for me. However, you may want to select "Yes" to completely remove the drivers.)
  2. Shutdown the machine.
  3. Boot into BIOS. Locate the SAS/RAID setting and select "Disable". This will turn off the RAID controller. Save changes and shutdown the machine.
  4. Remove your hard drive(s). In my case there were two drives: primary OS SSD, secondary 3.5" SDD used as a data drive (D:\).
  5. Locate the SATA_1 data and power cable. Plug the primary OS drive into these cables. (Note: if you do not have an extra SATA port but you do have a CD/DVD drive, you can simply unplug the SATA data/power cables from the CD/DVD drive and plug them into your primary OS drive to perform the update.)
  6. Boot into Windows.
  7. Download the "MediaCreationTool1909.exe" from the Microsoft website. (In my case, I was upgrading Build 1809 to 1909.)
  8. Run the Media Creation Tool and follow the steps to update Windows on your existing machine.
  9. Wait. This process can take a while. (Mine took ~45 minutes.)
  10. Once Windows has completed the update, boot into Windows and run the Windows Update "Check For Updates" again. My system had a few additional updates to install before the system was completely "up-to-date".
  11. Shutdown the machine.
  12. Here you have a choice. Leave the primary OS drive plugged into the SATA port, or, relocate it back into the SAS bays. (In my case I plugged the secondary 3.5" HDD back into the SAS bay.)
  13. Boot into BIOS. Locate the SAS/RAID setting and select "Enable". This will turn the RAID controller back on. (If you only have a single hard drive and want to leave it plugged into an extra SATA port, then this step is not necessary. You can put the case back together and begin using your new updated Windows.)
  14. Save the BIOS settings and exit.
  15. Boot Windows.
  16. The system should automatically find the secondary hard drive and re-install the Intel C600 Chipset SAS RAID Controller. If not, you can manually install it using the appropriate driver from the motherboard manufacturer.
  17. Enjoy you newly updated machine!
  18. End of procedure.


I have been running the new updated machine and have not experience any issues with it.


System Specifications:

Dell Precision Workstation T7600

OS Version (before workaround): Windows 10 Pro 1809 (updates to 1903/1909 were blocked due to the C600 SAS RAID controller)

OS Version (after workaround): Window 10 Pro 1909

Primary OS "C:" drive: 2.5" SSD, 256GB

Secondary "D:" drive: 3.5" HDD, 1TB

Non-Raid configuration (All disks labeled Non-Raid.)


Nvidia Quadro K5000 Graphics Card


Good luck to everyone!





I have a question about this setup with windows 10.


Can you have 2 hard-drives in SAS with the RAID disable so we can see two partitions/Drives on My Computer?


Or it has to be a single one and the other in the Sata port of the motherboard?


I have the same situation and system - Dell T7600 with a SSD bot drive. I had to plug it into the SATA wires on the back side in order to install Windows or do an image drop. It boots fine and even sees a test drive I put into the SAS RAID rack.

The Intel C600 2015 driver is loading and shows the test SATA drive in the SAS rack.

When I place the SSD back into the SAS RAID rack either by itself or with the test drive and boot, I get Inaccessible Boot Drive error. BIOS is all correct.

If Windows 10 is using the IastorS.sys driver for the C600 to access the test drive, why doesn't it allow booting to the SSD?

Also, there is no place to install the SSD in the box. Not one free 5.25" or 3.5" bay anywhere. This was a $10K workstation and it's so frustrating.

Thoughts? Thanks!


I also have a T7600 and ran into the same error last night, so I was glad to find some information here to help me start troubleshooting. My system is all SSD (front bays only, nothing internal), including the boot drive and (2) 4Tb SSDs in a RAID 1 array (I know, it's excessive). My Dell has been smooth as silk since I replaced the had drives with SSDs in the hope of milking a few more years out of this box, which I like a lot. Now this. Argh! 

I ran the Intel Driver & Support Assistant (FWIW) and it says I'm current.

I have no new information to add yet, but I wanted to quickly post here so you'd know there's at least one more Dell T7600 user facing this issue. If I find a solution or confirm one already offered here, I'll post again. Otherwise, check the obituaries.

I've delayed the mandatory update process for 7 days. Good luck to all!

System Specifications:
Dell Precision Workstation T7600, 32Gb
Motherboard: Dell 082WXT
BIOS: Dell Inc. A17, 06/30/19
Processor: Intel Xeon CPU E5-2630 
OS: Windows 10 Pro Version 10.0.18363 9200
NVIDIA Quadro K4000 graphics card (running 3 Acer monitors, various models)
Primary OS Drive C: - 2.5" SSD 512Gb (Front bay #0)
Data Drive - two 4TB SSDs in RAID 1 array (Front bays #1, #2)

Intel® Rapid Storage Technology enterprise Information
User interface version:
Intel controller: SAS
Number of phys: 8
Intel controller: SATA (AHCI)
Number of SATA ports: 1
RAID option ROM version:
Driver version:
ISDI version:




Yes - you can have 2 drives in SAS / RAID disabled / 2 separate drive letters.


My workstation was originally setup this way from Dell. I have never used the RAID feature. Windows 10 is installed on one hard drive in SAS Bay 0. The 2nd hard drive is my "data" drive, installed in SAS Bay 1. The system boots from the OS drive and Windows detects the second drive as a separate drive. I have mine mapped as "D:". The problem with this setup is Windows 10 will not update beyond build 1809 when the drive is installed in the SAS Bays. The workaround to update Windows 10 is listed above in my previous post. After you update you can move the OS drive back into the SAS bay, however, I am not sure if future updates will continue to fail. I left my OS drive plugged into the SATA port because I noticed an increase in performance.


Good luck!




I have just seen this post and it may solve my problems. Hopefully anyway.

I have a Dell T3600 and having no end of problems trying to add drives to  my set up.

I have SATA and AHCI enabled in the A18 latest Bios for the T3600.

My drives are in SATA-0 and SATA-1 and they work fine. Win 10 is on C: a 1TB ssd and the other is a 4TB data drive in 3 partitions all with their own drive letters.

I have had to take the DVD drive out of SATA-1 so the 2nd HD drive works.

So have 2 drives both in SATA ports and no DVD.


I cannot get any drives to work in my HDD0-3 ports no matter what I do.

I have the latest Win 10 Pro x64 21H2 and it works great with the drives in the SATA ports.

I have tried various Chipset drivers but nothing works to get the HDD ports working so I can add drives.


Are there any suggestions how I can do this please?

Thank you in hope


Super User Retired Employee

You are responding to a very old thread. Please open a new thread to discuss your issue. Have you discussed this issue with Dell's tech support folks? To me, BTW, this sounds like a hardware issue.