Rapid Storage Technology
Intel® RST, RAID
2055 Discussions

Cant Load RST software on new PC

DRH11
Beginner
709 Views

I cant load any version of Intel RST on my new PC.

Configuration:

Asrock B660-HDV motherboard

Intel i5-12500 CPU

1 x 1TB SSD (boot drive, Win11 home loaded)

2 x 2TB HDD (targets to become a RAID1 array)

 

I downloaded the zipfile RapidStorage(v19.5.0.1037.1_0907) from the intel site, as being the recommended RST software load for 11th to 13th Gen Intel chipsets. the B660 chipset is listed as being supported in the readme file. Successfully extracted and installed the RST software and then ran from the RST.exe file. The run aborted and I received the attached error message.

I then downloaded the zipfile RST-Win10_Win11-19.5.1.1040 from the intel site, being the version recommended for Win11. Same result with the same error message.

the only thing I can think of is that I have the OS already loaded. Is this still an issue, I know it was years ago. The advice from the Asrock website re creating a RAID array, though not MB specific is to download the appropriate driver from Intel and run the exe file. No mention of prior to OS installation. In fact, I would have to have an OS to follow their instructions.

0 Kudos
1 Reply
Alberto_R_Intel
Employee
690 Views

DRH11, Thank you for posting in the Intel® Communities Support.

 

We are sorry to hear about this issue and we will be more than glad to assist you with this matter.

 

In reference to your inquiry, no, it should not be an issue to have the OS already loaded, unless you installed it while the SATA mode on the BIOS was on "AHCI", since to be able to create a RAID configuration the SATA mode should be on "RAID". If you change it now, it will be necessary to reinstall the OS.

 

As you can verify in the link below, the Intel® RST version tested and validated by AsRock for your board is ver:19.5.0.1037.1_0907, please try to install that version again since it should work with your system with no problems:

https://www.asrock.com/mb/Intel/B660M-HDV/index.asp#Download

 

If the problem persists after that, just to confirm:

Were you able to properly install Intel® RST before on this specific machine?

If yes, when did the issue start?

Did you make any recent hardware/software changes that might cause this problem?

What kind of RAID configuration are you trying to create?

Does the problem happen at home or in the work environment?

Please attach the SSU report so we can verify further details about the components in your platform, check all the options in the report including the one that says "3rd party software logs":

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-?product=91600

 

We also recommend to get in contact with AsRock Support to make sure the latest BIOS version is currently installed on your machine or to gather the instructions on how to update it, and to check the RAID mode setting in the BIOS:

https://www.asrock.com/support/

 

Any questions, please let me know.

 

Regards,

Albert R.

 

Intel Customer Support Technician

 

0 Kudos
Reply