Rapid Storage Technology
Intel® RST, RAID
2088 Discussions

DATA Recovery (accidental re-initialization of RAID 1)


Hello. I am desperate. Please help me. This is what happened:

1: I had two 2GB disks in RAID1 (mirror), through Intel RST (Rapid Storage Technology). I was using this as backup (stupid I now).

2: Later I bought newer PC and I moved the disks here. In the meantime I have read that RAID1 is not good for backup, so I decided not to use it anymore. But I did not cancel the RAID array - I was using both disks separately - one of them I formatted and it was used as backup disk (I started using EaseUS Todo Backup). Everything was fine. To be clear, I will name the disks: D=DATA, E=BACKUP.

3: I found out some of my PC drivers were not up-to-date, so I decided to download all drivers for my PC (motherboard), including this Intel RST, not thinking about what it could cause. After installation of Intel RST and restart, there was windows startup problem and disk checking came up. It stack at some percent for maybe an hour, so I restarted. This repeated many times and after I finally got into windows, I found out that the RAID1 was initialized somehow (by Intel RST) - disks are mirrored, but many data are missing. And some of the data worked, some I could not even open. It looked like it restored RAID with data from my previous PC (3 months ago) - data since then were missing. But, also data from backup (E drive) from EaseUS software were present, but corrupted, so I couldnt recover from them.

4: I lost important data (architectural projects, my firm documents etc), but I rely always on myself (mistake). So, in agony, I tried to use the Recuva software, which recovered me tons of files, but without any structure (200,000 files in one folder), and still the new ones were missing. I restored the files to E drive

5: I decided to call in IT-guy (too late), who of corse told me, that after new data were copied (after data loss), it will be difficult to recover them. He tried to recover the data with EaseUS Data Recovery PRO, but with bad results. Data missing from the 3-months span were missing, and data, which he was able to recover, were not working - file error comes after opening any file (jpg, pdf, dwg...)

6: Any ideas, what could bring me my data back? Is it somehow to restore the state, before this accidental re-initialization of RAID happened? Thank you very much for yout help!!!

0 Kudos
1 Reply

Thank you very much for contacting the Intel® Communities Team, munkey_89.



Allow me to share with you that unfortunately, we do not have any type of software for you to use in order to recover data either a method to achieve so. I recommend you to use another 3rd party software or to take the disk to your local store so a technician can help you trying to recover those files.




Antony S.