Rapid Storage Technology
Intel® RST, RAID
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
2034 Discussions

Enable RST in BIOS after installing in AHCI mode



Windows 10 fails to boot when I enable RAID in BIOS. Please tell me how to install the "iastor" driver properly.

Steps to recreate:

1. Install Windows 10 with the AHCI drivers to a hard drive

2. Do whatever (for 6 months +)

3. Install RSP drivers and software from the vendor (ASUS)

4. reboot

6. Enable RAID in BIOS

7. Configure two drives in stripe mode (unrelated to windows-system-drive)

8. Boot

What I expect:

I can boot the system and access my windows-system-drive as if nothing hat changed.

I can configure or format the newly created raid-0 with windows tools.

What actually happens:

Reboot at the INACCESSIBLE_BOOT_DEVICE blue screen


I get the notorious INACCESSIBLE_BOOT_DEVICE error message when I try to boot after changing "sata selection mode" from AHCI -> RAID in the BIOS.

The supplier of my motherboard lists a dated version of the software (and the driver) on their website.

I reckon this is fine because the newest package fails to install with "platform not supported" even though I picked windows 10 64 bit, in the download page.

The older package from ASUS installs fine. I assume it installs the driver.

https://www.asus.com/us/Commercial-Servers-Workstations/Z97WS/HelpDesk_Download/ https://www.asus.com/us/Commercial-Servers-Workstations/Z97WS/HelpDesk_Download/

If my board is supported by the newer package, then please tell me which one to download if not "windows 10, 64 bit" from this page (or fix your installer):

https://downloadcenter.intel.com/download/27147/Intel-Rapid-Storage-Technology-Intel-RST-?product=55005 Download Intel® Rapid Storage Technology (Intel® RST)

I've tried the "setup rst exe" variant.

MD5: 1b30f69e52fe9440d5c386f3f5ff7fef

Version: (Latest) Date: 9/12/2017

I surmise someone forgot to translate a string, so the installer is crapping out on me for no good reason - please check the IntelRST.log.

It could be that I need to enables RAID in bios for it to detect my "platform" as supported, but that is a chicken - egg problem in this particular case.

i.e. I can not boot if I enable RAID in BIOS.

That was the background.

The final objective:

I want to stripe two drives in my system and access them from Gentoo (I am not asking for help with this process).

There is a total of 4 drives in the system. Windows is not on a completely separate drive.

Come to think of it, let us simplify the problem;

Forget the other drives and the kind of RAID I want to set up and how I plan to use it.

The problem:

I need instructions on how to enable Windows 10 to boot from a non-raid drive while the motherboard SATA access is configured in RAID mode after the windows OS has been installed to a non-raid drive.


I have also tried the "sysprep" method to allow windows to detect new hardware - but I did not use the "generalize" option. Perhaps I need to do that?

Anyway, I rolled back to a backup because It created a whole new user and messed up my quick-launch-bar and some other user settings.

0 Kudos
2 Replies

Hello jazzoslav,

Thank you for joining the Rapid Storage Technology Community. I am sorry to hear you are having issues with this matter.

The most important fact regarding the issues you are having is related to switch done to the SATA mode, if this mode is changed from AHCI to RAID the operating system must be re-install. If this procedure is not done, BSOD's and other issues while creating the RAID structure are completely expected, this is a operating system limitation. For you to proceed with your objective, you must set your BIOS to RAID and re-install the operating system. Once the operating system has been reinstalled on RAID mode you can create the RAID volume.


Amy C.

0 Kudos

/thread/119394 jazzoslav,

If you need further assistance let us know.


Amy C.

0 Kudos