Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DDrag6
Beginner
805 Views

Intel RST 16.8.2.1002 fails to install on Windows 10 Version 1809

Installation around 80% progress and then it fails with "Fatal error during installation" message.

https://downloadcenter.intel.com/download/28653/Intel-Rapid-Storage-Technology-Intel-RST-User-Interf...

 

Excerpt from %USERPROFILE%\Intel\Logs\IntelRST_MSI.log around where I think the error appears.

Action start 14:59:08: IIF_PREPUNINSTALL. ** UninstallDrivers **: 2019:03:23 14:59:08:834: Loading resource with id 30008 ** UninstallDrivers **: 2019:03:23 14:59:08:834: Loaded resource: Your system has Intel(R) Optane(TM) or Intel(R) Smart Response Technology(TM) acceleration enabled. The package you are trying to install does not support your current acceleration configuration. Before continuing please do the following: 1. Please disable acceleration. 2. Please clear all cache volumes that were used for acceleration. 3. Please start the installation again. ** UninstallDrivers **: 2019:03:23 14:59:08:834: === MwClient: Checking block cache requirement ** UninstallDrivers **: 2019:03:23 14:59:08:834: === MwClient: Middleware initialized. ** UninstallDrivers **: 2019:03:23 14:59:08:850: === MwClient: Session opened ** UninstallDrivers **: 2019:03:23 14:59:08:850: === MwClient: Found 1 controllers ** UninstallDrivers **: 2019:03:23 14:59:08:850: === MwClient: Nvc cache size: 0 ** UninstallDrivers **: 2019:03:23 14:59:08:850: === MwClient: Check for level2... ** UninstallDrivers **: 2019:03:23 14:59:08:850: === MwClient: Checking block cache requirement - passed ** UninstallDrivers **: Install data file: C:\Program Files (x86)\Intel\Package Cache\{409CB30E-E457-4008-9B1A-ED1B9EA21140}\Install.data ** UninstallDrivers **: !!!Win32 Exception: (0xB00B) - Error extracting from memory CustomAction IIF_PREPUNINSTALL returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox) MSI (s) (D8:04) [14:59:08:881]: Note: 1: 2265 2: 3: -2147287035

Previous version 16.8.0.1000 installed just fine previously. In fact it is the one mentioned in the log above, I will try to manually uninstall it first and then install the new one, maybe that will help.

0 Kudos
2 Replies
DDrag6
Beginner
182 Views

Uninstalling previous Intel RST version (16.8.0.1000), rebooting and then installing the new version solved the issue for me, thank you.

 

Additional note:

Having to apply the same on another system with similar results, I realize something that the two have in common is the TEMP variable pointing to an OSFMount RAMDrive.

 

Trying to uninstall the older version on this system failed with something like "unable to extract language" or "unable to load language". Opening up an Administrtor CMD, setting temporarily in the console the user TEMP and TMP variable pointing to the system drive, works to uninstall it.

 

I haven't retried the whole scenario from the start, possibly changing the TEMP variable to a system drive in the first place and update in place, maybe that would have worked from the beginning. The RAMDrive performs fine otherwise, no idea why it would influnce the installation process.

 

Alberto_R_Intel
Moderator
182 Views

DDrag6, Thank you for posting in the Intel® Communities Support. Perfect, excellent, it is great to hear that the problem got fixed and you were able to install the Intel® RST 16.8.2.1002. Thank you very much for your feedback, we are sure it will be very helpful for all the peers viewing this thread. Regards, Alberto R. Intel Customer Support Technician Under Contract to Intel Corporation
Reply