Community
cancel
Showing results for 
Search instead for 
Did you mean: 
TSand4
Beginner
1,338 Views

Intel RST no longer present since windows 10 update

have a toshiba Satellite A505 Core I3. For quite a while I had the Intel RST running on my system. It was originally Win7 upgraded to Windows 10 a few years back. I had the RST driver working which reduced my Disk utilization drastically. Since a windows 10 udate about 2 months ago Im not longer able to install it. I get

2018:07:10 16:14:09:843: E Win32 exception occurred!!

2018:07:10 16:14:09:844: Error code: 0x4E24 (20004)

2018:07:10 16:14:09:845: Error text: ''

2018:07:10 16:14:09:846: Extended error text: 'Error in device matching'

2018:07:10 16:14:09:847: Debug info: 'Setup.cpp (916)'

2018:07:10 16:14:09:848: Node is not valid. Failed to resolved error string from config file error: 20004

2018:07:10 16:14:09:849: propertyId: 8095, serror: This platform is not supported. errorCode: 20004

My disk usage is staying above 90%

0 Kudos
3 Replies
RAJU2529
New Contributor III
192 Views

you must uninstall previous RST driver and its associated files by REVO UNINSTALLER , because you have upgraded from windows 7 to windows 10.

Install latest intel RST driver 16.0.2.1086

https://downloadmirror.intel.com/27681/eng/SetupRST.exe https://downloadmirror.intel.com/27681/eng/SetupRST.exe

The latest windows 10 edition is 1803 ,

Is your laptop or desktop is compatible with windows 10 v1803 and is able to run windows 10 ?

is windows 10 drivers are available for the laptop or desktop in your OEM website.

TSand4
Beginner
192 Views

I still get the same result when I try to run setup.

My system has failed 3 times to do the Windows 10 1803 update

v

My system has been running windows 10 for over a year

n_scott_pearson
Super User Retired Employee
192 Views

Your platform has a 1st generation Core processor and a 5 Series chipset. Intel supports Windows 10 with 4th generation and newer Core processors and the corresponding 8 Series and newer chipsets. Because you upgraded Windows, an existing compatibility driver kept RST working. Microsoft decided to drop all support for this compatibility driver, however, and uninstalled support for this compatibility driver as part of the 1803 update.

Bottom line, I am sorry to say that there is no solution.

...S

Reply