Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
1,160 Views

New build RAID 1 performance with ICH9R Read speed 33% of single drive and write reported at 120% (huh)

Hi,

I have a very odd problem. Just purchased 2 new 2Tb Seagate drives to replace my old "click of death" seagate1.5Tb drives. Everything seemed fine until I started copying large volumes of data from the Raid drive, transfers seemed very slow. So did some benchmarks.

I have had this system for over 2 years with no issues, the only change here is to replace my old raid drives with new ones. System is Gigabyte GA-P35-DS3R / 8Gb mem / ATI 5850 / Vertex2 SSD as main drive and 2 x seagate 1.5Tb in RAID 1 (Windows 7 64). I did not bother with the speed of the raid so it was probably there all the time.

So testing. Tried lots of things.

Split the raid set into individual drives and tested a single drive.

Seagate 2TB LP gives Read = 103Mb Write = 96.9Mb/s

So far so good, it's about as expected for a 5900rpm drive.

Add two of these drives in RAID 1 - mirrored, would expect the read speed to be about the same (or higher) and write to go down. Tried different ports (0,1 / 4,5 etc)

Result Read = 44Mb/s Write = 127Mb/s

and WTF, I mean really how can Raid1 write quicker than a single drive. Is the Intel driver doing something funny here? No read cache?

This is reflected in copies of about 10Gb of files, the copy from the drive takes about twice as long with the drives in RAID

Now this motherboard also has 2 SATA ports for Gigabytes flavour of Raid so I tried that for the raid set

Seagate 2TB LP using Gigabyte raid gives Read = 118Mb Write = 74.9Mb/s

About what I would expect from RAID1.

It gets worse

Using ATTO for benchmarks I tried different versions of the Intel drivers (8.9 / latest 10.something) see below

Very strange results.

Any ideas on what might be happening? I don't expect miracles but I would expect sequential reads to be about a 1/3 the speed of a single drive.Perhaps ATTO is reporting things incorrectly but real world copies show the drop in read performance of the drive and write seems quicker, although I suspect it is just the cache as completion is reported a while before drive activity stops.

Thanks

John A

0 Kudos
2 Replies
Highlighted
Community Manager
12 Views

Try a format with 8K (8192) allocation unit size (cluster) and Write back cache on in RST.

I did lots of testing for RAID 1 and a 8K cluster seemed best for some reason.

Highlighted
Community Manager
12 Views

Peter,

Thanks, I will give it a go. Will need to use different drives as my Gigabyte RAID is stable now and in use.

0 Kudos