Rapid Storage Technology
Intel® RST, RAID
2077 Discussions

RAID 5 VMD RST Poor Writting performance / Z790

OptimusDark
New Contributor I
10,395 Views

Hello,

I recently bought a Z790 system and created a RAID 5 volume with 3 HDD.

I have 3 identical and brand new WD HDD.

Each individual disk have good performace. Using Diskmark it reaches 280Mb/s for both SEQ1MQ1T1 & SEQ1MQ8T1 writting test.

When I create a 3x RAID 5 volume the SEQ1MQ8T1 is measured at 218Mb/s (less than a single disk)  even worse the SEQ1MQ1T1 drops to 22Mb/s.

When I copy from local non RAID disk large files, it confirms 20Mb/s in real life data transfer... It can drop sometime to 5Mb/s and during few seconds to less than 1mb/s.

When I check the task manager, I can see that the drive is at 100%. 500ms of response time and between 0 et 60Mb/s of data transfer rate.

Strangely, Only one core is often at 100% when copy is in progress.

The problem is even worse when copying from network.

I installed all latest drivers (intel chipset, VMD/RST 13th gen) and MB BIOS is up to date.

I tried Windows 11 public releases as well as insiders (up to beta channel), the behaviour is the same.

I'm affraid that the problem could be between intel driver & Microsoft way of managing storage system cache...

Do you have any clue ?

Thanks for your help.

PS: I've attached the diskmark results (individual disk & RAID 5 volume results) and SSU infos

27 Replies
OptimusDark
New Contributor I
649 Views
0 Kudos
Mat_A
Beginner
641 Views

This still only gets me to about 10mb/s write speed. This should be at least 80-100mb/s.  The drives do 240mb/s sustained when they are not in RAID.

0 Kudos
OptimusDark
New Contributor I
629 Views

you must :

- Deactivate Write-cache buffer flushing

- Activate Buffered write (sorry don't know the exact words using since I'm on the french interface) on the RAID volume configuration. You must click on "Modify cache mode configuration" to access this parameter.

 

Please send captures from your raid configuration.

0 Kudos
Mat_A
Beginner
628 Views

I don't see any options to modify any cache or buffering from the Intel Management UI. It does say "Data disk cache: Enabled"

0 Kudos
Mat_A
Beginner
593 Views

Perhaps the poor performance is because the drive is still Initializing? It is initializing very slow. 3% in 5 hours.

0 Kudos
OptimusDark
New Contributor I
528 Views

Yes you must wait for the initialization process to finish. The HDD are busy during that time. Try the speed test after.

 

To access cache mode parameter your must click on the zone as described in the attached image.

0 Kudos
Mat_A
Beginner
467 Views

So after the initialization process was finished I was able to access the cache mode parameters. I set them to what you recommended and now my write performance is where it should be.

Thank you so much!

0 Kudos
Reply