Rapid Storage Technology
Intel® RST, RAID
1980 Discussions

RAID members appear offline under Windows XP


I have the following configuration on my ASRock Z68 Pro3-M Motherboard:

SATA3_0 - Optical drive

SATA3_1 - OCZ Agility 3 90GB SSD



SATA2_4 - Empty


The two HDDs are in a RAID1 Array and are accelerated through Smart Response Technology.

The SSD is partly used for SRT (20GB) and partly used for Operating System (Windws 7 x64)

Under Windows 7 everything looks normal:

I have installed Windows XP Professional (32 bit) on the external drive to use in case of main OS failure. The problem is, Intel RST displays all my internal drives as offline:

I'm affraid to click "Clear and reset disk" as this might cause data loss.

The thing is, I've installed Windows 7 on that external drive in the past and everything worked ok. I tried using Windows XP as it is more lightweight in terms of space used (the disk is mainly used in a media player).

So my question would be - how do I get iaStor in Windows XP to show drives correctly?

0 Kudos
2 Replies


On Windows 7 there are no issues because RAID drivers have been installed properly, this happens with Windows XP because RAID drivers have not been installed yet.

We do know that Microsoft* Windows* XP requires a floppy device to successfully load a mass storage driver during installation.

Since there are no floppy drives anymore a USB floppy drive should be used instead to successfully load mass storage drivers during the Microsoft Windows* installation process. Then again, a problem like the one you describe may occur since some USB floppy disk drive models are not supported during the Microsoft* Windows* XP installation.

This issue occurs if the USB floppy disk drive ID is not listed in the 'txtsetup.sif' file. For more details on this issue and information on compatible USB floppy drives, please refer to the following link:

http://support.microsoft.com/kb/916196/en-us http://support.microsoft.com/kb/916196/en-us

NOTE: This link is being offered for your convenience and should not be viewed as an endorsement by Intel of the content, products, or services offered there.

You can also try slipstreaming the RAID drivers to the Windows* XP installation disk:

http://www.intel.com/support/motherboards/desktop/sb/cs-028426.htm# slipstream http://www.intel.com/support/motherboards/desktop/sb/cs-028426.htm# slipstream

NOTE: Keep in mind that this is a process that Intel does not support, therefore if you need further advice about the slipstreaming process, check different online resources.

Additionally I do not recommend you clicking on "Clear and reset disk" while using XP, this could erase your data, you can confirm this by accessing the Option Rom with CTRL-I during the booting process, there you can confirm if the RAID structure is normal or not.


Dago MC.

0 Kudos

Ok, I'll go a little bit into detail.

First of all, I have slipstreamed the latest available "F6" drivers into my windows XP installation kit using nLite. I know this has worked because without these drivers slipstreamed, I would get Blue Screen with Error 0x7B (Inaccessible Boot Device) in windows setup. Only after slipstreaming those drivers was I able to continue setup and actually see my external drive in windows setup.

Because I didn't want my MBR to be modified, I installed windows XP on the external drive with my internal drives disconnected.

Once installed, I tried installing latest INF driver (success) and latest RST driver (aparently success). I then reset the computer and would not see the iaStor icon in the system tray. I reconnected the internal drives and reinstalled RST driver. At the end of the install I was informed that I was supposed to install .NET Framework 3.0. I went to Microsoft's .NET Framework website and installed the latest version - 4.0.

After rebooting, the iaStor icon was in the notification area, but it would be stuck in a state where it would have a blue orb next to it and say "Storage service is not running". Attempting to open the application or starting the service manually would result in an error.

I then installed all .NET Frameworks I could find: 1.1, 2.0, 3.0, 3.5 with all available updates. After restart, the iaStor icon was in the notification area, and have a yellow triangle with exclamation mark next to it. When I open the application, it looks like it does in the above screenshot.

It is pretty strange because installing windows 7 in the same conditions (remove internal drives, install windows 7, reconnect internal drives, install RST) worked perfectly the past three times that I needed it.

I have attempted reinstalling RST one more time (uninstall, reboot, install) on WindowsXP although the issue wasn't fixed.

0 Kudos