Rapid Storage Technology
Intel® RST, RAID
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
1809 Discussions

RST and Lenovo W series - disappearing drives

Community Manager

There is what appears to be a widespread issue with Lenovo W series laptops where, after resuming from sleep or hibernate, a second hard drive in the Ultrabay appears as ejected. Various posts on the Lenovo community website indicates this is an issue several people are experiencing.

I am also having this problem - essentially I have a pattern where when I suspend then resume the drive disappears and if I suspend/resume again the drive reappears. It consistently does it in an alternating pattern. This only happens for the second drive in the Ultrabay.

I am not expecting any definitive solution here however I would welcome any advice about how to go about debugging or diagnosing the problem? Is there any way to enable detailed logging of commands sent to and responses received from each drive? I can hear the drive powering up but then it powers down again.

I am running the latest version of the RST drivers for my series 5 controller on my W510 -, dated 19/11/2012. I am running Windows 8 64 bit.

Any suggestions would be very welcome since I and several other people on the Lenovo forums are getting no assistance from Lenovo.



0 Kudos
7 Replies

I have the exact same problem on my Lenovo T440p where today I installed Windows 8.1 64bit (UEFI).

I have a Samsung 850 Pro 256GB SSD as my primary disk and a Hitachi 500GB hard disk on the ultrabay adapter.

The Hitachi hard disk disappears/reappears at each sleep/resume cycle.

I have the latest BIOS and all the latest device drivers installed, including the Intel Rapid Storage Technology driver.

Did you find a solution for your problem?



Hello guys,

@Robert, since you have a 5 series chipset system you could try using RST version 12.0. https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=22675&lang=eng&ProdId=2101 Intel® Download Center

I suggest you to uninstall the current version from programs and features in Control panel. Then, restart the computer and install this version.

@Aslg, your computer uses 4 series chipset, so the latest RST version that can be installed is 11.7 https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=22194&lang=eng&ProdId=2101 Intel® Download Center . Please follow the same procedure I suggested to Robert.


Hi Sylvia,

thanks for the reply.

The Lenovo T440p contains an Intel Core i7-4600M Processor and, I think, a 8 series chipset. I thought I could use the latest IRST version ( here: https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=24293&lang=eng&ProdId=2101 Intel® Download Center

I installed it but it did not work. It has exactly the same problem reported by Robert.

In the Lenovo forum people is suggesting to use version but I noticed it does not support Windows 8.1 (only Windows 8). I have Windows 8.1 installed in the T440p.

The problem seems to be a bug introduced after and never corrected in the next IRST versions.

What do you recommend to do?



I confirm I have a 8 series chipset.

I went ahead and I installed the following versions of IRST:

  1. I installed and it did not work (same problem).
  2. I also tried and it did not work.
  3. I then tried and it did not work.
  4. I finally tried and it did not work.

All the above IRST versions exhibit exactly the same problem on Windows 8.1: secondary drive disappears after resume, then reappears at the next resume, and then disappears again at the next resume, and so on.


I find hard to believe that only few people have this problem. But maybe we all have something "wrong" in our configuration and there is a working configuration for the majority of others.

Maybe I should ask the opposite question:

  • Is there anyone that has the secondary drive working without any problem on Windows 8 or 8.1?

If yes, which secondary disk model do you have? Which ultrabay adapter? Which IRST version?



Aslg, since you already tried different RST versions, this definitely could be a hardware issue.

My recommendation will be to test another hard drive. I suggest you to check with Lenovo if they have a list of compatible hardware.


Hi, if your issue still hasn't been resolved, hopefully this will help:

1) Go into your BIOS, navigate to the "Power" configuration and if you see something like "Intel Rapid Start" disable it.

2) THIS IS WHAT SOLVED MY PROBLEM: On your caddy or ultrabay you will find a switch, it's very small and the location of this switch will depend on which manufacturer built the caddy/ultrabay (example of what it looks like, here: http://img.auctiva.com/imgdata/3/4/5/0/2/7/webimg/809401815_o.jpg%29, http://img.auctiva.com/imgdata/3/4/5/0/2/7/webimg/809401815_o.jpg), just slide this switch to the opposite side and push the caddy back in (make sure its fully inserted) and your issue should be resolved.

My issue was with the SSD in my caddy / ultrabay slot disappearing after waking / resuming from sleep mode. Every second sleep wake/resume or reset would solve the issue but it was really frustrating.

I have a Lenovo W540 running W8.1. Good luck!