Rapid Storage Technology
Intel® RST, RAID
1828 Discussions

Raid 1 same disks with 1MB storage difference


Here is the story.

I have an Intel computer with 2 same 256GB SSDs. Disk A is connected to SATA 0 and Disk B is connected to SATA 1.

Disk B is the system (boot) drive with Windows 7. Disk A has no partitions. I changed boot sequence into BIOS and made SATA 1 first boot.

Installed last version ( Intel® Rapid Storage Technology.

RST status shows that Disk A has 242.197MB capacity but Disk B has 242.198MB.

When I try to create a RAID 1 volume and select Disk A, Disk B gets grey and cannot select it.

And vice versa. When I select Disk B, Disk A gets grey and cannot select it.

Why ??

Why cannot create RAID 1 volume from existing drives ??

0 Kudos
4 Replies
Super User Retired Employee

Whenever you create an array, regardless of its type, the contents of the included HDDs/SSDs are lost completely.

I heard one of the ICS folks say recently that this wasn't the case. Well, *my* understanding has always been that this was *always* the case; that any array creation or deletion will result in a loss of the data on the included drives.

Ok, with this in mind... You asked the RST GUI to create an array using your two SSDs, but, since one of these SSDs is your current boot device, it is considered to be "in-use" and thus unavailable for this purpose because its contents would be immediately lost. Now, you could go into the BIOS extension (via CTRL-I) and create this array from there (because "Disk B" won't be "in-use" then) - but in so doing, remember that you will lose the contents of the partitions on your "Disk B" and thus you will need to reinstall Windows 7 from scratch afterwards.

Again, this is *my* understanding. If the ICS folks know for sure that I am wrong, I hope that they will chime in and let us know soonest!

Hope this helps; my intent is not to create friction or mislead anyone.



Sorry Mr. Pearson

I'm affraid you're wrong.

Creating the RAID from existing hard drive is possible if you are under windows environment.

You can use the Intel Rapid Storage software to manage, create and modify RAID 1.

When creating the RAID volume through CRTL-I; this for sure will erase data.

See here for Intel Rapid Storage guide (page 30, paragraph 8.2)

http://download.intel.com/support/chipsets/imsm/sb/irst_user_guide.pdf http://download.intel.com/support/chipsets/imsm/sb/irst_user_guide.pdf

This is exactly what I try to do but only ONE disk drive is selectable every time

That's my case

Anyway thank you for your reply


Finally I solved my problem myself but I don't know what's wrong.

Here is how I did that.

1. I created an image of my Disk B (boot drive) to Disk A with Acronis - so I had 2 same bootable drives

2. I changed boot sequence into BIOS and made SATA 0 first

3. Boot from Disk A

As I mentioned Disk A has 244.197MB capacity but Disk B has 244.198MB

4. Followed Intel instructions for "Creating RAID 1 from existing hard drive" keeping data from Disk A (system)

That's all.

But I don't know what's wrong.

Even that I tried to boot from SATA 1 or that I tried to duplicate a larger disk (1MB larger !!!) to a smaller ??

Never know ...

Super User Retired Employee

Thank you Panagiotis, that exactly is what I was looking for.

Of course, never trust this to work. Always make a backup. As they say - and no matter the context - a fool and his data are easily parted (and likely soon too!).