Community
cancel
Showing results for 
Search instead for 
Did you mean: 
331 Views

SSD cannot be detected under RAID mode with iRST driver

Hi there,

Our product is PCIe Gen3 x4 M.2 SSD.

We are testing upgrade SSD FW through Download microcode tool.

And we found that when our device under RAID mode with iRST driver (any kind of RAID configuration, RAID 0,1,5...all have the same issue), the download microcode tool cannot detect the SSD. The OS and CrystalDiskInfo cannot detect SSD as well. Means we can’t proceed the FW update process through the tool.

Without iRST driver, it’s normal.

And we also try on other brand’s SSD (Samsung, Phison, SMI), all of the drives can duplicate this issue.

We’d like to know that do you have any idea of this situation?

Feel free to let me know if there’s any need to be explained more detail.

Really appreciate that :)

0 Kudos
7 Replies
AndrewG_Intel
Moderator
145 Views

Hello User15773322230403027350

 

Thank you for posting on the Intel® communities.

 

We understand you are testing firmware upgrades of SSDs when those SSDs are part of a RAID configuration. Regarding your inquiries, we would like to inform you that in order to proceed with firmware upgrades the SSD must not be part of RAID configuration, meaning this, that in order to perform the upgrade on a current RAID-member SSD, it will need to be removed from the RAID structure. This is the expected behavior under RAID configurations.

 

We will share your feedback with the relevant department so they might consider any option in the future but we cannot guarantee that this capability will be implemented because of how RAID-member disks work.

 

Regards,

 

Andrew G.

Intel Customer Support Technician

A Contingent Worker at Intel

n_scott_pearson
Super User Retired Employee
145 Views

Once upon a time, the CSMI protocol was necessary to talk to RST (and especially to communicate at the physical device level). I am not sure whether this is still the case. Intel Customer Support will likely need to query the RST software team.

 

...S

145 Views

Hi Andrew, Pearson,

Thanks for both of your reply.

Maybe i should explain more detail of it.

The failure symptom not just FW upgrade tool cannot detect SSD. Even the Crystal Disk Info cannot recognize the SSD as well. Which means i cannot check the S.M.A.R.T. info of SSD under RAID mode with iRST driver.

Any other kind of detect tool cannot recognize the SSD.

We tried any motherboard/chipset, all of them can meet that issue. Also did cross validation with other brand SSD, the same situation.

Thanks again for your answer.

 

-Johnny

n_scott_pearson
Super User Retired Employee
145 Views

No, I understood what you meant the first time - and I explained why you were having problems. You need specially-crafted software, designed for the CSMI protocol, to be able to do this. I would add that this is strongly discouraged; folks should not be accessing physical drives while they are in use within RAID arrays - and they especially should not be updating firmware as this could change the characteristics of the drive. You should be removing drives from use in RAID arrays while doing anything like firmware updates. As for S.M.A.R.T., RST includes its own S.M.A.R.T. monitoring capability and will inform you of any issues developing (presuming you have the RST software installed). Also, as I said, if you want to craft support for this protocol, you need to be talking this over with the RST developers.

 

...S

Storozh
Beginner
145 Views

Hello User15773322230403027350 !

It is very strange to hear this, but it is more strange that you did not give any initial data which operation system you use, not what version Intel RAID driver from Device Manager and which version iRST is installed. From some people it is necessary to pull out additional information with ticks 😉.

n_scott_pearson
Super User Retired Employee
145 Views

Everything is presumed to be Windows 10. Windows 7 is dead, dead, dead.

 

Yes, getting the necessary information is sometimes like pulling teeth (or herding cats).

...S

145 Views

Yeah, it's Windows 10, obviously.

As for the motherboard/chipset, i tried any of them can meet that problem.

i'll check the RAID driver and version then provide to you guys.

Thanks!

Reply