Community
cancel
Showing results for 
Search instead for 
Did you mean: 
PCutt
Beginner
2,610 Views

Second HDD not detected in Windows

I have an Asus ROG GL503VM laptop with an SSD as the boot drive and an HGST mechanical HDD as a secondary data drive. The second HDD was detected for about a day out of the box but disappeared from Windows after OS and BIOS updates. The drive is visible and works fine when I boot to Linux and shows up in the BIOS, but nothing I have tried has restored its availability in Windows. I am not configured for RAID but Intel RST was the SATA mode selected by OEM presumably because it is supposed to help SSD performance.

To be clear, it is not visible in Device Manager, Disk Managment, or when listing disks in diskpart. It is formatted NTFS with one partition and It is visible in the BIOS and in Linux.

I have tried converting to AHCI mode and reinstalling Windows, updating and running several versions of the RST driver, and updating and downgrading the BIOS several times. I pulled the HDD out and put it in an external enclosure and the drive works fine in Windows externally. I put another HDD in the laptop and have the same problem. Again, I have no problem using the second HDD in Linux. It is just a Windows problem.

I have run diskpart, run the clean command, deleted and recreated partitions, you name it while externally connected and when booted to Linux. This is by far the most difficult nonsensical problem I have yet to resolve. It appears to be driver related.

Asus wants me to RMA the laptop for what appears to be a software problem. HGST is pointing the finger at Windows, and I have yet to get any feedback in Microsoft forums.

Any ideas? Having a 1TB inaccessible drive is extremely frustrating!

Thanks,

Patrick

0 Kudos
4 Replies
idata
Community Manager
586 Views

Hello pcuttle,

 

 

Thank you for joining the Intel Community Support.

 

 

I can see that you have taken several troubleshooting steps to resolve this issue. Please allow me to gather basic information to check what the root of this issue may be.

 

 

If the Intel® Rapid Storage Technology (Intel® RST) is already installed in your computer, please run the system report for this tool and attach it to the thread. To save a system report, follow these steps:

 

 

1.Open the Intel Rapid Storage Technology user interface (Start > Programs > Intel > Intel® Rapid Storage Technology).

 

2.Click the Help icon.

 

3.Click the System Report icon.

 

4.Click Save.

 

 

If the Intel® RST is not installed, please intall it and run the report. I found the version of the Intel® RST provided by your system manufacturer in case you need it.

 

http://dlcdnet.asus.com/pub/ASUS/nb/DriversForWin10/IRST/IRST_B_Intel_kabylake_Win10_64_VER15701014....

 

 

Even though you do not have RAID configured in your system, the report may shed light on this issue as well.

 

 

Wanner G.
PCutt
Beginner
586 Views

Wanner,

System Report

System Information

OS name: Microsoft Windows 10 Home

OS version: 10.0.17134

System name: DESKTOP-DN3R14I

System manufacturer: ASUSTeK COMPUTER INC.

System model: GL503VM

Processor: GenuineIntel Intel64 Family 6 Model 158 Stepping 9 2.801 GHz

BIOS: American Megatrends Inc., GL503VM.311

PCH: 0xA152

Intel® Rapid Storage Technology enterprise Information

Kit installed: 16.0.2.1086

User interface version: 16.0.2.1086

Language: English (United States)

RAID option ROM version: 15.5.0.2858

Driver version: 16.0.2.1086

ISDI version: 16.0.2.1086

Storage System Information

RAID Configuration

Hardware Information

Controller name: Intel(R) Chipset SATA/PCIe RST Premium Controller \\Scsi0

Type: SATA

Mode: RAID

Number of SATA ports: 2

Number of volumes: 0

Number of spares: 0

Number of available disks: 1

Rebuild on Hot Plug: Disabled

Manufacturer: Intel Corporation

Model number: 0x282A

Product revision: 49

Direct attached disk: 171521802251

Disk on Controller 0, Port 0

Status: Normal

Type: SATA SSD

Location type: Internal

Usage: Available

Size: 119 GB

System disk: Yes

Disk data cache: Enabled

Command queuing: NCQ

Transfer rate: 6 Gb/s

Model: SanDisk SD8SN8U128G1002

Serial number: 171521802251

SCSI device ID: 0

Firmware: X4131002

Physical sector size: 512 Bytes

Logical sector size: 512 Bytes

Empty port

Port: 2

Port location: Internal

Thanks for the reply and the link to the driver. I failed to mention that I already installed that version, without luck, so I updated to the latest version available from Intel. I also failed to mention some of the other more technical things I have actually tried such as modding the AMI BIOS with updated RST driver module. However, I have been unable to flash it since it is unsigned by ASUS.

As you can see, the second HDD is not even seen. Earlier today, I booted to Linux, repartitioned the HDD as MBR vice GPT and the drive was visible in windows and the IRST utility on Port 2, but again disappeared after rebooting. I repeated the process with no luck. Happy feeling only lasted briefly!

Thanks,

Patrick

idata
Community Manager
586 Views

Hello pcuttle,

 

 

According to all the information provided, your HDD should be detected in Windows. There seems to be nothing unusual in your system configuration that may shed light on this issue. Regarding the Intel® RST, you have even installed different versions of the tool and because you have not configured RAID in your system, it should not impact your system negatively. If possible, you can check for a firmware update.

 

 

Our recommendation is that you can get any feasible troubleshooting step from your computer and operating system manufacturer. If you do, please share any updates with us for future reference, too.

 

 

I look forward to hearing from you.

 

 

Wanner G.
PCutt
Beginner
586 Views

Wanner,

After following some recommendations from other support forums, I ran a HDD SMART utility in Linux that provided a detailed report for the HDD. The error log showed over 2600 UDMA CRC Count errors and research on that error suggested a bad SATA cable. I am currently trying to get Asus to send me a replacement cable.

Thanks for your assistance and I'll let you know how things work out following the cable replacement.

Patrick

Reply