Rapid Storage Technology
Intel® RST, RAID
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
1814 Discussions

Smart Response working with Caviar Black 1TB, not with 2TB

Community Manager

Hi, I have been successfully running Intel Smart Response Technology version on a Gigabyte GA-Z68X-UD3H-B3 board with a Core i3-2120 processor and Windows 7 Pro 64-bit. I have a WD Caviar Black 1TB drive and an OCZ Agility3 60GB SSD with firmware 2.25. I recently upgraded the machine to a Caviar Black 2TB drive by cloning the drive using the Acronis WD edition clone tool. However, SRT refuses to start with the 2TB drive. The partitions all appear to be correctly created, and the drive does not have any physical problems (bad sectors) as it's brand new. I verified that it can accelerate another drive on the system (a Seagate 1TB), so it does not appear to be a software, driver, or configuration issue. I also swapped the 1TB drive back in and was able to accelerate it with no problems. I also tried the latest versions of the RST driver, up to the current one, and nothing I have done will get it to work. When it fails to configure with the newer versions of driver, it complains that the operation failed, but gives no suggestions. Sometimes it says to try restarting, sometimes not.

The errors that show up are:

An error occurred while an operation was in progress. The operation could not be completed.

An error occurred and the selected disk or volume could not be accelerated. Please restart your computer, and then try the operation again.

I am ready to try reinstalling Windows and all of the applications on the new drive, but I don't want to spend the time to do this without a reasonable idea that it will actually fix the problem. Does anyone have any suggestions or experience with this problem?

0 Kudos
2 Replies
Community Manager

I suppose anytime some mentions "cloning" in reference to Windows 7, I immediately get a little nervous.

Are you showing the same drive letters as the old system, like is C: still the OS partition?

Is there some reason you did not just image the drive with the Windows 7 Backup and Restore utility then restore that image to the new drive?

If you are going to keep your current configuration, perhaps disassociating the SSD or setting it to available might allow you to reconfigure the array with the new drive.

Community Manager


The new drive shows the same letter (C:) as the old one. It boots and seems to run everything fine. I had to reauthorize a few applications, but that seems to be common when you change drives. I used the Acronis/WD utility to move some XP systems to new drives with no issues.

I did not really think of using the Windows utility to do this, but that may be worth a try. I am thinking the WD drive cloning created something weird with the file system or underlying structure that is keeping SRT from accelerating the drive.The drive does not use advanced formatting, so that's not it either.

I may try the Windows system image backup to a spare HD, wipe and install Win7 again, and then try accelerating the fresh copy. If that works, I can try restoring the image and see if it still works.

I also tried marking the SSD as available, spare, doing a clean erase with the OCZ drive utility, re-enabling acceleration, etc. I am also running the same version of RST ( on both drives to reduce the variables.