Rapid Storage Technology
Intel® RST, RAID

Unable to build a Raid 5


Hi all,

I've spent about 2 days on this without success so hoping someone will be able to help.

I have a HP z400 workstation ( motherboard is an intel x-58, with a controller ICH10R/DO ) and I'm trying to build a RAID 5 with 4x4TB seagate ironwolf HDDs. I have installed the OS ( Windows 7 Pro ) on a SSD . There are no extra raid controller/cards, only using the one on the mobo.

The issue i'm encountering is as follow:

At the boot, the Intel Matrix strorage manager rom allows the creation of a RAID 5, but only detects 1.6TB per HDD, limiting me to approx 5TB for the array.

In windows, the HDDs are recognized as full 4TB drives, but the Intel Rapid storage software doesn't allow me to create a Raid 5 ( I can create 0, 1 or 1+0 , but not 5, it's grayed out ) and when I look at the documentation, it is supposed to be supported, and I meet all the requirements listed in the help section.

Any driver or software update that could help?, i did try all the 'official' ones of the hp support website... maybe a specific version not signed by HP? a specific version of the intel software? or will i need to buy a raid card? and will that even work?

Thanks in advance


0 Kudos
3 Replies

Hello Joce,



Thank you for contacting Intel® technical support. I will be more than happy to help you.



I understand that you are having issues creating a RAID 5 volume in your system.


Regarding the size detected for the drives, this is happening because there is a chipset limitation that will allow you to use only up to 2 TB under special circumstances like this one.



To create a RAID 5 volume in your system, I would recommend you not to do it with Intel® Rapid Storage Technology. Please do it with Intel® Matrix Storage Manager, which is fully compatible with your chipset. If necessary, please update this tool. You can download the latest version using the next link: https://downloadcenter.intel.com/download/17882



As a possible workaround, you can try to create the RAID 5 volume using the Intel® Option ROM tool. To access this tool, reboot your computer and press CTRL+I when requested.






Xavier A.
0 Kudos
Super User

I have the following comments:

  • You are aware of the fact that the applicable SATA ports on the X58 ICH are only SATA II (3Gb/s) capable, right? It is possible to get add-in RAID cards that will provide SATA III (6Gb/s) performance.

  • Your motherboard may provide additional SATA (or eSATA) connectors. You cannot use these for RAID. I am just saying, make sure you are using the right connectors. If your board doesn't have any others, no need to react to this comment.

  • In order to use drives that are larger than 2TB - and be able to use the RAID Option ROM to create RAID array(s) - you must enable UEFI support in the BIOS. Now, doing so will also likely require that you reinstall Windows 7 (so that it can be booted in UEFI mode). In this case, during the Windows 7 installation process, make sure you delete *all* partitions created on your SSD so that its partition table can be recreated using UEFI (GPT) partitioning.

[Aside: For safety, I *always* delete all partitions and then tell the Windows installer to install to the drive's free space (which is all of the drive at this point). This allows the Windows installer to own the partition creation process and control the number and size of the partitions it creates.]

  • It is unclear (to me) why it denied RAID5 array creation at runtime. This may be because of the (non-UEFI) limitation at the BIOS level - and I agree that this doesn't make sense - but, well, sh1t happens...

Hope this helps,


0 Kudos

HI Scott,

for the points you mentionned...

- Yes I am aware of the SATA II limitation of the board, it's a pity that it doesn't have SATA III, but performance isn't really bothering me. I mainly wish for a minimum of redundancy, but I can't afford to make it a RAID 10...

- I have verified the ports, and made sure they are all on the same controller, not dedicated to eSATA or anything else, even tried to change the ports in case I was wrong, ( did port 0 to 3, and 2 to 5 ) , went in the BIOS as well and made sure they were all set the same.

- for the 2 versions of RST , I tried so many, I passed though the ones HP had, and some from intel, I will give it a go as well as those given by Xavier in the earlier post.

- there are no UEFI options in the BIOS ( some motherboard have a 'compatible' mode for it, or simply straight up switch to UEFI, but this one doesn't seem to have it )

Yes it is a sh*tt* situation, as it is supposed to be compatible, I also switched over to a Windows 10 yesterday, hoping this might help, but for now, the same issues persist.

I'll make some more tests tonight,


0 Kudos