Rapid Storage Technology
Intel® RST, RAID
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
1814 Discussions

Which IRST RAID driver will let me load Windows 8.1 Pro 64-bit on Asus Z97-WS and RAID 1 array?


I have assembled a computer from new parts, including an Asus Z97-WS motherboard (Intel Z97 chipset) and two Western Digital VelociRaptor 1TB (WD1000CHTZ) hard disk drives. I have set the BIOS to RAID, and with IRST created a RAID 1 volume using the two hard disk drives. The drives are plugged into the SATA ports on the motherboard controlled by the Intel chipset.

When I try to load Windows 8.1 Pro 64-bit, at what used to be the F6 stage, where one loads RAID drivers, I cannot find an IRST RAID driver that Windows will recognize as a proper driver. I often get the error code 0x80300001. Without the proper driver, Windows does not recognize the RAID volume as a bootable device, and therefore refuses to install Windows on it.

I have tried every driver on the disc that Asus supplies with the MB, the latest drivers from the Asus website, and every latest/current Intel IRST RAID driver I could find on Intel.com. None permits me to load Windows on the RAID array. POST sees both drives, and I could load Windows to either drive as a lone drive (after breaking the RAID array). IRST says the array is normal and bootable, though BIOS does not recognize the array as a bootable device--which is natural, since I haven't found a driver for it yet.

I would GREATLY appreciate a solution to this problem.

Thank you,


0 Kudos
6 Replies

Hello Eric, thanks for contacting us through the Intel Communities.

Regarding your situation I would like to inform you that Windows 8.1 comes with preloaded F6 drivers, therefore it is not necessary to install any. You just need to run the RST executable file

The driver version of the software that you need to install on this board is 12.9. So please try installing the following https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23496&ProdId=2101&lang=eng Download Center

If you continue having issues, I suggest you to delete the RAID and install the operating system in only one hard driver (no RAID set up).

The hard drives needs to be on RAID ready. Once you are able to install Windows 8.1 in the hard driver, you can create the RAID array on Windows.


Sylvia; I have a MSI Z97 Gaming 7 Mobo with a Core I7 4790K running Win 8.1 loaded on a SSD. I just updated to this Mobo and CPU configuration. I've done a clean install of Win 8.1. I have four HHD's that I am trying configure for RAID usage. My problem is that when I set the BIOS SATA mode to RAID, Win 8.1 will not completely load. I am able to create a RAID Volume in the IRST with no problem. During boot however, Win 8.1 tries to load, but after a few secs, a message flashes across the screen to the effect Windows has encountered a problem and will reboot. Since my problem sounded a little like Eric's, I downloaded the driver you recommended for Eric, but I got a "Platform Not Supported" message. There is no RAID driver showing up in Device Manager all be it I can only see the Device Manager when in ACHI mode so maybe the RAID driver doesn't show up unless in RAID mode?. So that may be normal. I've ran the Intel Driver Update utility, which didn't report any out of date drivers. I also loaded what are supposedly the latest SATA/RAID drivers from MSI. I also updated the BIOS to the latest version. I've noticed that just setting the SATA Mode to RAID without creating a RAID volume causes the same problem. The SATA ACHI driver is Version 13. 1.0.11058. Don't know if the RAID driver would be the same version. If it is normal for the RAID driver not to show up in the Device Manager unless in RAID mode, how do I know if one is loaded at all? I've seen some suggestions that you have do the Win 8.1 install in RAID mode to get the RAID drivers installed, but don't know how that works works.

Any help would be greatly appreciated.


Hello Eric,

I followed Sylvia_intel's suggestion and succeeded, clarifying related mysteries along the way: now I have a SSD boot drive for Win 8.1 and apps, AND a multi-terabyte RAID 1 volume accelerated by a 64gb SSD m.2 cache. These instructions are stated so that you can also end up with Windows 8.1 installed on your RAID volume, provided that (unlike me) you figure out how to initially clean-install Windows 8.1 on a multi-terabyte drive to end up with the four recommended GPT partitions:

1, Set your BIOS to RAID and only connect ONE (boot)drive on which you will install Windows 8.1 (Pro 64-bit here too). I left my SSD boot drive empty and uninitialized: Win 8.1 upgrade/OEM DVD initialized it to a MBR partition style with 350 MB active system partition and the OS(C) boot partition filling the rest of my (120-230gb) SSD boot drive.

2. Boot into your clean-installed Windows 8.1 and in Computer Management/Device Manager/Storage Controllers you'll find Intel(R)... SATA RAID Controller instead of ... AHCI Controller drivers(per Sylvia).


Load the basic chipset drivers (and AI Suite 3, for Asus), and consider BIOS update to latest (Asus) recommended BIOS.

3. Get the latest (Asus) recommended Intel RST, e.g., Intel_RAID_Win7-8-8-1_VER13031001.zip from (Asus) support/downloads for your motherboard, and install it in Win 8.1(./Intel/Install/AsusSetup.exe).

4. I had to reboot and fiddle around for Intel RST to launch and say "boo": pin it to task bar, click right to Properties/Compatability, Run in compatibility mode for Windows 8, Change settings for all users), Oh, did I mention installing "Start Menu 8" to keep Windows 8.1 Metro from driving me insane?

5. NOW you can shut down and install the additional drive(s) for your RAID volume. For Raid 1 you may have OS and/or data already on one drive; clean and initialize the other drive with the same partition style (MBR or GPT). Then bring up Intel RST app to build your RAID volume: it will copy data from the one that has partitions on it, if one of them does.

6. Next morning the RAID volume is ready to rename and configure. I shut down and installed a 64gb caching SSD (ZTC-SM201-064G) into the motherboard's m.2 slot, initialized it to an empty MBR drive, and Intel RST guided me through setting it up as a 60gb accelerator cache for my RAID 1 volume.(Transcend's N8S750 is also entering supply chain.)


I was relieved to find that Intel RST "volume" refers to the RAID, and can have as many OS "partitions" as I wish; likewise relieved to find that having two SSDs, one two-drive RAID 1, and one SATA CD/DVD combo drive does not exceed Intel's "four volume" limit, and that I can (but need not) offload the CD/DVD combo drive onto a "for data drives only" ASMedia SATA controller– and boot from it! Apparently ASUS user manual means only to say that your normal boot drive or volume should be on the Intel (AHCI or RAID) controller (to keep Win 8.1 happy without F8?)


Hope this helps!


Re Step 1 (a wee bit off-topic: UEFI installation of Windows 8.1 fails in some UEFIs) I found and reported a bug in Asus Z97 UEFI BIOS v. 1008 (05/29/2014): it does not permit installation of a standard/OEM Win 8.1 .iso on a GPT drive, which you'll need to do if your boot drive is > 2TB. Problem: Win 8.1 .iso necessarily contains both bootldr and bootldr.efi files. Even if you F8-boot Win 8.1 DVD with UEFI(FAT)OpticalDrive and select a GPT-initialized target drive, UEFI BIOS 1008 sees the bootldr file and runs it (failing in Setup) without first checking for bootldr.efi and running it. I resolved this problem by creating a GPT USB (FAT32) flash drive and simply deleting the bootldr file(cf.http://tipsandtricksforum.com/thread-245.html How to create UEFI bootable USB to install Windows 8.1). Now I have UEFI boot SSD for Win 8.1+Apps: several advantages over MBR-formatted boots! BTW: if your target drive is already GPT-initialized, ignore Microsoft's OEM-warning that the partition order is not the recommended one: you'll get the same GPT partition-order as for an uninitialized installation drive: 300 MB NTFS MS Recovery, 100 MB FAT32 EFI System, x GB NTFS (C:)


I'm having the same problem as HoJo. I have a Gigabyte Z97X-UD3H with a Crucial 256GB SSD on which I have installed windows 8.1 Pro 64 bit. Everything has been working fine for many months with the bios set to ACHI mode. Now I want to add a RAID 1 with (2) 2TB disks. I set the bios to RAID, create the volume and try to boot into windows. As Windows 8.1 tries to load a message flashes then the system reboots. If I set it back to ACHI everything is fine, but I can't use RAID.I have tried the latest version of the IRST and also with the same result.

Thanks in advance for your help.


Rwin, if you change the SATA mode in BIOS from AHCI to RAID, it will be necessary to reinstall Windows.

Please check this thread