Rapid Storage Technology
Intel® RST, RAID
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
1808 Discussions

intel RST raid 1 preserve data greyed out


Hello, at the moment i'm bit frustrated, my situation looks like this:

1. i had intel RST raid 1 (seagate 1TB constelletion x 2 ) setup (in bios set Raid and intel RST), raid 1 was working, but both DRIVES started to fail (realocated sector count and other smart errors).

2. I bought new 4TB seagate raid disks

3. I removed one old 1Tb hard drive and put in new 4TB hard drive and marked as spare, raid rebuilded with new and old drive

4. i removed 1Tb hard drive and resseted 4Tb drive from CTRL-I as non raid drive

5. i streched 4Tb raid drive to maximum in disk management (because it is MBR-NTFS not GPT it's not bigger than 2TB...), for now 2Tb enough later i will reinstall server to 4TB and GPT, but i dont know how to proceed...

6. i updated server firmware to latest (intel server board 1200bt), and the installed latest intel RST software.

what i wan't to accomplish is create RAID from intel RST raid 1 preserving data

but how You see this option is greyed out...

And here is screenshot of disk management (i deleted other backups disks to better understand):

if anyone would advise me, what to do? How to build raid1 with preserving data?

Should i backup everthing and reinstall windows server with GPT partitions, and then how to restore everything as it was?

And here is screenshot from CTRL-I (it was taken before i upgraded intel RST software)

Thank You in advance...

0 Kudos
6 Replies

Hello KrabisLV,

At this point you reached the Desktop Intel® Rapid Storage Technology support. On Desktop platform you need to enable at the BIOS level the UEFI so you can have HDDs of 4TB.

Perhaps this requires a different configuration for Server Platform So I will move your post to Server Team so they can check on this.

Kevin M


Let me provide some assistance.

I noticed that your Disk 1 contains a Primary partition. Have this drive being used in the past? If so, would it be possible to delete the volume and try again.

I would probably consider backing up the data and consider using GPT installation to be able to use the entire drive capacity.

Feel free to contact our http://www.intel.com/p/en_US/support/contactsupport Intel Customer Support team for proper walk through of this process.


Hello, thank You for answer.

What i did:

1. i had set up of olds disks 2x1Tb (they had bad blocks)

2. i purchased new 4TB disks, and then removed one disk from my old setup and added new disk

3. intel RST asked me to rebuilt to new disk (it rebuildes succesfully now i had one old disk 1Tb and new disk 4TB)

4. i removed old disk 1Tb and then resetted disk in CRTL-I to no raid disk (i needed to strech partition wider...)

5. Then i streched partition and added 2nd new 4Tb disk

what i need to do:

1. for now, i want to rebuild raid 1 (with both new drives)

2. it does not allow me to preserve data

i'm not worrying about space 4TB, later this year i will need to reinstall server, for now i have enough space...

Can anyone plz help me to preserve data and rebuild raid 1 ?

what information do i need to supply to help You?


Can you try to make the system partition smaller than 2TB and then attempt to create the array again? If same results; then, due to the extensiveness of the process I would recommend contacting our http://www.intel.com/p/en_US/support/contactsupport Intel Customer Support team to provide a walk through support for this process.


Hello, Yes i tried to shrink system and Data partition by 2GB, but still no option to preserve data.


I noticed that both partitions combined are larger than 2TB. C: drive (200.37GB), and D: drive (1845.53GB). I would probably considering shrinking your D drive as it has 66 % free space. You might additionally delete the volume for your F: drive and compare results.

If this does not resolve this, I would need to ask you to open a ticket with our http://www.intel.com/p/en_US/support/contactsupport Intel Customer Support team as we might need to escalate this issue.