Server Products
Data Center Products including boards, integrated systems, Intel® Xeon® Processors, RAID Storage, and Intel® Xeon® Processors
4851 Discussions

Display issues with Intel S1200v3RPS board running Ubuntu 14.04


This was going to be just a standard install or so I thought...

All went well until I start the Unity desktop and it is awfully slow.

Monitor settings in Unity display settings show max option of 1280 x 1024 when the monitor is capable of much higher resolution.

Installed the Intel Graphics drivers for Linux from

Tried multiple monitors just to be sure that the problem was not with the monitors.

Really need to resolve this issue.

Do I need to install any monitor drivers for Samsung? The same monitors (I tried two different ones) work fine on the same version of Ubuntu on a low-end Intel motherboard.

I think the problem is specific to S1200v3RPS, the onboard graphics controller, or some such issue. Big question is: What am I missing?

0 Kudos
2 Replies

Does this only happen under Unity desktop? How you tried other Desktop-modes to compare results?

I just installed 14.04 on one of our systems and it seems to be working fine. I added KDE desktop and it works fine with it, too.

I could not find previous reports from customers with this issue. While researching on this, I noticed some users have use the "unity –replace" command or the "setsid unity" command.

At the moment of the test I only had a 19 inches LCD which maximum resolution was 1280x1024. I will update this once I get another monitor to test with.


I tried only with Ubuntu and Unity desktop. After some research I found that the problem has been detected earlier and documented properly. See for details. I do get it working at 1280x1024 but cannot increase the resolution and any display refresh is clearly shaky, to say the least. Very slow... The problem is with the video controller on the motherboard: Matrox g200...

I think that it is a shame that this bug continues... The Intel low-end motherboards from the S1200v3RP family is a very economical solution for those who can put a Linux server together on their own. Of course, one would not use any desktop for a true server but even as a development platform for the 4th generation Intel i3 processors, this is a good motherboard. A desktop is a must there... So I hope that this bug/issue is resolved at the earliest. Something that is now clearly an Ubuntu issue - or so I think. Unless the Intel display drivers project for Linux Intel(R) Graphics Installer 1.0 for Linux* | Linux Graphics handles this fix...

One can hack into the X windowing code and get it fixed but that would not be a permanent solution...

Please share your thoughts... I am a bit rusty with my Linux internals...

0 Kudos