Server Products
Data Center Products including boards, integrated systems, Intel® Xeon® Processors, RAID Storage; and Intel® Xeon® Processors
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
4297 Discussions

HD Problem with Modular Server - corrupted data

idata
Community Manager
1,092 Views

Hi Folks,

I have a problem with a modular Server combined with Windows Server 2008 R2.

The raid looks fine in the web control center of the modular server. No corrupted HD's or whatever.

But the drives (formated with NTFS) itself seem to look good after reformatting and reboot. But as soon as I stuff data on it the start showing disc errors on Windows boot and CHKDSK is crashing the data complete after restarting the mashine. This happens only on the data lun.

How can that be?

Fortunately we have a backup of the data, but when restoring the data it only requires a new system boot or a "check drive" with windows onboard programs and the data is corrupted again.

Any ideas?

0 Kudos
3 Replies
Edward_Z_Intel
Employee
66 Views

What's your RAID configuration? Are the OS LUN and data LUN in the same storage pool? What's the brand/model of your HDDs? It's highly recommended to use HDDs in the http://www.intel.com/support/motherboards/server/MFS5520VI/sb/CS-030301.htm Tested hardware and operating system list (THOL).

idata
Community Manager
66 Views

Dear Edward,

thanks for your quick reply.

System and storage pools are separated.

In the data pool we have 7 LUNs and only two have these problems.

The have started to change the hard drives from Toshiba to Hitachi after 4 have been marked as defect in a very short time. This was also recommended by our german support company Thomas Krenn (the also delived the new hard discs) - we are also in direct contact with them, but we still have no solution.

Last night we shut down all of the servers and disconnectde the Storage Controller. After reinserting it the controller the system came up again, but with the same errors as before.

Tonight we are planning to delete the LUNs and recreate them. (Of course we don't want to try that during wokring hours.)

Another strange effect we had last night:

I formated one of the LUNs with NTFS,

chkdsk did not show any errors until we restored the data from tape ( data files only .. not sectors or so) chkdsk showed errors on the drive again.

(Ok, we thought that might have been the problem ... but !!!)

Than I copied the data from the LUN to a SAN. Chkdsk on SAN = no errors

reformattnig defective LUN & copy back data from SAN

drive ok

reboot of server using these drives showed automated chkdsk again with the same errors as before

result ... data broken. Same error as before !

And like I mentioned before. The Modular Server shows all hard discs as fully functional (including two spares)

If you have any ideas .. please let me know.

Edward_Z_Intel
Employee
66 Views

Have you tried to upodate the storage driver on your compute modules? Is it a single or dual storage controller configuration?

Reply