Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
2,878 Views

Intel SRCSASRB Raid controler managing software on Ubuntu server

Hi

 

First: I know that Ubuntu is not officially supported, but my questions are not Ubuntu specific.

 

I currently try to install the Raid Web Console 2 software on an Ubuntu server for remote administration.

My Steps was:

convert the "RAID_Web_Console_2-3.04-05.noarch.rpm" to "raid-web-console-2_3.04-6_all.deb" with alien (>sudo alien --scripts RAID_Web_Console_2-3.04-05.noarch.rpm)

installed libstdc++6 from the ubuntu repositories

installed the "raid-web-console-2_3.04-6_all.deb" file

 

This works fine, but now I have some problems.

For remote managing two daemons must be started:

/etc/init.d/vivaldiframeworkd start

/etc/init.d/mrmonitord start

 

First I have modified /etc/init.d/vivaldiframeworkd (changed directory of the jre and modiefied the for loop syntax)

/usr/local/RAID0 Web Console 2/Framework/startup.sh changed directory of the jre)

/usr/local/RAID0 Web Console 2/Framework/shutdown.sh changed directory of the jre)

After that "vivaldiframeworkd" seems to work. Don't know how to test it, but "ps aux" gives me:

root 28446 0.0 0.0 3944 568 pts/0 S 10:18 0:00 sh /usr/local/RAID Web Console 2/Framework/startup.sh

 

root 28448 2.8 0.8 2316520 70808 pts/0 Sl 10:18 0:01 /usr/bin/java -classpath ../jre/lib/rt.jar:../jre/lib/jsse.jar:../jre/lib/jce.jar -Djava.library.path=. -jar Framework.jar

 

I think it works

 

Next is "/etc/init.d/mrmonitord start". Here is my main Problem. The startscript writes an error:

> cat /var/log/mrmonitord.debug

> /etc/init.d/mrmonitor: 49: /usr/local/bin/mrmonitord: not found

 

If I start "/usr/local/bin/mrmonitor" directly I get:

> /usr/local/bin/mrmonitord

 

> -bash: ./mrmonitord: No such file or directory

 

> ls -alhs /usr/local/bin/

> 4,0K drwxr-xr-x 2 root root 4,0K 2009-09-28 16:59 .

 

> 4,0K drwxr-xr-x 11 root root 4,0K 2009-09-28 16:59 ..

 

> 1,3M -rwxrwxrwx 1 root root 1,3M 2009-05-14 11:34 mrmonitord

 

Can anyone say me what this message means? mrmonitord is there (ls confirms this).

I don't understand why there is an "No such file or directory" error. Does mrmonitor open an File which is not on the right place?

 

Thanks for help in previous

 

Keros
0 Kudos
7 Replies
Highlighted
Employee
17 Views

Good news - you're on the right track. That's exactly what the message means. Even though mrmonitord is present, it's calling for some other file which isn't.

Bad news, I don't know of any easy way to fix it. Unfortunately, that's one of the downsides of compiling on unsupported OSes. You might try posting this to the server group at http://communities.intel.com/community/openportit/server/ask?view=discussions

0 Kudos
Highlighted
Community Manager
17 Views

Hi keros

I have the Same problem with /etc/init.d/vivaldiframeworkd

can you post youre changes? i do not know what to do...

0 Kudos
Highlighted
Beginner
17 Views

I was in the same boat, and I now have mrmonitord running.

First clue was that mrmonitord is a 32-bit ELF binary and I am installing it on a AMD64 system

root@athena:/# file /usr/local/bin/mrmonitord

/usr/local/bin/mrmonitord: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.2.5, stripped

solution to this was to install the 32-bit compatibility libraries - ia32-libs

Next problem was that it is missing some shared libraries, namely libstdc++5.

root@athena:/# ldd /usr/local/bin/mrmonitord

linux-gate.so.1 => (0xf776b000)

libdl.so.2 => /lib32/libdl.so.2 (0xf7755000)

librt.so.1 => /lib32/librt.so.1 (0xf774c000)

libpthread.so.0 => /lib32/libpthread.so.0 (0xf7732000)

libxerces-c.so.28 => /usr/lib/libxerces-c.so.28 (0xf7323000)

libstdc++.so.5 => not found

libm.so.6 => /lib32/libm.so.6 (0xf72fd000)

libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf72df000)

libc.so.6 => /lib32/libc.so.6 (0xf719a000)

/lib/ld-linux.so.2 (0xf776c000)

libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf70a8000)

Now, you need to install the 32-bit version of the library under /usr/lib32. I just downloaded a debian package and extracted the files manually. Now my mrmonitord seems to work.

root@athena:/# ldd /usr/local/bin/mrmonitord

linux-gate.so.1 => (0xf7781000)

libdl.so.2 => /lib32/libdl.so.2 (0xf776b000)

librt.so.1 => /lib32/librt.so.1 (0xf7762000)

libpthread.so.0 => /lib32/libpthread.so.0 (0xf7748000)

libxerces-c.so.28 => /usr/lib/libxerces-c.so.28 (0xf7339000)

libstdc++.so.5 => /usr/lib32/libstdc++.so.5 (0xf727f000)

libm.so.6 => /lib32/libm.so.6 (0xf7259000)

libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf723b000)

libc.so.6 => /lib32/libc.so.6 (0xf70f7000)

/lib/ld-linux.so.2 (0xf7782000)

libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf7004000)

0 Kudos
Highlighted
Community Manager
17 Views

I faced the same problem, with Ubuntu Server 10.04 on an Intel machine. The solution is basically the same, although the various libraries that needed to be found were different. Here is my walk through:

INTEL RAID Web Console 2, for Ubuntu Server 10.04 LTS, Intel machine. >> Make sure Java JRE is installed.>> Make sure Gnome is installed. >> Download WebConsole 2 from INTEL, unpack into directory of your choice >> Install utilities: sudo alien -k --scripts Lib_Utils-1.00-08.noarch.rpm sudo alien -k --scripts Lib_Utils2-1.00-01.noarch.rpm sudo dpkg -i lib-utils_1.00-08_all.deb sudo dpkg -i lib-utils2_1.00-01_all.deb >> Install libstdc++6 if it isn't already there. sudo apt-get install libstdc++6 >> Install main RPM sudo alien -k --scripts RAID_Web_Console_2-8.05-04.noarch.rpm sudo dpkg -i raid-web-console-2_8.05-5_all.deb >> This will throw errors of various kinds. Don't worry about it. Selecting previously deselected package raid-web-console-2.(Reading database ... 98178 files and directories currently installed.)Unpacking raid-web-console-2 (from raid-web-console-2_8.05-5_all.deb) ...Installing....Setting up raid-web-console-2 (8.05-5) .../home/joe/WebConsole/home/joe/WebConsole/home/joe/WebConsole/etc/init.d/vivaldiframeworkd: 26: Syntax error: Bad for loop variableStarting Monitor: /home/joe/WebConsole /home/joe/WebConsole/var/lib/dpkg/info/raid-web-console-2.postinst: line 217: jre/bin/java: No such file or directory/home/joe/WebConsole./popup: 4: ../jre/bin/java: not found Processing triggers for ureadahead ...Processing triggers for libc-bin ...ldconfig deferred processing now taking place >> Get more libraries sudo apt-get install ia32-libs >> check the mrmonitord to see what libraries are missing: ldd /usr/local/bin/mrmonitord linux-gate.so.1 => (0xf776e000)libdl.so.2 => /lib32/libdl.so.2 (0xf7753000)librt.so.1 => /lib32/librt.so.1 (0xf774a000)libpthread.so.0 => /lib32/libpthread.so.0 (0xf7730000)** libxerces-c.so.28 => not foundlibstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf763a000)libm.so.6 => /lib32/libm.so.6 (0xf7614000)libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf75f5000)libc.so.6 => /lib32/libc.so.6 (0xf749a000)/lib/ld-linux.so.2 (0xf776f000) >> Get the library manually wget http://http.us.debian.org/debian/pool/main/x/xerces-c2/libxerces-c28_2.8.0-3+lenny1_i386.deb http://http.us.debian.org/debian/pool/main/x/xerces-c2/libxerces-c28_2.8.0-3+lenny1_i386.deb >> Extract it locally mkdir libxerces-extractsudo dpkg -x libxerces-c28_2.8.0-3+lenny1_i386.deb libxerces-extract/cd libxerces-extract/usr/lib/ joe@udp011919uds:~/libxerces-extract/usr/lib$ lslibxerces-c.so.28 libxerces-c.so.28.0 libxerces-depdom.so.28 libxerces-depdom.so.28.0 >> Copy it into lib32: sudo cp libxerces-c.so.28.0 /usr/lib32/libxerces-c.so.28 >> Try invoking mrmonitord, then see what is missing again joe@udp011919uds:~/libxerces-extract/usr/lib$ /usr/local/bin/mrmonitord /usr/local/bin/mrmonitord: error while loading shared libraries: libicuuc.so.38: cannot open shared object file: No such file or directory joe@udp011919uds:~/libxerces-extract/usr/lib$ ldd /usr/local/bin/mrmonitord linux-gate.so.1 => (0xf76ec000)libdl.so.2 => /lib32/libdl.so.2 (0xf76d1000)librt.so.1 => /lib32/librt.so.1 (0xf76c8000)libpthread.so.0 => /lib32/libpthread.so.0 (0xf76ae000)libxerces-c.so.28 => /usr/lib32/libxerces-c.so.28 (0xf72e1000)libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf71eb000)libm.so.6 => /lib32/libm.so.6 (0xf71c5000)libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf71a6000)libc.so.6 => /lib32/libc.so.6 (0xf704b000)</di...
0 Kudos
Highlighted
Community Manager
17 Views

Very nice way Joseph, got it working with version 9.00.

but small hint you dont need to edit vivaldiframeworkd startup script at line 26 - didnt work for me, but simply change line 1 to # !/bin/bash and it will work smoothly.

Thanks, you made my day

Charles

0 Kudos
Highlighted
Community Manager
17 Views

Hi Keros

I have the same problem. The vivaldiframeworkd is not starting. Did you can post the vivaldiframeworkd. Did you have solved the errors? I'm interesting for the solution. I use Ubuntu Server 10.04 LTS 64 Bit on a Intel 5500 Server.

Best regards Americo

0 Kudos
Highlighted
Beginner
17 Views

Sorry for posting on such an old post, but there is very little information on this out there, I thought I'd share how I got this working on my system (Ubuntu 12.04.2 x86_64).

The new WebConsole version 12 doesn't appear to have the "mrmonitord" dameon, it seems as everything runs through the vivaldiframeworkd. Everything interesting is installed to "/usr/local/RAID Web Console 2".

Install the Lib_Utils, Lib_Utils2, and RAID_Web_Console with alien and dpkg as described above. After the raid_web_console was installed, it started spewing connection failed java errors. Open another terminal and kill the java process it started (ps aux, look for the pid of the java process near the bottom, kill it). I took "Strip's" advice and changed the shell interpreter to /bin/bash from /bin/sh and that solved the loop error.

I started the vivaldiframeworkd service and was able to connect without issue. As mentioned above, root must be enabled with "sudo passwd" and then enter a password for your root account.

I had already installed "libstdc++6" previously to get the cli utility working, so it may or may not require that package to be installed.

0 Kudos