Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,713 Views

Intel Server Board S5000PSL / Xeon L5320 -> Speed Stepping (Energy Consumption)

Hello,

I'm using a Intel S5000PSL Server Board with two Xeon L5320 CPUs and am having a problem with the power consumption.

The CPU does not step down to a lower power level.

Is there a way I can achieve that?

Here are some Informations from the server:

Board:

Intel S5000PSL

BIOS Version: S5000.86B.15.00.0101.110920101604

OS: Microsoft Windows Server 2008 R2 Standard (x64) Build 7601 (with SP1)

2xCPU:

Processor Manufacturer: Intel(R) Corporation

Processor Version: Intel(R) Xeon(R) CPU L5320 @ 1.86GHz

External Clock: 1066 MHz

Maximum Clock Supported: 1866 MHz

Current Clock: 1866 MHz

CPU Socket: Populated

CPU Status: Enabled

Processor Type: Central Processor

Processor Voltage: 1.2 V

Processor Upgrade: ZIF

Socket Designation: CPU1

Processor Name: Intel Xeon L5320

Original Processor Frequency: 1866.7 MHz

Original Processor Frequency [MHz]: 1867

CPU ID: 000006F7

CPU Brand Name: Intel(R) Xeon(R) CPU L5320 @ 1.86GHz

CPU Vendor: GenuineIntel

CPU Stepping: B3

CPU Code Name: Clovertown LV

CPU S-Spec: SLA4Q, SLAC9

CPU Thermal Design Power (TDP): 50 W

CPU Max. Case Temperature (Tcase_max): 60 °C

CPU Type: Production Unit

CPU Platform: LGA771 (FC-LGA6)

Microcode Update Revision: 6B

Number of CPU Cores: 4

Number of Logical CPUs: 4

Memory Information:

Memory 8GB

Memory Speed: 667 MHz

Memory

[General information]

Total Memory Size: 8 GBytes

Total Memory Size [MB]: 8192

[Current Performance Settings]

Current Memory Clock: 332.4 MHz (5 : 4 ratio)

Current Timing (tCAS-tRCD-tRP-tRAS): 5.0-5-5-15

Read to Read Delay (tRD_RD) Same Rank: 3T

Write to Write Delay (tWR_WR) Same Rank: 2T

Read to Write Delay (tRD_WR) Same Rank: 4T

Write to Read Delay (tWR_RD) Same Rank (tWTR): 8T

Write to Read Delay (tWR_RD) Different Rank: 2T

Read to Precharge Delay (tRTP): 3T

Write to Precharge Delay (tWTP): 16T

Write Recovery Time (tWR): 5T

RAS# to RAS# Delay (tRRD): 3T

Row Cycle Time (tRC): 20T

Refresh Cycle Time (tRFC): 28T

Drives:

Raid-1: 2 Drives

Raid-6: 6 Drives (external controller)

Energy Settings in the OS are as followed:

Intel Processor Diagnostic Tool:

CPU-Z reading max Multiplier:

In the bios speed stepping was activated, and I do not know what to do, to conserve some energy.

I hope you can help me to either find a setting, so I can put it into a more energy preserving mode when the power is not used.

Or if not have a recommendation on what to switch to, if it is not possible for some reasons.

Thank you very much in advance!

0 Kudos
7 Replies
Highlighted
Community Manager

Re: Intel Server Board S5000PSL / Xeon L5320 -> Speed Stepping (Energy Consumption)

If the the Speed-stepping was enable, then from the hardware perspective should be working fine. However we would recommend updating the firmware again just in case.

 

 

Bear in mind that this could also be that your operative system may be running a software that is causing this spike in the processor, in this case it would be a matter of checking what software or services are running on this system.
0 Kudos
Highlighted
Beginner

Re: Intel Server Board S5000PSL / Xeon L5320 -> Speed Stepping (Energy Consumption)

Can you recommend a way to find what's causing this?

Or is there a diagnostic tool / software to show the problem?

0 Kudos
Highlighted
Community Manager

Re: Intel Server Board S5000PSL / Xeon L5320 -> Speed Stepping (Energy Consumption)

We are not aware about any other tool from us to check this besides the one that you already provided. At this point it will be a matter of checking in the operative system the services or programs running that may be causing this.

0 Kudos
Highlighted
Beginner

Re: Intel Server Board S5000PSL / Xeon L5320 -> Speed Stepping (Energy Consumption)

I have tried to find the source of the problem, but am not finding the corresponding service or software doing this.

Can someone help and post a way to find what is causing the cpu not to use a lower multiplier?

You may know what is needed to keep it up at full multiplier so hopefully can help in finding the problem.

Maybe there is also a software beeing able to overpower this malfunction and set the multiplier autmatically, like

0-10% multiplier 1

10-50% multilier 2

and so on

Thank you for a hint.

0 Kudos
Highlighted
Community Manager

Re: Intel Server Board S5000PSL / Xeon L5320 -> Speed Stepping (Energy Consumption)

The processor does this automatically so there is not utility to bypass this settings as previously mentioned.

 

Have you tried updating the server board firmware?

 

I've sent you and email with some information regarding this issue too.

 

 

Let me know if you received it.

 

 

Regards,

 

 

Esteban V.
0 Kudos
Highlighted
Beginner

Re: Intel Server Board S5000PSL / Xeon L5320 -> Speed Stepping (Energy Consumption)

@ Estenan.V.: I got your mail, and no, it's not usable,

It states: Attempted to install on an unsupported platform.

Checked CPU for rest-able settings in powerconfig.

HWInfo64 states this picture all the time:

The firmware was updated but did not change anything.

Currently running: S5000.86B.15.00.0101.110920101604

Given the CPU can go to sleep-mode, what tool can I use to see what is causing it to stay awake?

There is supposed to be a Signal to the CPU telling not to rest.

0 Kudos
Highlighted
Community Manager

Re: Intel Server Board S5000PSL / Xeon L5320 -> Speed Stepping (Energy Consumption)

Hello Mark,

 

 

As stated before there is no utility to tell the processor to do that. This feature runs automatically within the processor, so if it's enabled in BIOS then should be working fine. If you already check in deep the processes running at the operative system level then the next course of action is trying using a different processor a see if it exhibits the same behavior.

 

 

0 Kudos