Community
cancel
Showing results for 
Search instead for 
Did you mean: 
FKens
Beginner
1,264 Views

RMM 3 command line status check

I've got a few devices that have RMM loaded. I know it's an intel rmm and pretty sure it's RMM3.

What I don't know is what is the IP of the device and how to get it from just the command line.

I can get RMM3 to work on a few devices because I know the RMM IP. I was given the RMM IP to the other boxes but when I try it either times our or gives me an error or sends me to some default page.

I have CLI access to all the devices and have tried using the mmconfig (all linux) and it's not working. I thought I noticed another command but wasn't able to try it due to a forced reboot on my windows box but can't remember where I saw it.

I think the CLI instances (linux) are barebones so after the RMM3 was installed all access to the commands may have been removed. I tried looking for them in the /usr/local/somewhere/somewhere folder and didn't find it. I haven't attempted to actually find the file.

I would like to know if there is a way to use basic linux commands without having to download anything and list the RMM status of each device at least the IP.

Any assistance would be helpful.

Thanks

0 Kudos
3 Replies
DSilv11
Valued Contributor III
114 Views

IPMItool lan print 1

ipmitool lan print 3

ipmitool user list 1

ipmitool user list 3

first 2 will tell you if the BMC \ RMM is configured for access and the IPs

2nd 2 will tell you if any users accounts are enabled for access.

1 is the shared base board NIC and 3 is the dedicated RMM nic

FKens
Beginner
114 Views

Doc silver;

Thanks, however I learned that the firewall may have been blocking me. Since then I've asked that they allow the RMM IP through. In one case they have.

I logged on to the device using putty and got the SMASH CLP prompt. I am going through the Intel_rmm_userguide_r1_4.pdf for what to do and it's not very helpful. I've typed sow help and it basically tells me to read the document I cited.

I tried the commands from an ssh putty session, you suggested and I get "No such file or directory".

Where do I run these commands?

DSilv11
Valued Contributor III
114 Views

Those command would run on the local OS (assuming your Linux version has IPMItool installed.)

If you are reaching the RMM now it has a web based interface you can access by just opening a web browser to the IP address of the RMM. (HTTP:\\10.10.10.1)

IPMItool can also be installed on your local system and run over the network using the command syntax:

ipmitool -H10.10.10.1 -Uuserid -Ppassword lan print 1

However since the above command are to tell you the IP, & if any userids are enabled, it does not do a lot of good since you can't use the commands unless you already know the BMC user name and password and IP.

You can get ipmitool here http://sourceforge.net/projects/ipmitool/files/?source=navbar IPMItool - Browse Files at SourceForge.net if it is not on your linux box.

It includes instruction to compile from windows or you do a sheach for ipmitool.exe, SUN use to post a windows version pre-compliled.

IPMIutil is a sister utility for windows and is here http://ipmiutil.sourceforge.net/ ipmiutil - IPMI Management Utilities

I have not used it as much so not sure of all the syntax.

Reply