Server Products
Data Center Products including boards, integrated systems, Intel® Xeon® Processors, RAID Storage; and Intel® Xeon® Processors
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
4433 Discussions

RS2WC080 driver gives error "This device cannot start. (Code 10)"

Community Manager

I purchased an rs2wc080 raid adapter a few weeks ago but couldn't get it going on my evga 680i motherboard (doesn't seem to like non-graphics cards in its PCI-e x16 slots). Fortunately I did have a test machine with xp on it to validate the rs2wco080 works. I ended up buying an Intel S3420GPLC motherboard just so I could get the adapter working.

I was able to set up a raid 50 array (using the rs2wco080's built in utility on boot up). I then was able to install Cyrix Xenserver 5.5 and the card seem to function propertly (I was able to create storage repositories using the raided drives). However, a ended up reloading the system with a fresh install Windows 2008 x64 (Note: not R2) with all the updates as of the date of this post. All the drivers seem to work the rs2wc080. While the installation starts at the end Windows gives the error

"Windows found the driver software for your device but encountered an error while trying to install it. Intel Raid Controller RS2WC080 This device cannot start. (Code 10)".

I downloaded the latest drivers for the rs2wco080 from Intel's website (ir3_Windows_signed_DRV_v4.32.0.xx) and installed from the W2K8_x64 folder. As an experiment I also tried uninstalling the drivers and resinstalling with R2 version. (same error).

Thanks for any help

0 Kudos
5 Replies
Community Manager

Got it working by just reinstalling Windows 2008 x64 again. I'm just updating the record in case anyone else has the same problem.

The original installation was also a fresh copy of Windows 2008 but for some reason either the order of installation seems to have caused the problem or that I did updates before installing the raid card. This was the order of operations I took.

1. Installed OS

2. Installed mobo chipset drivers (supplied from Intel website)

3. Installed mobo nic drivers (supplied from Intel website)

4. Installed raid card driver (supplied from Intel website)

5. Windows update last.

Community Manager


I am having similiar problem as the author.

I just bought RS2WC080 and placed it on the Supermicro MBD-X9SCL-O which is based on Intel C202 PCH Chipset (inside SC826 chassis). After posting through BIOS the card is detected and I can configure my array, set all the options and initialize it. (however init is all the time 0%).

I have installed OS on the SSD drive connected to the mobo controller (windows 7 pro, later windows 2008 r2), installed chipset and NIC drivers and then RAID driver. As a result I get "this device cannot start (code 10)" and I cannot see my array through webconsole.

I tried to install Windows again, but on that array. I set it to bootable through Ctrl+G option, I loaded driver drugin Windows install, but literally nothing has happened. I can't see that controller in windows.

Do you think that it may be compatibility issue with Supermicro mobo?




I also just bought the RS2WC080 raid controller. In created a raid 5 virtual host, which can be seen in my motherboard bios (MSI Z 77A-GD65). I tried to install the latest drivers but I also get the message "this device cannot start (code 10)". I'm running on a Win7 Ultimate.



I tried to reinstall windows, but nothing changed. I tried different drivers (LSI, and even the IBM drivers). Please help.




I finally got it to work.

It tried all firmwares I could find on the intel homepage.

This one was the only one that worked:

IR3_2008SASHWR_FWPKG-v20.10.1-0107 (fw: 2.130.354-1664)

After flashing the controller with this fw, windows 7 ultimate (64) immediatly found the controller.

With this the code (10) problem has been resolved for me.

Btw: this fw from the intel homepage is corrupted:


I almost got an heartattack when I read failure corrupted fw!

Here is a compatibility list for tested fw with os:

Although you won't find most of the fw in the download section.




Thanks Megatron! Came across this problem today and exactly like you said that firmware did the trick to get Windows 7 x64 to start properly. Thanks for the follow up!