Community
cancel
Showing results for 
Search instead for 
Did you mean: 
AKorn3
Beginner
1,227 Views

Raid config midplane2 sees HDD, bios doesn't

Jump to solution

Setup:

 

-S5000PALR

 

-AR2500 Chassis

 

-HW Active Midplane2 Raid w/ Activation Key & Dimm

 

(FALSASMP2 I believe, http://www.intel.com/support/motherboards/server/sb/CS-031742.htm http://www.intel.com/support/motherboards/server/sb/CS-031742.htm )

-3 SATA2 drives

-Latest Bios

Issue

 

Bios / Software / SW Raid (ctrl-c) does not see my SATA drives plugged through my backplane

 

Ironically HW Raid (ctrl-g) does see my SATA drives

The SATA is detected in the bios when plugged directly to the motherboard, therefore I must presume the problem lies with the use of the Midplane2. Since I can only see the drives when using HW Raid, does that mean I'm forced to use it? No documentation says so. For my purposes I actually do not want to use RAID of any kind for my setup. Disabling RAID, sw and hw, changing Sata to legacy, enabling ahci, does not help with my SATA detection.

If I can't get this to work, my only choice is to buy a passive midplane and plug all my sata straight to the motherboard. Right now I am unsure of the reason why my SATA drives are not detected, but I am still new to servers so I'm hoping it is just lack of experience vs a defect. Hopefully you guys can help me figure this one out. The one thing I am reluctant to do is update the RAID firmware as there are lot of warnings and I don't want to introduce possibly new problems and I dont plan to even use RAID anyway.

Thank you for any help.

0 Kudos

Accepted Solutions
Edward_Z_Intel
Employee
12 Views

Since you're using Midplane2, the HDDs are controlled by the embedded SAS controller, not onboard SATA controller. And since you have RAK and DIMM installed, you have HW RAID enabled.

If you really don't want to use RAID, you can remove the RAID Activation Key and DIMM from the Midplane2, and then it will work in IT/IR mode, which supports native SAS pass-through.

View solution in original post

2 Replies
Edward_Z_Intel
Employee
13 Views

Since you're using Midplane2, the HDDs are controlled by the embedded SAS controller, not onboard SATA controller. And since you have RAK and DIMM installed, you have HW RAID enabled.

If you really don't want to use RAID, you can remove the RAID Activation Key and DIMM from the Midplane2, and then it will work in IT/IR mode, which supports native SAS pass-through.

View solution in original post

AKorn3
Beginner
12 Views

Thank you kindly, you have resolved my problem. I took the Key and Dimm out and voila, the bios recognized all my drives.