Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,902 Views

S3420GPLC-based system does not recognize size of Seagate ST4000NM0033 4 TB disk correctly

Hi,

today I got my brand new ST4000NM0033 Constellation ES.3 4TB drive.

I plugged it into my server (Intel S3420GPLC motherboard, onboard SATA controller) and - bad surprise - I saw a size of only 1801 GB (BIOS level) and 1678 GB (Windows Server 2008 R2 level).

Switching between MBR and GPT modes in Windows did not make any differences.

Intel claims it should support drives larger than 2 TB (see http://www.intel.com/support/motherboards/server/sb/CS-032920.htm http://www.intel.com/support/motherboards/server/sb/CS-032920.htm).

So I plugged it into my IcyBox and hooked it up to my PC (Win 7 x64) by means of USB 2.0. Same story - only 1678 GB are recognized.

Then, I used the same IcyBox and connected it to the same PC by means of e-SATA. And what a surprise - it was properly recognized at 3726 GB, and I created and formated a partition of this size.

Finally, I plugged it back into my S3420GPLC Server. The ServerManager GUI tool now Claims 3726 GB, but diskpart stays at 1678 GB.

Now the 300€ question (that's about what I paid for the disk):

how do I get my server to recognize the full capacity consistently? How much data can I actually put on it?

Any help would greatly be appreciated!

Thanks a lot,

Tom

0 Kudos
15 Replies
Highlighted
Beginner
77 Views

I have exactly the same problem. any help much appreciated.

0 Kudos
Highlighted
Beginner
77 Views

I forgot to mention that my BIOS is at revision 51, which seems to be the latest and greatest.

As per Intel's documentation, already version 50 should provide support for drives > 2 TB.

Best regards,

 

Tom
0 Kudos
Highlighted
Employee
77 Views

Are you trying to install OS on it, or you just hook it up to an existing Windows installation as data disk?

0 Kudos
Highlighted
Beginner
77 Views

Same case but with a little different. I had S3420GP and Seagate Baracuda ST3000DM001 3TB. This 3TB just hook up to an existing windows 2003 Standart Edition as data disk (or in other term, as slave disk). In BIOS, the hdd not detected but when i run into "Intel Deployment Assistant (ver 3.6), my 3TB only detected as 763893 MB.

I have download "S5500_Windows_4_5.zip" file (https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=18317&lang=eng&OSVersion=Windows%20%... help Download Center), open the "ofu_userguide_r0_2.pdf", read it and then base on that pdf, the zip file i extract into d:\, open command prompt window, go to the extraction file (ex: d:\S5500 Window\Windows_OFU970_B21\OFU\windows) and run "install.cmd".

Not working because the command is not correct, it's said:

USAGE: Install [Platform]

The Platform is the number corresponding to different platforms.

S5000 = 1, SHW40 = 2, SE752 = 3, SBX44 = 4, S3000 = 5, SFC4UR = 6, S3200 = 7, SB

LUES = 8

Example:

Install 3

So, Because i don't know my S3420GP is on what platform, then i choose no 7, because i think my S3420GP is still on one family with S3200.

Then i run "install 7", the progress quiet OK, and in the end, it said the server must reboot unless for Win PE.

After reboot, still following the guide from "ofu_userguide_r0_2.pdf", then i ran "flashupdt -u /tmp/flashupdt.cfg".

Not working because the system can't found flashupdt.cfg.

I'm very sure that file is not on the extracted file nor in C:\ directory.

And then i search in http://support.intel.com http://support.intel.com as suggested in "ofu_userguide_r0_2.pdf", but with no result.

Any solution so my 3TB can be used properly? Many thanks..

0 Kudos
Highlighted
Employee
77 Views

Run "Setup_Win.exe" under OFU folder to install the utility. That document you read is for different server platforms. Use the document in the OFU package under doc folder.

The flashupdt.cfg is in the firmware package: https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=21517 Download Center. You need to download and extract it before running flashupdt.

Yes the board does support drives larger than 2TB. See http://www.intel.com/support/motherboards/server/s3420gp/sb/CS-030738.htm Memory and hardware compatibility for a tested hardware list.

0 Kudos
Highlighted
Beginner
77 Views

I have already run "Setup_win.exe" then run the flashupdt.exe -u flashupdt.cfg, here the result:

One-Boot Flash Update Utility Ver 9.70 Build 21

Copyright (c) Intel Corporation 2012

Update file configuration: XXX S3420GPX:S3420GPV:S3420GPC,1.0

Update file configuration: Revision 0.22

FRU & SDR Update Package Version for Intel(R) Server Board S3420GP

Copyright (c) 2010 Intel Corporation

Intel(R) Server Board S3420GP detected

Select the function you want to perform:

1 Update only the SDR

2 Update only the FRU

3 Update both the SDR and the FRU

4 Modify the Asset Tag

5 Exit FRU/SDR update

Answer: 3

Select the Chassis

1 Intel(R) Server Chassis PP5UP (SC5650UP)

2 Intel(R) Server Chassis HJ-Fix (SR1630GP)

3 Intel(R) Server Chassis HJ-HS (SR1630HGP)

4 Intel(R) Server Chassis PP5UP ULA

5 Intel(R) Server Chassis PP4DP_BRP (SC5299DP_SC5299BRP)

6 Intel(R) Server Chassis P4304XXSFCN (Union Peak Short)

7 Other Chassis

8 EXIT Update

Answer: 7

Usage of these fan speed control profiles is for internal use only.

Legal disclaimer for external use is pending.

Select a fan speed control profile for your chassis

1 Other Chassis Full Speed Fans

2 Other Chassis Slow ramp

3 Other Chassis Medium ramp

4 Other Chassis Fast ramp

Answer: 1

Does the system have chassis intrusion?n

Is a fan connected to the CPU connector?y

Is a fan connected to the SYS FAN1 connector?y

Is a fan connected to the SYS FAN2 connector?n

Is a fan connected to the SYS FAN3 connector?n

Is a fan connected to the SYS FAN4 connector?n

Probing system for sensor and FRU device hardware.

This may take up to one minute to complete.

Detected sensor and FRU device hardware

********************************************************************************

********************************************************************************

Would you like to update the chassis info area of the FRU?y

Would you like to enter the chassis type (HEX byte)?n

Would you like to enter the chassis serial number?n

Would you like to enter the chassis part number?n

Would you like to enter the 31 byte chassis manufacturer name?n

Would you like to update the product info area of the FRU?y

Would you like to enter the product part number?n

Would you like to enter the product serial number?n

Would you like to enter an product asset tag?n

Processing BMC update.........Please wait

Querying USB Interface...

Updating the OpCode........100% Done

Updating the PIA...........100% Done

Verifying the OpCode.......100% Done

Verifying the PIA..........100% Done

This may take up to 50 secs to exit.

Clearing SDR repository.......Please wait

Processing SDR Update.........Please wait

Updating the SDRs..........64 of 64.

Verifying SDR Update..........Please wait

Writing FRU - ID(0) Addr(20) SlaveAddr(20) Bus(FF)

Writing FRU Internal Use Area

Writing FRU Chassis Info Area

Writing FRU Board Info Area

Writing FRU Product Info Area

Updating the system BIOS...100% Done

This may take up to 50 secs to exit.

The system has been updated successfully.

A system reset is required for the update to take effect.

But when i restart, my 3TB still detect as 763893 MB (801 GB) on BIOS but the BIOS has been updated to ver S3420GP.86B.01.00.0051, build date: 05/11/2012 and BMC from ver 1.23 updated to ver 1.25

And when i login into windows, the hdd not detected alias not found in the windows explorer nor Disc Management.

0 Kudos
Highlighted
Employee
77 Views

I have tried it here with a Hitachi 3TB drive. Both BIOS and Windows see the drive properly. So, looks like compatibility issue. That's why we always recommend selecting hardware from the tested list.

Besides, which SATA mode did you set? Perhaps it's because your drive is using 4K sector. Does it have a emulated 512 sector mode?

0 Kudos
Highlighted
Beginner
77 Views

For SATA mode, i used Intel ESRT 2 which support RAID 0/1.

How do i know my drive using 4K sector or 512 sector mode?

right now i jus trying to update Intel® Rapid Storage Technology (Intel® RST) base on http://knowledge.seagate.com/articles/en_US/FAQ/218615en Intel Rapid Storage Technology (RST) drivers and Support for Disk Drives Beyond 2.2 TeraBytes (TB)

 

Wish me luck

0 Kudos
Highlighted
Employee
77 Views

For ESRT2, you'll need to create a VD on the new HDD before it can be detected in OS. See http://www.intel.com/support/motherboards/server/sb/CS-030492.htm http://www.intel.com/support/motherboards/server/sb/CS-030492.htm. When ESRT2 is enabled, BIOS doesn't display HDD info. Does the ESRT2 utility display HDD size correctly?

You drive has 512 Bytes per sector - it's documented in the datasheet: http://www.seagate.com/files/www-content/product-content/constellation-fam/constellation-es/constell... http://www.seagate.com/files/www-content/product-content/constellation-fam/constellation-es/constell.... Maybe I was looking at the wrong document last time. Sorry for the confusion.

0 Kudos
Highlighted
Beginner
77 Views

Yep, when ESRT2 enabled, BIOS doesn't display HDD info but when i chose Enhanced or AHCI mode, the HDD consist 801.5 GB which is not correct.

Then, when i use ESRT2 utility, the hdd still display 763893 MB

And for update Intel RST (https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=17882&ProdId=2101&lang=eng&OSVersion... Download Center), no luck, because it's said "This computer does not meet the minimum requirements for installing the software. Setup will exit."

For the hdd i used, ST3000DM001 (http://www.seagate.com/files/staticfiles/docs/pdf/datasheet/disc/desktop-hdd-data-sheet-ds1770-1-121... http://www.seagate.com/files/staticfiles/docs/pdf/datasheet/disc/desktop-hdd-data-sheet-ds1770-1-121...), it used 4K sector.

0 Kudos
Highlighted
Employee
77 Views

If you change from HDD mode from ESRT2 to AHCI or Enhanced in BIOS, you'll need to reboot the system to get correct HDD size. In my case AHCI mode doesn't display HDD size in BIOS, but OS can see the entire HDD size.

If you're using ESRT2, you can't install OS to a disk larger than 2TB. Install OS first on a HDD less than 2TB, and then initialize the large drive.

As for RST, you need to enable RST mode in BIOS before you can install RST driver/utility.

0 Kudos
Highlighted
Beginner
77 Views

In my case, the OS installed in a HDD < 2TB and the 3TB hdd is hook up as slave disk. And when i change into AHCI or Enhance mode, the OS can't be load because it's has been installed on ESRT2 mode and the doc said that.

Tomorrow i will check where to find the option to enabling RST mode in BIOS, thx.

0 Kudos
Highlighted
Employee
77 Views

ESRT2 should support 3TB HDD. Did you create a VD using the 3TB disk? Also make sure you have the latest ESRT2 driver loaded.

0 Kudos
Highlighted
Beginner
77 Views

Hi Edwardzh, sorry to keep you waiting because right now i'm in deep trouble with my origin hdd RAID.

Maybe i should tell from the beginning. Okay, before i add-in the new 3 TB hdd, previously my server had 2 Hdd which each capacity are 2TB. They configured as RAID 1 and run no problem for one year later.

When this 2 new 3TB comes, like you see in the history above, i tried to make this 2 hdd 3 TB to be recognize in BIOS as 3TB.

I tried upgrade the BIOS but still the BIOS still recognize this 2 hdd as 801Gb.

Then using Intel Deployment Assistant cd, i run RAID Web Console 2 - V6.71-01, i tried to make this 2 new hdd as HOTSPARE to see the miracle wether the capacity change to 3TB.

But there is no change, after that i redo the status from HOTSPARE to the origin, then restart the machine.

But after restart, suddenly the machine said "Reboot or select other media".

After that, i reboot the server and go to BIOS to see what happend, and you know, in the Boot Order, my previous 2TB not detected !

So, in the panic mode, shutdown the machine, unplug the 2 new 3TB hdd, then boot the machine, insert "Intel Deployment Assistant" cd again, go to RAID configuration, resetting again to RAID 1, reboot the machine, go to BIOS and in the Boot Order, they appear.

But still the "Reboot or select other media" message appear.

Next, i tried to press ctrl+E to go in Embedded Raid II Configuration Utility in the machine and suddenly, the system do rebuilding automatically.

Here the screen shot i've taken:

The picture above have been taken on Sept, 11.

This afternoon the rebuilding is complete, after that i reboot the machine but "Reboot or select other media" message still appear.

I going to ctrl+E again and you know, the rebuilding process came back !

My Question is why this is happening? i mean, i just change the status on new hdd but the side affect is impact on other hdd.

And why the process rebuilding occur again?

And if the system doing rebuilding, my data is going lose or not?

thanks

0 Kudos
Highlighted
Employee
77 Views

Sounds messy... First when you re-create RAID 1 using IDA CD did you initialize the VD? I hope you didn't because if you did, then all data is wiped-out already.

Now let's try this. Connect only Drive 1 and boot the system. The RAID will be in Degraded state, but see if it can boot to OS. If it can't boot, disconnect Drive 1 and connect Drive 2, and then boot again.

If both fail, then the last chance is to perform a Recovery Install. You'll need to load the latest ESRT2 driver during installation. If your old Windows partition can be detected, you may still get your data back. Again, do it with only one drive connected. If you're lucky enough to get your data back, you can rebuild later.

The reason of doing it is that in RAID 1, if one drive fails, you'll still be able to get your data from the other drive. However in your case completing the rebuild in Ctrl-E utility is not a good sign, because the data on the good drive might be overwritten, if disk 1 is having some intermittent error. Anyway, let's give it a try.

Again, when ESRT2 is enabled, the disks are not seen by BIOS because they're handled by the ESRT2 OpROM. If you change to AHCI or Enhanced mode, you'll have to reboot the system so that the BIOS can detect the drives correctly. And I wouldn't suggest using the drivers on the IDA CD, because they haven't been updated for quite a while. Always go to http://downloadcenter.intel.com http://downloadcenter.intel.com to get latest drivers.

0 Kudos