Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,166 Views

SR1625UR/2625UR HSC Firmware upgrade issues

Hi All-

This is my first post here so please don't be too harsh if my etiquette is not perfect

At any rate, I have a mixture of Intel SR1625URSASR & 2625URLXR systems - a while back there was a firmware upgrade which was posted for the Hot-Swap controller (v2.15). I applied this to all the systems, and noticed afterwards that the version being reported was now nothing, or sometimes 00.

Well, v2.16 was just released which according to the changelog fixed the problem of firmware version not being detected. That sounds great and all, but when I try and apply the firmware update by booting to EFI.... the update utility (fwiaupd.efi) can't find the controller! Duh!

I noticed there was a few flags that the utility could take which allows one to set the address to poll... default is 20. So I even tried manually running the HSC 2.16 update by doing:

fwpiaupd.efi -ni -u -b -address=20 -bin PET216.bin

or

fwpiaupd.efi -ni -u -b -address=20 PET216.hex

sadly... no microcontroller found. I know it's there though, since it does show up if I run the command as:

fwpiaupd.efi -address=20 -i

Firmware and PIA Flash Update Utility

Version 4.0.2 Build 6

Copyright (c) Intel Corporation 2009

*******

Trying to communicate with device on address 0x20

Inventory on address 0x20

Boot Block 0.18

Op Code 0.54

PIA 0.54

RMM3 0.54

**********

I'm sensing I might have to start setting jumpers to make this work??

Any pointers, comments, suggestions, similar problems or descriptions of anything even close to my issue is welcome.

TIA and I look forward to hearing from the community....

-spnyc

Tags (1)
2 Replies
JasonT_Intel
Moderator
51 Views

I tried updating the HSC on a SR2625UR with this firmware (2.16) with no issues. I just ran the script file included in the zip & it went well. I was able to go from 2.09 to 2.16 without any issues. I wish I had tried going to 2.15 first to see if I can replicate your issue.

To answer your question about a jumper on the backplane, I am not aware of any jumpers that would allow you to force update the firmware of the HSC.

One thing you could do though is to re-seat your bridge board. Hope this helps.

idata
Community Manager
51 Views

Hello Sir,

First thing kindly confirm SYSTEM SOFTWARE REQUIREMENTS/REVISIONS .

BMC revision:

 

BMC 43 or higher

 

 

- BIOS revision:

 

R0035 BIOS or higher

 

 

- FRUSDR 02 or higher

 

 

Updating using your own utility or switches is unsupported, and may leave your HSC in a non-functional state.

 

 

Firmware Installation Procedure (Requires HSC firmware already running):

 

1) Unzip the release package, and copy the contents onto removable media.

 

 

2) Boot to EFI, and change directories to the release directory.

 

 

3) Run the provided x625HSC215.nsh file.

 

 

4) The HSC will receive a boot code update. This could take up to 13

 

minutes to upload and verify.

 

 

5) After verification, the firmware requires 60 seconds to finish

 

updating. The front-panel power and reset buttons will be placed in

 

secure mode during this time. Any attempts to access these buttons

 

will result in security violation entries in the system event log.

 

Please do not reset or remove power from the system during this time

 

as any interruption could leave the HSC inoperable.

 

 

6) Please update your BMC's SDR package to the latest version.

 

 

7) Please reboot your system.

 

 

 

Warm Regard

Abdul Ahad

Reply