Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
3,367 Views

SS4200-E no_root_squash

I have made a recent purchase of the SS4200-E with the sole purpose of running as a NFS server. I edit the /etc/exports file to reflect the no_root_squash needed to meet my needs and it appears that the system resets this setting each time it restarts. There has got to be a fix for this issue but I can seem to find any solution yet.

 

Any Advice?

 

Thanks in advance.
15 Replies
Highlighted
Employee

Re: SS4200-E no_root_squash

The system reverts to the original /etc/exports (and possibly other files) every reboot. I don't know where you could hide something to do that.

0 Kudos
Highlighted

Re: SS4200-E no_root_squash

Below steps worked for me..

Step 1: edit /etc/exports

 

· / *(rw,sync,no_root_squash)

 

· Step 2: execute /etc/init.d/portmap restart

 

· Step 3: execute /etc/init.d/nfs restart

 

· Step 4: execute /etc/init.d/iptables stop

 

· Step 5: verify by executing "showmount –e localhost"

 

step 6: Ensure that gateway ip (netstart -nr)
0 Kudos
Highlighted
Employee

Re: SS4200-E no_root_squash

Cool! And that persists beyond reboots?

0 Kudos
Highlighted

Re: SS4200-E no_root_squash

yes..

I just ensured with the linux team, below steps will permanantely make changes..

Step 1: edit /etc/exports

 

· / *(rw,sync,no_root_squash)

 

· Step 2: execute /etc/init.d/portmap restart

 

· Step 3: execute /etc/init.d/nfs restart

 

· Step 4: execute /etc/init.d/iptables stop

Step 5 : · Step 6: verify by executing "showmount –e localhost"

 

step 6: Ensure that gateway ip (netstart -nr)

Step 1: edit /etc/exports

 

· / *(rw,sync,no_root_squash)

 

· Step 2: execute /etc/init.d/portmap restart

 

· Step 3: execute /etc/init.d/nfs restart

 

· Step 4: execute /etc/init.d/iptables stop

Step 5 : chkconfig nfs on

Chkconfig portmap on

Chkconfig iptables off

 

· Step 6: verify by executing "showmount –e localhost"

 

step 6: Ensure that gateway ip (netstart -nr)

0 Kudos
Highlighted
Community Manager

Re: SS4200-E no_root_squash

I have exactly the same no_root_squash need as the op and have tried following the instructions in response 2 and 4 but my /etc/init.d doesn't contain the executables listed. Here is the contents of my /etc/init.d:

S20urandom S40bond-init S41netplug S50sshd S60executord default_ip.awk rcS

 

S39interfaces S40network S50samba S59hostnamed cups hotplug zeroconf

I believe I'm running the latest firmware, 1.1.11.32736, and nfsd is enabled and working (i.e. I can mount SS4200-e volumes from my linux boxes using nfs).

0 Kudos
Highlighted
Community Manager

Re: SS4200-E no_root_squash

<!-- /* Font Definitions */ @font-face {font-family:"Cambria Math"; panose-1:2 4 5 3 5 4 6 3 2 4; mso-font-charset:0; mso-generic-font-family:roman; mso-font-pitch:variable; mso-font-signature:-1610611985 1107304683 0 0 159 0;} @font-face {font-family:Calibri; panose-1:2 15 5 2 2 2 4 3 2 4; mso-font-charset:0; mso-generic-font-family:swiss; mso-font-pitch:variable; mso-font-signature:-1610611985 1073750139 0 0 159 0;} @font-face {font-family:Consolas; panose-1:2 11 6 9 2 2 4 3 2 4; mso-font-charset:0; mso-generic-font-family:modern; mso-font-pitch:fixed; mso-font-signature:-1610611985 1073750091 0 0 159 0;} /* Style Definitions */ p.MsoNormal, li.MsoNormal, div.MsoNormal {mso-style-unhide:no; mso-style-qformat:yes; mso-style-parent:""; margin:0in; margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:Calibri; mso-fareast-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;} p.MsoPlainText, li.MsoPlainText, div.MsoPlainText {mso-style-noshow:yes; mso-style-priority:99; mso-style-link:"Plain Text Char"; margin:0in; margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.5pt; font-family:Consolas; mso-fareast-font-family:"Times New Roman"; mso-bidi-font-family:"Times New Roman";} span.PlainTextChar {mso-style-name:"Plain Text Char"; mso-style-noshow:yes; mso-style-priority:99; mso-style-unhide:no; mso-style-locked:yes; mso-style-link:"Plain Text"; mso-ansi-font-size:10.5pt; mso-bidi-font-size:10.5pt; font-family:Consolas; mso-ascii-font-family:Consolas; mso-fareast-font-family:"Times New Roman"; mso-hansi-font-family:Consolas; mso-bidi-font-family:"Times New Roman";} .MsoChpDefault {mso-style-type:export-only; mso-default-props:yes; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:Calibri; mso-fareast-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;} @page Section1 {size:8.5in 11.0in; margin:1.0in 1.0in 1.0in 1.0in; mso-header-margin:.5in; mso-footer-margin:.5in; mso-paper-source:0;} div.Section1 {page:Section1;} -->

kamalanathan

I was hoping you could elaborate on this a little more. When I run step 2 below I get the following messge

-sh: /etc/init.d/portmap: not found

Further I don't see the other files that you mention under the init.d directory. It appears that portmap, nfs and iptables run from somewhere else.

Any ideas on this?

Thanks

Sean

0 Kudos
Highlighted

Re: SS4200-E no_root_squash

Hello sean,

Which OS are you using?

make sure you have the following package installed in your OS.

1. portmap

2. NFS-utils

3.iptables

Issue the below commands to know whether you have NFS packages installed in your build.

# rpm -qa |grep portmap

# rpm -qa|grep iptables

# rpm -qa|grep nfs

I have RHEL 2.6 kernel machine and below lines will configure NFS setup permanently.

Step 1: edit /etc/exports

 

· / *(rw,sync,no_root_squash)

 

· Step 2: execute /etc/init.d/portmap restart

 

· Step 3: execute /etc/init.d/nfs restart

· Step 4: execute /etc/init.d/iptables stop

Step 5 : chkconfig nfs on

Chkconfig portmap on

Chkconfig iptables off

 

· Step 6: verify by executing "showmount –e localhost"

 

step 7: Ensure that gateway ip (netstart -nr)

Thanks,

kamal.

0 Kudos
Highlighted
Community Manager

Re: SS4200-E no_root_squash

Linux version 2.6.19.2 (soho@lsoho059.lss.emc.com) (gcc version 4.2.1) # 1 PREEMPT Tue Jun 24 04:35:38 MDT 2008

This is the version of Linux that shipped on the unit. I came installed with a 256MB DOM and boots from that. I'm guessing that you were not responding to that OS when you posted your solution.

Thanks

0 Kudos
Highlighted
Community Manager

Re: SS4200-E no_root_squash

I'm very interested in the solution for 1.1.11.32736. The file /mnt/soho_storage/config/exports apparently regenerates on reboot.

I wonder if it's possible to edit the script that regenerates this file. Anyone know where it is?

Message was edited by: benm&# 13; &# 13; See the next page of comments for my complete solution to this problem.

0 Kudos
Highlighted
Community Manager

Re: SS4200-E no_root_squash

Since there's no "/etc/init.d/nfs restart" script with my firmware, I can instead just type "exportfs -a" after adding no_root_squash to exports. This gets makes it work until the next reboot.

0 Kudos
Highlighted

Re: SS4200-E no_root_squash

oh really!..

Does it work for you?

 

Anyways, thanks for sharing the info!
0 Kudos
Highlighted
Community Manager

Re: SS4200-E no_root_squash

Well, it's only a temporary workaround. I'm still looking for a way to do this automatically so that it works after a configuration change or reboot.

Message was edited by: benm&# 13; &# 13; **See the next page of comments for my complete solution to this problem.**

0 Kudos
Highlighted
Community Manager

Re: SS4200-E no_root_squash

Benm

That works! Thanks for posting the answer. Please let us know if you run across a more permanent solution.

0 Kudos
Highlighted
Community Manager

Re: SS4200-E no_root_squash

For ultimate configurability and control, you could use the hardware only SKU which is just the SS4200-E without the EMC DOM, and install Linux. Or just remove the DOM. Obviously this isn't a supported configuration from Intel, but you would have more options for greater capabilities.

The SS4200 is just a 945GZ GMCH motherboard with a ICH7R south bridge (chipset software RAID). The eSATA port is controlled by a SIL3132 eSATA controller. The NIC is an Intel® 82573E 10/100/1000 Megabits per second (Mb/s) Ethernet Local Area Network (LAN) Controller. There should be no problem getting generic Linux drivers for those components.

The issue may be installing with some sort of video capabilities. The http://www.intel.com/support/motherboards/server/ss4200ehw/sb/CS-028981.htm Windows Home Server* Integration Guide shows how to use a video controller on the system with the use of a PCIe x1 to PCIe x16 flex extender.

You could probably even get a different DOM and use that for the OS. The SS4200-E system ships with a 256MB DOM for the EMC OS, but the system itself should support a larger DOM size. The DOM is just plugged into an IDE port.

Then all you need is a USB keyboard, mouse and CD-ROM.

0 Kudos
Highlighted
Community Manager

Re: SS4200-E no_root_squash

0 Kudos