Server Products
Data Center Products including boards, integrated systems, Intel® Xeon® Processors, RAID Storage, and Intel® Xeon® Processors
4865 Discussions

VMD for Storage Spaces Direct

George_Misits
Beginner
1,946 Views

I have 2 Server Systems R2208WFTZSR with S2600WFT motherboards.

Both have 8 NVMe SSD drives installed in them.

I don't have any VROC keys installed, i would like to use Intel VROC Pass Through mode.

The only way I am able to see the disks in Windows Server 2022 DC is to use the VROC driver.

My problem is, that Storage Spaces Direct sees them as BusType RAID, which is not supported.

(I know, that there is a workaround for the RAID BusType, but I would like to use these servers in a production environment, expanding the cluster in the future, so I want to go on the supported route.)

 

Is there any way to have the drives in real pass trhough mode, and see them as BusType NVMe?

Or do I have to use another controller, or special firmware?

0 Kudos
1 Solution
BrusC_Intel
Employee
1,901 Views

Hello, György Misits.


Thank you for posting on the Intel community Support forums.


I received your thread regarding this particular VMD inquiry, and I will be reviewing this with you.


The only option I can see in this case, if Storage Spaces does not see them as compatible, would be to disable VMD for the drives that will be used with Storage Spaces from the system BIOS, or simply disable it for all drives since VROC RAID configurations will not be used.


  1. Goto BIOS > Select Advanced > PCI Configuration > Volume Management Device
  2. Select each VMD that needs to be enabled or disabled (VMD Port 1x, VMD Port 2x and VMD Port 3x of each system Slot and PCIe SSDx can be enabled/disabled independently) press Enter key and select Enable or Disable
  3. Press F10 to exit and save the changes


Please let me know if this works for you, or if you are looking for something else, and I will follow up on July 5th in case additional time is required.


Regards,


Bruce C.

Intel Customer Support Technician


View solution in original post

0 Kudos
3 Replies
BrusC_Intel
Employee
1,902 Views

Hello, György Misits.


Thank you for posting on the Intel community Support forums.


I received your thread regarding this particular VMD inquiry, and I will be reviewing this with you.


The only option I can see in this case, if Storage Spaces does not see them as compatible, would be to disable VMD for the drives that will be used with Storage Spaces from the system BIOS, or simply disable it for all drives since VROC RAID configurations will not be used.


  1. Goto BIOS > Select Advanced > PCI Configuration > Volume Management Device
  2. Select each VMD that needs to be enabled or disabled (VMD Port 1x, VMD Port 2x and VMD Port 3x of each system Slot and PCIe SSDx can be enabled/disabled independently) press Enter key and select Enable or Disable
  3. Press F10 to exit and save the changes


Please let me know if this works for you, or if you are looking for something else, and I will follow up on July 5th in case additional time is required.


Regards,


Bruce C.

Intel Customer Support Technician


0 Kudos
George_Misits
Beginner
1,880 Views

Thank you Bruce C. the solution worked, now I see all drives as standard NVMe.

 

Best regards,

George Misits

0 Kudos
BrusC_Intel
Employee
1,864 Views

Hello, George_Misits.


I'm happy to be of assistance, and thank you for marking the thread as resolved.


In that case, I will proceed to permanently close this support thread, but if you need any type of assistance from Intel in the future, just open a new thread or contact us using any of the available support methods, and you may also receive a survey to help us improve.


Best regards,


Bruce C.

Intel Customer Support Technician


0 Kudos
Reply