Server Products
Data Center Products including boards, integrated systems, Intel® Xeon® Processors, RAID Storage; and Intel® Xeon® Processors
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
4297 Discussions

missing SATA driver with Installing Windows 7 Pro on Intel Server Board S5500BC

JSO2
Beginner
1,244 Views

I have started installing Win 7Pro when it got to the point where it asked for a driver for storage device, I searched the Intel support site and found S5500 Based Server AHCI SATA Storage Driver for Windows, downloaded the

File name:

RST_9.6.4.1002_Win_drivers_and_utils.zip, unzipped it , choose "Intel® ICH10R SATA AHCI Controller" but I got a blank screen, why?

I checked the motherboard BIOS selected AHCI for MASS Storage Device then browse for driver again this time it picked ICH10R SATA AHCI Controller however it still won't install Windows 7. Anyone have this problem before ? I setting the machine up with one hard disk and one DVD ROM only. Where is the correct SATA driver for this motherboard?

0 Kudos
5 Replies
JSO2
Beginner
126 Views

Forgot to say , hard disk was used on a RAID 5 setup with a adaptec controller, condition of the drive close to brand new..

Daniel_O_Intel
Employee
126 Views

If you are using an adaptec RAID controller, you should be using an adaptec driver. The driver you downloaded is only if you are running the drive off the motherboard ports.

JSO2
Beginner
126 Views

not using Adaptec RAID controller anymore so SATA drive is connected to motherboard SATA 0 .

JSO2
Beginner
126 Views

Since the hard disk was used in a RAID setup previously should I reformat the hard disk ?

SWood11
Beginner
126 Views

you're using the correct drivers. try wiping the disk out and try again. it could be picking up leftover adaptec metadata on the disk.

Reply