Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Flemming_P_
Beginner
99 Views

Admob cordova plugin problem

Hi I used this plugin in earlier projects

But now I dont see "Cordova Plugin Registry" in XDK 3619

Please see the Issue here

https://www.scirra.com/tutorials/4993/intel-xdk-adding-admob-plugin-a-pictorial-guide

 

R/Flemming

Tags (2)
0 Kudos
3 Replies
Nicolas_O_Intel
Employee
99 Views

Hello,

The Cordova project decided to use NPM instead of their custom Plugin Registry.

The Cordova Plugin Ad Admob has been publish in NPM here https://www.npmjs.com/package/cordova-plugin-ad-admob

Just select "npm" as Plugin Source, and use cordova-plugin-ad-admob in "Plugin ID", and you will get the admob plugin.

 

Flemming_P_
Beginner
99 Views

Thanks for answer

I still get BUILD FAILED when adding this .... use cordova-plugin-ad-admob in "Plugin ID",

Here is the LOG

https://am-xdk2.s3.amazonaws.com/cust.67c760b7-77dd-4b93-8f8a-665b67d9092e/app.d60112e3-43af-4d2f-b9...

I have no Idear what is wrong ?

 

 

 

 

PaulF_IntelCorp
Employee
99 Views

This is the key error, near the end of the build log:

* What went wrong:
Execution failed for task ':processReleaseResources'.
> Error: more than one library with package name 'com.google.android.gms'

You've got multiple plugins that are adding the same Java library, but different versions. I cannot tell which plugins are competing for these two libraries, you'll have to remove them, one-by-one, and build until the error goes away. This will help you isolate which plugins are causing the problem (you'll have to go through this process a few times to locate all the plugins that are causing the problem). Once you know which plugins are competing you'll have to figure out which plugin is most important to your app, or figure out some other method to resolve the competition.

Note, this is not something that the XDK can resolve for you, it is due to two or more plugins trying to pull in incompatible library resources. The fix is either in the mix of plugins you use or, in some cases, using updated or modified plugins that resolve the conflict.

Reply