Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
59 Views

Android Crosswalk cannot download and save Zip .apk files after v2248 install

After installing version 2248, I tried to download the successfully built Android Crosswalk and regular Android builds, but after pressing save to desktop, the zip file was never downloaded and saved (after many attempts). Could this be from the recent update (v2248) or a problem on my part? Also I have tried to continuously install old versions 2170 and 1621 (saved from my downloads) because I could not reinstall the current version due to a "Network Error" from both FireFox and Google Chrome that seems to only affect Intel XDK related downloads from previous builds to current builds on official website and forums. With the old versions, the problem of not being able to save still remains. Is anyone else experiencing these similar problems? or is this just a problem on my part?

On top of not being able to download my build Zip .apk Crosswalk Android file, I also couldn't download the .apk from my email as it said "Failed - Network Error" and or re-download Intel XDK from https://software.intel.com/en-us/intel-xdk as it also said "Failed - Network Error". But I can download other files from the internet and have tried both FireFox and Chrome which leads me to believe that that this is not a problem on my part.
But could it be? If so, does anyone possibly know why and how to fix this problem?

 Thank you for your time.

Tags (2)
0 Kudos
15 Replies
Highlighted
New Contributor III
59 Views

I'm using v2248 and don't have that problem. (System specs: Windows 7 x64, i5 Core)
I can download Crosswalk and native Android builds without any problem.

 

0 Kudos
Highlighted
Beginner
59 Views

Okay, Thanks for the reply. On top of not being able to download my build Zip .apk Crosswalk Android file, I also couldn't download the .apk from my email as it said "Failed - Network Error" and or re-download Intel XDK from https://software.intel.com/en-us/intel-xdk as it also said "Failed - Network Error". But I can download other files from the internet and have tried both FireFox and Chrome which leads me to believe that that this is not a problem on my part. But could it be? If so, does anyone possibly know why and how to fix this problem? Thank you.
0 Kudos
Highlighted
59 Views

So you are not able to save the .apk or .zip files to your desktop? I am not able to replicate this nor has it been reported before. There have also been issues with running behind a corporate network proxy or firewall. To check them try running Intel XDK from your home network where, presumably, you have a simple NAT router and no proxy or firewall. 

In the meantime, could you try unchecking the 'Use a secure link' check box and do a download? And also try emailing the build. See if that file from public link can be saved. (See screenshot attached)

0 Kudos
Highlighted
59 Views

Looks like your comment has been updated since my last answer. Are you behind a proxy or firewall?

0 Kudos
Highlighted
59 Views

I have also experienced this, but what happens is the download can get extremely slow, a download file is created and it can take 15 minutes or more when it should only take about one minute.

The problem you are describing is likely a problem with our cloud-server, I do not think it is related to the XDK or your install or your network connection. There has been a lot of work going into the cloud services to improve security and reliability, so the changes there are likely the cause of the problem.

Please try again to determine if this was a temporary issue or if it is a persistent issue for you. Also, confirm that you can log into the App Center and identify your projects in your account, there are situations where duplicate accounts have been created as a result of some of the login changes, and yours may be getting crossed (I have also experienced this issue and it has very confusing symptoms). A link to the App Center is on this page: https://software.intel.com/en-us/xdk/docs/lp-additional-resources -- after logging into the App Center you may have to leave the login tab open and then click the link on the above page a second time (that bug is known and is being fixed).

0 Kudos
Highlighted
Beginner
59 Views

Anusha Muthiah (Intel) wrote:
Looks like your comment has been updated since my last answer. Are you behind a proxy or firewall?
I use a regular home windows 7 firewall with an antivirus that also has its own firewall, but I do not believe my firewall has any effect on these processes.
Paul Fischer (Intel) wrote:

I have also experienced this, but what happens is the download can get extremely slow, a download file is created and it can take 15 minutes or more when it should only take about one minute.

The problem you are describing is likely a problem with our cloud-server, I do not think it is related to the XDK or your install or your network connection. There has been a lot of work going into the cloud services to improve security and reliability, so the changes there are likely the cause of the problem.

Please try again to determine if this was a temporary issue or if it is a persistent issue for you. Also, confirm that you can log into the App Center and identify your projects in your account, there are situations where duplicate accounts have been created as a result of some of the login changes, and yours may be getting crossed (I have also experienced this issue and it has very confusing symptoms). A link to the App Center is on this page: https://software.intel.com/en-us/xdk/docs/lp-additional-resources -- after logging into the App Center you may have to leave the login tab open and then click the link on the above page a second time (that bug is known and is being fixed).

I think you are right about Intel's cloud-server because I can download other content from the web but whenever I try to re-download the XDK from https://software.intel.com/en-us/intel-xdk (many atempts on both Chrome and FireFox) or download files emailed from the build I get the same Network error message. Also my connection to Intel's website is not that great either as I sometimes see missing css, js or html content when loading in (while my connection to other websites are fine). This proves your point of the cloud-server. The problem has been persistent for the last 2 days (possibly further; perhaps since the last update on the 17th as I have been using it for the last 2 days) I can see my projects on App center and it seems to be good with a glance look but I still have that same network error message when trying to download my build, It starts to download (I'd assume download file is created) and in the process it says "Failed - Network error" like my other attempt downloads from email (public and secure).
Ad wrote:
I'm using v2248 and don't have that problem. (System specs: Windows 7 x64, i5 Core) I can download Crosswalk and native Android builds without any problem.
Ad seems to have not been affected by the cloud-server problems so could this be area based or could it be local? Before the version 2248 update, everything was working perfectly. Is there anything that I can do in the mean time, as I cannot receive .apk file to update my Android application? Thank you.
0 Kudos
Highlighted
59 Views

The fact that you are getting CSS and JS errors even from the regular Intel web site makes me believe there is something else going on, possibly with your login. Those main intel.com site pages are on a completely different server system than the build server and the App Center. If those pages are responding weird AND the XDK cloud-servers are weird, the only thing I can think of is the login services. That is the only common element between those two entities.

Let me talk to the engineers in charge of that element to see if they have any insight.

I doubt that an earlier version of the XDK would make any difference, but if you want to try, there is a post on the forum that has copies of the 6120 release (make sure to keep a copy of the 2248 release to reinstall, later).

0 Kudos
Highlighted
59 Views

I spoke with the folks in charge of the login system and that is definitely not part of the problem, the only interaction there is the initial login, after that the XDK itself and the XDK backend servers are not pinging that component with any significant frequency. Even the URLs that are used to download built files are different than our regular site.

So are you saying that you get bad pages when you go to a page in the *.intel.com domain, using a regular browser?

0 Kudos
Highlighted
Beginner
59 Views

Paul Fischer (Intel) wrote:

The fact that you are getting CSS and JS errors even from the regular Intel web site makes me believe there is something else going on, possibly with your login. Those main intel.com site pages are on a completely different server system than the build server and the App Center. If those pages are responding weird AND the XDK cloud-servers are weird, the only thing I can think of is the login services. That is the only common element between those two entities.

Let me talk to the engineers in charge of that element to see if they have any insight.

I doubt that an earlier version of the XDK would make any difference, but if you want to try, there is a post on the forum that has copies of the 6120 release (make sure to keep a copy of the 2248 release to reinstall, later).

The problem has mysteriously gone away and now I am able to build and reinstall the current XDK from official website, if you and or Intel had made any fixing modifications; thank you for your time and service.

0 Kudos
Highlighted
59 Views

Glad to hear it's working again. Not clear what was wrong, if you see this again, please let us know.

0 Kudos
Highlighted
Beginner
59 Views

Hi

I am using the 3759 of intel xdk and windows 7. I am getting the same issue, not able to download build zip.

Any help I Appreciate.

 

0 Kudos
Highlighted
59 Views

Radha W. wrote:

I am using the 3759 of intel xdk and windows 7. I am getting the same issue, not able to download build zip.

How are you attempting to download? Did you try mailing the download to yourself using the "share" icon on the build tile?

0 Kudos
Highlighted
Beginner
59 Views

I have tride the both options, download icon which comes after build successfully generated and mail. But not using "share"icon.
0 Kudos
Highlighted
59 Views

Please try using the "share" icon to send yourself a link to the built app:

Screen Shot 2017-05-24 at 10.32.00 .png

0 Kudos
Highlighted
Beginner
59 Views

Yesterday I have downloaded the intel xdk 3972 version, I use the share icon and mail to myself but not works, it is taking too much time for download. After some time I have tried the download icon option and then it works now. :) 

I don't know what is issue, but not sure this issue may will comes future. 

Thanks a lot for your help.:)

0 Kudos