Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Yury_B_
Beginner
192 Views

Android Virtual Device Manager can not recognize HAXM

When I am starting to create a new virtual device, I get: HAXM is not installed warning. However inside SDK-Tools HAXM is presented as installed.

Also if I run sc query intelhaxm using command line, I see: STATE: 4 RUNNING for this service.

If I click on Install HAXM during AVD creation process, I get the following dialog:

Android SDK is up to date. 
Running Intel® HAXM installer. 
Intel HAXM updated successfully! 
Done

Then I close the dialog and see HAXM is not installed again!

(!) Hyper-V is disabled. Intel VTx option in BIOS is enabled...

My system is Windows-10 64-bit, CPU - Intel Core i3-7100U

Also I have tried to install HAXM manually (not from SDK) - does not help.

If I run >%ANDROID_SDK_ROOT%\tools\emulator –avd <avd_name> -verbose –show-kernel
I get: CPU Acceleration: DISABLED, HAXM is not installed on this machine
However  sc query intelhaxm always returns: STATE: 4 RUNNING

What can I do else to make this working?

Thank you!

UPD. I am facing this issue with Android Studio 2.3.3, however version 3.0 works fine. For the some reason I need to use 2.3.3 with this project.

0 Kudos
0 Replies
Reply