Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Rob_J_
Beginner
183 Views

Basic network setup

System: Windows 7 with 3120A, WinSCP and PuTTY both working with root account.

I am trying to ping the host and eventually the internet but so far this hasn't worked.

 

On the Xeon Phi, ifconfig shows:

mic0 Link encap:Ethernet HWaddr <private>

          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING  MTU:64512  Metric:1
          RX packets:16933 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12845 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3712426 (3.5 MiB)  TX bytes:6368498 (6.0 MiB)

and on the host ipconfig shows:

Ethernet adapter Local Area Connection 6:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : <private>
   IPv4 Address. . . . . . . . . . . : 192.168.1.99
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection 7:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : <private>
   IPv4 Address. . . . . . . . . . . : 192.168.1.200
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1

where connection 6 is the Xeon Phi and Connection 7 is the wi-fi card.

On the Phi I have also tried

 route add default gw 192.168.1.1

which is the wi-fi router's gateway address to the 'net.

 

So far I can't ping out of the 3120A at all, although incoming pings from the host succeed.

Any clues or ideas gratefully accepted.

 

 

0 Kudos
8 Replies
Rob_J_
Beginner
183 Views

Solved. Windows firewall was blocking ICMP packets. Grrrrr.

Rob_J_
Beginner
183 Views

Further update on this, for anyone else who is trying to get an X100 coprocessor working properly in Windows.

 

1. Fix firewall issues in Win7. Specifically, if any network is marked as "Unknown Network" it must be set to either Home or Work, otherwise the firewall shuts down all outgoing traffic. It can NOT be set as a Public network. In my case the VPN I use to remotely access and control crypto mining servers was causing problems.

2. Bridge 192.168.1.99 to 192.168.1.200 (Xeon Phi to Wi-fi card - actually a tiny USB dongle - under Win7)

3. route add default gw 192.168.1.1 (on the Xeon Phi)

 

I can now ping the Google DNS at 8.8.8.8 but still have no DNS available to the Phi.

 

Rob_J_
Beginner
183 Views

Final step: edit /var/run/resolv.conf and add the line:

 

nameserver 8.8.8.8

 

DNS now works as expected. Job done.

 

Rob_J_
Beginner
183 Views

[root@mic0 ~]# traceroute google.com
traceroute to google.com (172.217.25.174), 30 hops max, 46 byte packets
 1  192.168.1.1 (192.168.1.1)  1.631 ms  1.384 ms  1.733 ms
 2  *  *  *
 3  10.194.33.209 (10.194.33.209)  39.487 ms  39.382 ms  39.804 ms
 4  *  *  *
 5  210.49.109.226 (210.49.109.226)  64.395 ms  198.142.255.70 (198.142.255.70)  39.379 ms  198.142.255.66 (198.142.255.66)  38.537 ms
 6  10.194.120.6 (10.194.120.6)  31.646 ms  26.686 ms  29.749 ms
 7  10.194.120.13 (10.194.120.13)  29.730 ms  10.194.120.9 (10.194.120.9)  29.570 ms  39.385 ms
 8  *  10.194.120.194 (10.194.120.194)  37.016 ms  10.194.120.202 (10.194.120.202)  29.390 ms
 9  210.49.49.9 (210.49.49.9)  29.418 ms  29.402 ms  39.770 ms
10  *  *  *
11  *  *  *
12  *  *  *
13  hu0-7-0-0.22btpr01.optus.net.au (59.154.18.238)  56.694 ms  hu0-4-0-0.22btpr01.optus.net.au (59.154.18.232)  41.736 ms  59.545 ms
14  72.14.219.128 (72.14.219.128)  50.535 ms  48.593 ms  59.854 ms
15  108.170.247.33 (108.170.247.33)  30.591 ms  108.170.247.65 (108.170.247.65)  49.230 ms  108.170.247.33 (108.170.247.33)  49.247 ms
16  108.170.235.193 (108.170.235.193)  40.576 ms  108.170.235.195 (108.170.235.195)  51.435 ms  108.170.235.193 (108.170.235.193)  44.949 ms
17  syd09s13-in-f14.1e100.net (172.217.25.174)  49.610 ms  58.686 ms  36.653 ms
[root@mic0 ~]#

 

Rob_J_
Beginner
183 Views

Mining Monero with lukminer:

 

Rob_J_
Beginner
183 Views

Making these setting persistent between boots has turned out to be a tricky exercise. The trouble with the MIC is that it behaves like a RAM disk, it has no memory at all when booted.

The first step to rectifying this is to create a file in the host filesystem (under C:\Program Files\Intel\MPSS\filesystem) that contains the changes required. Using that directory as a base, we add a new file mic0\etc\init.d\user which contains the following:

#! /bin/sh
# /etc/init.d/user
#

# Add an internet gateway
route add default gw 192.168.1.1

# Add a nameserver
echo "nameserver 8.8.8.8" > /etc/resolv.conf

Then we add a new line to mic0.filelist:

file /etc/init.d/ipv6 etc/init.d/ipv6 755 0 0
file /etc/init.d/user etc/init.d/user 755 0 0 <---- ADD
file /etc/hostname etc/hostname 644 0 0

Finally, rebooting the MIC shows these changes have been effective and that the files are present. Unfortunately I still can't see how to get this to apply automatically at boot, but at least now all I need to do to add the changes is issue the command:

/etc/init.d/user

from within PuTTY rather than having to remember all the gory details.

Rob_J_
Beginner
183 Views

Just put that last issue to bed. I needed to add the following to mic0.filelist:

slink /etc/rc5.d/S01timesync ../init.d/timesync 0755 0 0
slink /etc/rc5.d/S80user ../init.d/user 0755 0 0 <---- ADD
file /root/.ssh/authorized_keys root/.ssh/authorized_keys 600 0 0

Now when I boot up I can issue ping google.com immediately and it works. Awesome!

Whit_D_
Beginner
182 Views

I'm trying to do the same thing on Windows 10, without success (yet). My local network is 192.168.0.*, so I change the internal and external addresses of the Phi to 192.168.0.31 and 192.168.0.30 respectively. I can then ssh into the Phi from the host via the new address, and add the default gateway (192.168.0.1) and nameservers as you do. At this point, the Phi can ping itself and its external address only. Next, I bridge the Phi and host ethernet connections, setting the bridge IP to that of the host to reestablish internet connectivity. At this point, I can no longer connect to the Phi via ssh from the host... I have set Windows Firewall to allow ICMP traffic, and also tried with the firewall turned off with no apparent difference in the result. Thoughts or insight would be appreciated. Cheers.
Reply