Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Fabian_S_
Beginner
45 Views

Build Failed, in IOS and Windows Phone

Hi,

Intel XKD is giving me an error "build failed" when I build in IOS and Windows Phone.
I have even created a very simple test application in "Construct 2" and have no plugins added, it has only one button and a text. It only works on Android. I'm using the same developer credentials for both Windows and IOS as before.
Please, I need your support. We have completed our project and are ready to go to market.

Regards

Tags (2)
0 Kudos
1 Reply
PaulF_IntelCorp
Employee
45 Views

Fabian --

Hi Paul F.

Error built for Windows Phone

We have several weeks that we have tried to complete an application developed in "Construct2" and exported with "Cordova Android 4.0 (crosswalk), and IOS 8.0

1) We are having problems building for Windows Phone 8.1. No good if it's an Intel XDK error because the Microsoft Developer ID begins with CN = ..... I've already tried with the letters CN and without but have not been successful. I attached the error file showing  the XDK for build.

2) The other problem is incompatibility with Android. Building with Intel XDK is successful, but when we uploaded the "myapp.armv7.android.apk" file to Google Play for testing in "alpha testing". Then we tried on an Android 4.4.2 Galaxy S5 for viewing  in the Google Play store and we got a message that says "version of this application is not compatible". We don't understand because it says that because we exported the project from Córdoba "Android 4.0+ (Ice Cream Sandwich) (Crosswalk)" in Construct 2. it's supposed to work for all subsequent versions 4.0 ...?
We spoke with the support from Google Play and we were told that the problem is the "armeabi-v7a" that doesn't exist within the application.

"It seems that the problem is with" armeabi-v7a armeabi " is not in your application code"

Please, we need help to finish up our project.
Thank you

Are you still experiencing an issue with the Window Phone builds? There was a problem with that part of the build system that was corrected last week. Insert your Windows credentials without the CN= and confirm that it works that way.

Regarding Android builds, it sounds like you have a plugin that includes some native-code library files and that is causing the problem. This is not something the XDK can fix, it is something that only you can fix by identifying the problem plugin and replacing it with an alternate that does not cause this problem or with an updated version of the plugin.

Reply