Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
19 Views

Can't Build Must Check Optimize with Crosswalk?

I recently got a bunch of notices from Google Play, requiring me to add a privacy policy to my audio and video apps.

Problem is, XDK 3491 will not let me build. It seems to want me to check "optimize with Crosswalk". Problem with that is, it adds enough MBs to my audio and video apps, they may go over the 100mb Google Play limit. Is it really required, and how can I build without Crosswalk?

Also, it is telling me to change Cordova version; I have 5.1.1 I have been trying to update to the latest version of XDK, but my internet connection is really slow, and the update failed. Trying again.

So basically, I can't update the apps. Is there a way to get around the Crosswalk and Cordova stuff?

Tags (2)
0 Kudos
5 Replies
Highlighted
19 Views

You do not need to build with Crosswalk. The XDK is not "requiring" that you check the "Optimize with Crosswalk" checkbox, it's just recommending that you do this. You can still build for Android if you uncheck that box.

Likewise, you are not required to change to 5.1.1, it is a recommendation, not a requirement.

0 Kudos
Highlighted
Beginner
19 Views

I left another post. It will not let me build. I was finally able to update XDK to the newest version, 3759. It is frozen at "fail" even though I have updated the CLI and XDK. I have attached screenshots.

0 Kudos
Highlighted
19 Views

How large is your app. If the size of your project folder is about 400MB or larger it will cause a failure in the build system. Another issue is if you are specifying plugins via the intelxdk.config.additions.xml file -- all plugins need to be added to your project using the plugin manager, using the additions file will cause problems.

0 Kudos
Highlighted
Beginner
19 Views

The apps are around 35mb. I'll try deleting and re-adding the plugins.

0 Kudos
Highlighted
19 Views

Your project settings were in an odd state when I imported your project. I've seen this before but it is very hard to reproduce, so we do not know how to fix it.

I think all you need to do is disable the iOS build tile on the Build tab. See the image below from your screenshot, uncheck the blue checkmark in the upper right corner of the iOS build tile, the XDK won't let you build because there are issues with your iOS build settings that need to be addressed, but the blue checkmark means you are asking the XDK to build an iOS package as well as an Android package.

Then, in order to get your project files in sync, go to the Test tab and click the green "Push Files" button. This will force all your project files to synch and be written to disk. Once that is done, go back to the Build tab and try building your app.

In summary:

  • clear the blue checkmark on the iOS tile on the Build tab
  • go to the Test tab and click the green "Push Files" button
  • return to the Build tab and try building for Android

no-errors.jpg

0 Kudos