Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Dylan_H_
Beginner
299 Views

Cannot remove older version of software manager

I am desperately trying to update my software manager, but I cannot since the older version of the software manger cannot be uninstalled. I found a previous forum here https://software.intel.com/en-us/forums/intel-software-development-products-download-registration-li... but was unable to ascertain a solution from the thread. Jennifer said:

The workaround for this problem is to remove the Intel Software Manager components after verifying that there are no currently installed products using it.  The cause was probably an incomplete uninstall of an older version of ISM that the installer could not update.  I will close this thread - please create a new thread if you have a similar problem. 

How precisely do I remove the ISM if it cannot be uninstalled manually? I can send my error logs, but I really need this resolved. Thank you.

0 Kudos
2 Replies
Jennifer_D_Intel
Employee
299 Views

Hello,

There are two places the ISM has files.  One is [program files]\Common Files\Intel\Intel Software Manager.  The other contains the information about which products are currently installed, and is in C:\Users\[user]\App Data\Local\Intel Corporation.  Under that folder there should be folders for Intel(R) Software Manager and ism_current.  ism_current has the executables, and Intel Software Manager has the xml files containing the current installed software. 

In Intel(R) Software Manager there should be an xml file called local_store*.xml which contains the products you have installed.  You can look in there and see if it has anything.  The uninstaller doesn't run if it thinks you have existing products installed with it.  You can see if you can run ism.exe from either Program Files or the ism_current user folder, and see if it tells you anything. 

You can try deleting all these files and attempt the install from ism.msi again.  Delete folders [program files]\Common Files\Intel\Intel Software Manager and [user]\App Data\Local\Intel Corporation\Intel Software Manager and ism_current.  The msi should reinstall the files to [program files], and then when you run ism.exe it should update the folders under [users]. 

Let me know if you are able to re-install and update ISM.

Regards,

Jennifer

Xavier_H_Intel
Employee
299 Views

Hi,

I ran into a similar issue and any tentative of manual uninstallation failed.

In the end I ran this tool from Microsoft instead: http://support.microsoft.com/mats/program_install_and_uninstall/ to cleanly uninstall Intel Software Manager, and it worked well.

Reply