Community
cancel
Showing results for 
Search instead for 
Did you mean: 
PaulF_IntelCorp
Employee
178 Views

Cannot start XDK on Ubuntu et al Linux installs

This is a known issue that is under investigation. We hope to have it resolved in the next release of the Intel XDK. In the meantime, please see this FAQ for additional help > https://software.intel.com/en-us/xdk/faqs/general#bad-proxy. If that does not work try the workaround described below (which is also described in this post: https://software.intel.com/en-us/forums/intel-xdk/topic/593312#comment-1846587).

---- best workaround  ----

Install the Intel XDK for the local user, not as root or sudo. This is the most reliable and the default installation option. This will insure that the XDK has the proper permissions to operate on your Linux system. The XDK will be installed in a subdirectory of your user home (~) directory.

---- original workaround rephrased below ----

There is a permission problem when the Intel XDK is installed as "sudo" leaving the installer option "Launch Intel(R) XDK" selected.

The first time the Intel XDK runs under this scenario, it creates the folders ~/.config/XDK and ~/.config/XDK-Wrapper owned by root so the next time the Intel XDK is executed as a regular user it will incorrect permissions for those files and will fail.

The workaround is to change the ownership of those folders:

# change ownership of user files
sudo chown -R ${USER} ~/.config/XDK*

And then start the Intel XDK as a regular user (using the Launch icon or the command line):

# run xdk
~/intel/XDK/xdk.sh 

If this does not fix your problem, try the following: 

#Uninstall XDK 

# if installed as sudo
$ sudo /opt/intel/XDK/uninstall.sh
# if installed as user
$ ~/intel/XDK/uninstall.sh

# Remove installation folders, if they still exist
$ sudo rm -rf /opt/intel/XDK
$ rm -rf ~/inel/XDK

# Install XDK 
$ sudo <installer-path>/install.sh

# Unselect "Launch Intel(R) XDK" option in the installer wizard

# Run XDK as regular user (either from Launch Icon or command line)
$ /opt/intel/XDK/xdk.sh

Please let us know if this fixes your issue.

Tags (2)
0 Kudos
16 Replies
Sergio_J__C_
Beginner
178 Views

I will review and if I find the problem i would post

Aulia_R_
Beginner
178 Views

up up up

PaulF_IntelCorp
Employee
178 Views

Install the Intel XDK for the local user, not as root or sudo. This is the most reliable and the default installation option. This will insure that the XDK has the proper permissions to operate on your Linux system. The XDK will be installed in a subdirectory of your user home (~) directory.

natalia_galliani
Beginner
178 Views

Hello,

at first, I install XDK like user, but I can not achieve run it. Then I uninstall it and reinstalled like sudo, but it can not run anyway. So, do you think there is a problem whit the path /opt?

I have Ubuntu 10.04 in my computer.

PaulF_IntelCorp
Employee
178 Views

Please see the previous post for advice. Install it as a local user in your home directory.

natalia_galliani
Beginner
178 Views

Paul F. (Intel) wrote:

Please see the previous post for advice. Install it as a local user in your home directory.

 

Thank you for your fast reply. But I'sorry, it doesn't work. 

I keep the instructions once more. And this time I change the default directory "/opt/intel" by another path.

PaulF_IntelCorp
Employee
178 Views

Do not set or override the install path. When you install, choose a "local" install; do not choose a "root" or "sudo" install. Then let the install script choose the install location, do not change the install location. If you choose a "local" install it will install it into something like ~/intel/xdk, not /opt/intel.

natalia_galliani
Beginner
178 Views

Paul F. (Intel) wrote:

Do not set or override the install path. When you install, choose a "local" install; do not choose a "root" or "sudo" install. Then let the install script choose the install location, do not change the install location. If you choose a "local" install it will install it into something like ~/intel/xdk, not /opt/intel.

I uninstalled it again.

I remove files, like you indicate at first.

I don't choose "root" or "sudo", I don't click anything, default options is "install as_current user" and I don't modify it. Just press "Next"

In "Options" I see "Install location: /home/natalia/intel/XDK", I don't modify it. Press "Install".

After instalation, I unselect "Launch Intel(R) XDK". Press "Finish".

It doesn't run. I take pictures if you want to see.

 

PaulF_IntelCorp
Employee
178 Views

There is a script file inside of /home/natalia/intel/XDK that you must execute to start the XDK. For example, open a terminal and at the prompt, typing:

$ /home/natalia/intel/XDK/xdk.sh

will start the XDK app.

natalia_galliani
Beginner
178 Views

Yes Peter, I tried with this sentence too.

I think XDK can not work in my computer. It's all.

Thank you for tring to help.

Cheers.

Leon_B_
Beginner
178 Views

I've tested on Ubuntu 16.04 and it was working some weeks ago.

In Fedora, it won't work since 2993 build.

In Arch Linux, install throught AUR repo (and install yaourt):

$ yaourt xdk

it will download and install all dependencies and run any needed script

JLuna5
New Contributor I
178 Views

Hi, try reinstall XDK, i'm using XDK mac os version,  I have problems and I reinstalled XDK and is running fine.

Greetings,

 

JudLup!

13

David_S_1
Beginner
178 Views

I had a more recent experience where an xdk update from 3522 to 3619 worked for a while, then failed to restart apparently owing to a bad libudev.so.0 symlink. After faffing around with locating a replacement libudev1[...].deb (no easy task) and restoring the symlink, which did not work, I then tried a complete uninstall of 3619 (including rm -rf ~/intel/*) and reinstall of 3522, but I still could not start xdk. Only after nuking ~/.config/XDK and ~/.config/XDK-Wrapper followed by another clean reinstall of 3522, I was able to start up and run xdk on my Ubuntu 12.04 development box. Yeah, I need to upgrade.

George_Fisher
Beginner
178 Views

FWIW I have resorted to the following script (Ubuntu 16.10)

#!/bin/bash

# start Intel's XDK mobile app development IDE

if [[ -f ~/intel/XDK/xdk.sh ]]; then
    sudo ~/intel/XDK/xdk.sh&
elif [[ -f /opt/intel/XDK/xdk.sh ]]; then
    sudo /opt/intel/XDK/xdk.sh&
else
    echo "Intel XDK installation not found; see the website about to open"
    open_url https://software.intel.com/en-us/intel-xdk
    pause
fi

 

JLuna5
New Contributor I
178 Views

Hi Paul F, Could you solve the problem?

PaulF_IntelCorp
Employee
178 Views

JudLup Luna wrote:

Hi Paul F, Could you solve the problem?

Are you installing the 3922 version? The installation has been change to *REQUIRE* that you do a local install. Do not change to the install location to /opt/intel, use the default location (or a variant) that is located within your home directory.

Reply