Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Andrew_A_
Beginner
271 Views

Cant add or remove plugins

Hi, 

I'm a Construct 2 user with the latest version of XDK and Construct. 

I came to add a plugin to my project today and everything seemed normal until 'fetching plugin', upon which, after a random amount of time the dialog disappears and nothing happens. I also cannot remove any plugins, same issues as above but with 'removing plugin'. 

I have tried: 

A) Uninstalling and reinsalling XDK
B) Removing all traces of the plugins from config ect and then trying to add them only in XDK
C) Deleting all project files and exporting fresh from Construct
D) Adding the plugin manually in the files and then starting XDK

I tried a few other things too but obviously nothing has worked so far. 

To clarify this issue affects all plugins, third party and core. 

 

Any suggestions?

 

Thanks, 

Andy

Tags (2)
0 Kudos
25 Replies
PaulF_IntelCorp
Employee
40 Views

This is making less and less sense.  :-(  I just tried to reproduce this again today, with the app you originally gave me, and I can no longer reproduce it. So I'm starting to wonder why it failed for a while, but not permanently... It is now working for me, regardless of the presence of a config.xml file.

Can you setup an Ubuntu VM or do you know someone with a Mac where you could try this on a different OS and machine to see if you get the same results? The fact that I was able to see it for a day, but can no longer, makes me think it might be some strange timing issue, so trying under dramatically different conditions might make it work, or might help shed further insight into what is going on.

Andrew_A_
Beginner
40 Views

Hi Paul, 

my apologies for the extended delay on this reply - I've been out of the country again and that has limited my ability to get my hands on a Mac for testing. 

I have now managed to run some tests on a Mac and I can report that the problem that I am facing on my Windows laptop is not reproduced on that platform. Plugins are resolved and can be added/removed at will. 

I am unfortunately having some other issues with the Mac though - it wont update beyond 3522 (when I update, everything installs fine but once I close it and reopen, it is still 3522 and tells me that a new update has been downloaded and asks me if would I like to install it). I've tried uninstalling and just installing the latest version but no luck. Same issue.

This aside though, I am still very interested in getting my primary development device working with XDK again. Has there been any forward progress on the issue in my absence? Beyond reformatting my Windows device and starting again do you have any more suggestions? 

Thanks for all your help, 

 

 

PaulF_IntelCorp
Employee
40 Views

No further progress on why this is happening, I have not been able to reproduce again. At this point, I'm curious to see if our next release (which will be happening very soon) might make a difference. The version of node-webkit has been upgraded, substantially, so it will impact lots of behaviors.

Regarding the update problem, download and update the install manually, from http://xdk.intel.com rather than relying on that auto-updater. Sometimes that thing goes awry and the only way to get it working is to do a manual download and install.

Laurent_C_
Beginner
40 Views

Hello!

Necro post skill level 3.... But, I have exactly the same at this exact moment and I feel very lost.... I simply cannot add or remove any plugins to my project. I have added and deleted some in the past on this project, but... I can't anymore. Third party plugin -> cordova-plugin-ad-chartboost -> the popup shows for a while and closes, nothing happens...

PaulF_IntelCorp
Employee
40 Views

Laurent, what happens if you create a new blank project and try to add plugins to that project. Does that work? If so, it means there may be a problem with one of the project files in the problem project.

Reply