Community
cancel
Showing results for 
Search instead for 
Did you mean: 
pierre_g_
Beginner
527 Views

DCM /FW Install Issues (error: -4)

Hi,

Like many others, I have the -4 error when installing the latest DCM 1.4.27.41944.

Camera is a F200, ordered from Intel. SN is W4VF 0800 505R 0018 9R

The camera worked before on Windows 8.1. The current OS is a fresh Windows 10 64bit install, running on the same hardware than before. Neither the DCM not SDK has been install previously. CPU is i7-3520M. Laptop is a Lenovo X230. (I don't have desktop with Windows to try out)

The camera is plugged in an USB3 port.

In the device manager, the camera is not recognized in the Imaging devices section, but do shows up under Audio inputs and outputs as 'Microphone Array (Creative 3D Gesture Camera VF0800)'

Attached are the DCM install log files found under %temp%\micl_tmp_%username%

Any clue how to unbrick the camera ?

Pierre

 

 

 

0 Kudos
16 Replies
Xusheng_L_Intel
Employee
527 Views

Since we requires Intel 4th gen CPU and above, could you try this camera in the system meets this requirement? Thanks!

pierre_g_
Beginner
527 Views

Hi,

Thanks for the suggestion. I'll try to find a machine matching this requirement.

However, in the meantime, since:

  • the camera was already working on the same machine
  • I'm not blocked by a runtime error but a firmware update / camera init
  • I'm not aware of difference between USB3 on Intel gen3 and USB3 in Intel gen4   

Is there a way to unbrick the camera ?

 

Thank you,

Colleen_C_Intel
Employee
527 Views

What does is say in Device manager under USB - any Realsense (and exact name please)

pierre_g_
Beginner
527 Views

Hi

I've check on a win10 with a i7-3770 (gen4 Intel cpu), same behavior.

Under Windows, I don't remember seeing any other RealSense reference besides the one I put in my first post. I'll double check.

If it helps, here is the output of dmesg console under Linux (kernel 4.1.0) when I plug it in a USB3 port:

[  522.752765] usb 3-4: new high-speed USB device number 8 using xhci_hcd
[  522.883364] usb 3-4: New USB device found, idVendor=05e3, idProduct=0610
[  522.883369] usb 3-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  522.883371] usb 3-4: Product: USB2.0 Hub
[  522.883374] usb 3-4: Manufacturer: GenesysLogic
[  522.883904] hub 3-4:1.0: USB hub found
[  522.884248] hub 3-4:1.0: 2 ports detected
[  523.577210] usb 3-4.2: new full-speed USB device number 9 using xhci_hcd
[  523.822194] usb 3-4.2: New USB device found, idVendor=041e, idProduct=4099
[  523.822198] usb 3-4.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  523.822201] usb 3-4.2: Product: Creative VF0800
[  523.822203] usb 3-4.2: Manufacturer: Creative Technology Ltd
[  523.822205] usb 3-4.2: SerialNumber: 201501141707
[  523.958492] input: Creative Technology Ltd Creative VF0800 as /devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4.2/3-4.2:1.3/0003:041E:4099.0008/input/input21
[  524.013738] hid-generic 0003:041E:4099.0008: input,hiddev0,hidraw2: USB HID v1.11 Device [Creative Technology Ltd Creative VF0800] on usb-0000:00:14.0-4.2/input3

and lsusb -t

/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 480M
    |__ Port 4: Dev 10, If 0, Class=Hub, Driver=hub/2p, 480M
        |__ Port 2: Dev 11, If 0, Class=Audio, Driver=snd-usb-audio, 12M
        |__ Port 2: Dev 11, If 1, Class=Audio, Driver=snd-usb-audio, 12M
        |__ Port 2: Dev 11, If 2, Class=Audio, Driver=snd-usb-audio, 12M

The video interface is not even showing up like it used to.

Pierre

 

 

pierre_g_
Beginner
527 Views

Hi,

I checked and when I'm plugin-in the camera, I have 3 entries about the camera:

PS C:\Users\ticapix\Desktop> Get-CimInstance Win32_PnPEntity | Where Caption -match '3D'


Caption                     : Microphone Array (Creative 3D Gesture Camera VF0800)
Description                 : Audio Endpoint
InstallDate                 :
Name                        : Microphone Array (Creative 3D Gesture Camera VF0800)
Status                      : OK
Availability                :
ConfigManagerErrorCode      : 0
ConfigManagerUserConfig     : False
CreationClassName           : Win32_PnPEntity
DeviceID                    : SWD\MMDEVAPI\{0.0.1.00000000}.{24332ED6-DB49-4D71-A490-B3D104762369}
ErrorCleared                :
ErrorDescription            :
LastErrorCode               :
PNPDeviceID                 : SWD\MMDEVAPI\{0.0.1.00000000}.{24332ED6-DB49-4D71-A490-B3D104762369}
PowerManagementCapabilities :
PowerManagementSupported    :
StatusInfo                  :
SystemCreationClassName     : Win32_ComputerSystem
SystemName                  : MSA-49678190
ClassGuid                   : {c166523c-fe0c-4a94-a586-f1a80cfbbf3e}
CompatibleID                : {GenericAudioEndpoint, SWD\GenericRaw, SWD\Generic}
HardwareID                  : {MMDEVAPI\AudioEndpoints}
Manufacturer                : Microsoft
PNPClass                    : AudioEndpoint
Present                     : True
Service                     :
PSComputerName              :

Caption                     : Creative 3D Gesture Camera VF0800
Description                 : Creative 3D Gesture Camera VF0800
InstallDate                 :
Name                        : Creative 3D Gesture Camera VF0800
Status                      : OK
Availability                :
ConfigManagerErrorCode      : 0
ConfigManagerUserConfig     : False
CreationClassName           : Win32_PnPEntity
DeviceID                    : USB\VID_041E&PID_4099&MI_00\9&3A068627&0&0000
ErrorCleared                :
ErrorDescription            :
LastErrorCode               :
PNPDeviceID                 : USB\VID_041E&PID_4099&MI_00\9&3A068627&0&0000
PowerManagementCapabilities :
PowerManagementSupported    :
StatusInfo                  :
SystemCreationClassName     : Win32_ComputerSystem
SystemName                  : MSA-49678190
ClassGuid                   : {4d36e96c-e325-11ce-bfc1-08002be10318}
CompatibleID                : {USB\Class_01&SubClass_01&Prot_00, USB\Class_01&SubClass_01, USB\Class_01}
HardwareID                  : {USB\VID_041E&PID_4099&REV_1001&MI_00, USB\VID_041E&PID_4099&MI_00}
Manufacturer                : Creative Technology Ltd.
PNPClass                    : MEDIA
Present                     : True
Service                     : usbaudio
PSComputerName              :

Caption                     : Intel(R) RealSense(TM) 3D Camera (Front F200) Device
Description                 : WinUsb Device
InstallDate                 :
Name                        : Intel(R) RealSense(TM) 3D Camera (Front F200) Device
Status                      : OK
Availability                :
ConfigManagerErrorCode      : 0
ConfigManagerUserConfig     : False
CreationClassName           : Win32_PnPEntity
DeviceID                    : USB\VID_8086&PID_0A95\111111111111
ErrorCleared                :
ErrorDescription            :
LastErrorCode               :
PNPDeviceID                 : USB\VID_8086&PID_0A95\111111111111
PowerManagementCapabilities :
PowerManagementSupported    :
StatusInfo                  :
SystemCreationClassName     : Win32_ComputerSystem
SystemName                  : MSA-49678190
ClassGuid                   : {88bae032-5a81-49f0-bc3d-a4ff138216d6}
CompatibleID                : {USB\MS_COMP_WINUSB, USB\Class_FF&SubClass_FF&Prot_FF, USB\Class_FF&SubClass_FF, USB\Class_FF}
HardwareID                  : {USB\VID_8086&PID_0A95&REV_0100, USB\VID_8086&PID_0A95}
Manufacturer                : WinUsb Device
PNPClass                    : USBDevice
Present                     : True
Service                     : WINUSB
PSComputerName              :



PS C:\Users\ticapix\Desktop>

(I also grepped for 'Sense', 'Camera' but it doesn't return more entries than the 3 above)

 

I hope it helps the investigation. What else would you need ?

 

Pierre

 

 

pierre_g_
Beginner
527 Views

Hi,

Any idea of what is going wrong with the camera ?

Should I try something else ?

Do you need more info ?

 

Thanks

pierre_g_
Beginner
527 Views

Hi,

I updated my PC to Windows 10 (build 10658) and I have the same problem.

The camera is still listed as 'Intel(R) RealSense(TM) 3D Camera (Front F200) Device' in the device manager but the firmware cannot be updated. Same -4 error.

Is there a tool I could run to diagnose further the camera state ?

 

 

 

PKusm
New Contributor I
527 Views

Hi Pierre,

I don't think that your i7-3770 is the 4th Gen (Haswell) Intel Processor.
Check these wikipedia pages for further information:
1. Haswell

2. Ivy Bridge

pierre_g_
Beginner
527 Views

Hi,

That's correct, my bad.

Just for sanity check, I borrowed a laptop running Windows 10 (build 10240) with USB3 and an i7-4600U cpu, tried to install the DCM but I got the same -4 error.

I'm uploading a new set of logs.

From the logs, we can read:

2015-10-20 11:10:56,281 [T2584] InitCamera called
2015-10-20 11:10:56,281 [T2584] DFU Log message 27: IsDFUConnected called
2015-10-20 11:10:56,281 [T2584] DFU Log message 29: IsDfUdevice true
2015-10-20 11:10:56,281 [T2584] IVCAM_DLL.cpp:137 - Failure at this line.
2015-10-20 11:10:56,281 [T2584] DFU Log message 30: UpdateFirmware called
2015-10-20 11:10:56,281 [T2584] HAL_MediaFoundationHal.cpp:1128 - Failure at this line.
2015-10-20 11:10:56,281 [T2584]  [IvC 0] WinUsbHal::GetGVD
2015-10-20 11:10:56,281 [T2584]  [IvC 0] WinUsbHal::SendHWmonitorCommand start
2015-10-20 11:10:56,297 [T2584]  [IvC 0] deviceNum != 1
2015-10-20 11:10:56,297 [T2584] HAL_WinUsbHal.cpp:1088 - Failure at this line.
2015-10-20 11:10:56,297 [T2584] HAL_WinUsbHal.cpp:1046 - Failure at this line.
2015-10-20 11:10:56,297 [T2584] HAL_WinUsbHal.cpp:720 - Failure at this line.
2015-10-20 11:10:56,297 [T2584] HAL_CompositeIVCAMHal.cpp:145 - Failure at this line.
2015-10-20 11:10:56,297 [T2584] HAL_IVCAMHal.cpp:360 - Failure at this line.
2015-10-20 11:10:56,297 [T2584] DFU: WinUsb device missing. Assuming recovery mode. Trying to reset with ACPI.
2015-10-20 11:10:56,297 [T2584] DFU.cpp:883 - Failure at this line.
2015-10-20 11:10:56,297 [T2584] DFU: ACPI failed. proceeding with other options.
2015-10-20 11:10:56,297 [T2584] DFU Log message 27: IsDFUConnected called
2015-10-20 11:10:56,297 [T2584] DFU Log message 29: IsDfUdevice true
2015-10-20 11:10:56,297 [T2584] HAL_MediaFoundationHal.cpp:1128 - Failure at this line.
2015-10-20 11:10:56,297 [T2584]  [IvC 0] WinUsbHal::GetGVD
2015-10-20 11:10:56,297 [T2584]  [IvC 0] WinUsbHal::SendHWmonitorCommand start
2015-10-20 11:10:56,297 [T2584]  [IvC 0] deviceNum != 1
2015-10-20 11:10:56,297 [T2584] HAL_WinUsbHal.cpp:1088 - Failure at this line.
2015-10-20 11:10:56,297 [T2584] HAL_WinUsbHal.cpp:1046 - Failure at this line.
2015-10-20 11:10:56,297 [T2584] HAL_WinUsbHal.cpp:720 - Failure at this line.
2015-10-20 11:10:56,297 [T2584] HAL_CompositeIVCAMHal.cpp:145 - Failure at this line.
2015-10-20 11:10:56,297 [T2584] HAL_IVCAMHal.cpp:360 - Failure at this line.
2015-10-20 11:10:56,297 [T2584] DFU: GetFWData failed while in recovery mode. Ignoring the failure
2015-10-20 11:10:56,297 [T2584] DFU Log message 11: GotoDFU called
2015-10-20 11:10:56,297 [T2584] DFU Log message 27: IsDFUConnected called
2015-10-20 11:10:56,297 [T2584] DFU Log message 29: IsDfUdevice true
2015-10-20 11:10:56,297 [T2584] DFU: IsDFUConnected is true when not expected.
2015-10-20 11:10:56,297 [T2584] Signed Image version = 2.60.0

2015-10-20 11:10:56,297 [T2584] DFU_version = 12

2015-10-20 11:10:56,297 [T2584] FW_highestVersion = 2.60.0

2015-10-20 11:10:56,297 [T2584] FW_lastVersion = 2.60.0

2015-10-20 11:10:56,297 [T2584] OEM_Id =  0x0

2015-10-20 11:10:56,297 [T2584] moduleSerial = 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 

2015-10-20 11:10:56,641 [T2584] DFU: Second try of DFU_DownloadFirmware failed. Aborting DFU procedure.

and

2015-10-20 11:10:42:846 void __thiscall CUpdateFW::Init(void (__stdcall *)(int,int)) Entered
2015-10-20 11:10:42:846 void __thiscall CUpdateFW::Init(void (__stdcall *)(int,int)) Completed
2015-10-20 11:10:42:846 int __thiscall CommandMgr::ExecuteCommand(void) Entered
2015-10-20 11:10:42:846 CommandMgr.cpp	 int __thiscall CommandMgr::ExecuteCommand(void)%	arguments: C
2015-10-20 11:10:42:846 int __thiscall CUpdateFW::WFCompareVersions(void) Entered
2015-10-20 11:10:42:846 int __thiscall CUpdateFW::inGetFWFileInfo(void) Entered
2015-10-20 11:10:42:846 int __thiscall CUpdateFW::inGetFWFileInfo(void) Completed
2015-10-20 11:10:42:846 int __thiscall CUpdateFW::inGetVersions(void) Entered
2015-10-20 11:10:42:846 int __thiscall CUpdateFW::InitCamera(void) Entered
2015-10-20 11:10:42:846 UpdateFW.cpp	 int __thiscall CUpdateFW::InitCamera(void)e or more intermediate directories of log do not exist
	CIVCAM_DLL::InitCamera() failed, error code: 1280
2015-10-20 11:10:42:846 int __thiscall CUpdateFW::InitCamera(void) Completed
2015-10-20 11:10:42:846 int __thiscall CUpdateFW::inGetVersions(void) Completed
2015-10-20 11:10:42:846 int __thiscall CUpdateFW::WFCompareVersions(void) Completed
2015-10-20 11:10:42:846 CommandMgr.cpp	 int __thiscall CommandMgr::ExecuteCommand(void)Exists(void)	Command: Compare File version and FW version, ret:-3
2015-10-20 11:10:42:846 CommandMgr.cpp	 int __thiscall CommandMgr::ExecuteCommand(void)sts(void)	In recovery mode
[...]

2015-10-20 11:10:42:846 MessageDisplay.cpp	 void __cdecl MessageDisplay::PrintRetError(const int,const Ivcam::TIVCAM_STATUS)	Error Recovery Required. Update should be performed  
2015-10-20 11:10:42:846 MessageDisplay.cpp	 void __cdecl MessageDisplay::PrintRetError(const int,const Ivcam::TIVCAM_STATUS)e	

2015-10-20 11:10:42:846 MessageDisplay.cpp	 void __cdecl printIvcamStatus(const Ivcam::TIVCAM_STATUS)gramFiles(x86)	IV Camera status: Camera is in recovery mode

 

Could a dev look at that trace and check what are the expected behavior from the source code ? Filename and line numbers are provided in the log.

thank you,

pierre_g_
Beginner
527 Views

pierre_g_
Beginner
527 Views

Any update ?

Xusheng_L_Intel
Employee
527 Views

Pierre, we known several people have such issue and we are working on it. Since we cannot reproduce this issue so it maybe take some time to find root cause. We will keep you post. Thanks for the patient and supporting our RealSense SDK.

pierre g. wrote:

Hi,

It seems that it's not an isolated case. Other users are reporting the same -4 firmware update problem

 

pierre_g_
Beginner
527 Views

Hi,

I've captured and dumped the USB packets with USBpcap, from the USB3 port where the camera is connected, when trying to install the latest DCM.

The dump is attached on this post. (remove the .txt extension)

Apparently, one packet is not formated correctly, see dump and screenshot.

3 \\.\USBPcap3
  \??\USB#ROOT_HUB30#4&1cf5861f&0&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
    [Port 2] Generic USB Hub
      [Port 2] USB Composite Device
        Creative 3D Gesture Camera VF0800
          Microphone Array (Creative 3D Gesture Camera VF0800)
        USB Input Device
          HID-compliant consumer control device
          HID-compliant headset
    [Port 6] Generic SuperSpeed USB Hub
      [Port 1] WinUsb Device

 

I can hardly go deeper without reverse engineering your binaries.

Pierre

 

Xusheng_L_Intel
Employee
527 Views

Pierre, thanks for those valuable logs and those will help us to find the root cause. 

pierre g. wrote:

Hi,

I've captured and dumped the USB packets with USBpcap, from the USB3 port where the camera is connected, when trying to install the latest DCM.

The dump is attached on this post. (remove the .txt extension)

Apparently, one packet is not formated correctly, see dump and screenshot.

3 \\.\USBPcap3
  \??\USB#ROOT_HUB30#4&1cf5861f&0&0#{f18a0e88-c30c-11d0-8815-00a0c906bed8}
    [Port 2] Generic USB Hub
      [Port 2] USB Composite Device
        Creative 3D Gesture Camera VF0800
          Microphone Array (Creative 3D Gesture Camera VF0800)
        USB Input Device
          HID-compliant consumer control device
          HID-compliant headset
    [Port 6] Generic SuperSpeed USB Hub
      [Port 1] WinUsb Device

 

I can hardly go deeper without reverse engineering your binaries.

Pierre

 

pierre_g_
Beginner
527 Views

Hi,

Any update ?

Do you have new release or some internal tools I could try to bring back to life the camera ?

Thanks,

pierre_g_
Beginner
527 Views

Hi,

Any update ?

Intel released an update for the SDK. Can we expected a DCM update to unbrink our cameras ?

I contacted the Intel support that for all technical matters forwarded me back to this forum.

If you can't reproduce the bug to investigate, ask any of the users affected by the same bug to sign an NDA, join a beta program or whatever , run some internal diagnosis tool and get things done.

I find highly unprofessional to brick several users hardware via a normal software update and not even try to show sign of fixing it.

Reply