Software Archive
Read-only legacy content
Announcements
Intel Customer Support will be observing the Martin Luther King holiday on Monday, Jan. 17, and will return on Tues. Jan. 18.
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646
17065 Discussions

Data Path not set

Mwesigwa_E_
Beginner
126 Views

Am a newbie to Intel xdk, however i have been using Appery.io platform and everything seems familiar, I have a problem binding a webservice response to any componet,easch time i choose Multiple, the data path shows "not set".i have watched video tutorials and the data path sets it's self automatically..eg movies[].

Screenshot 2017-01-04 20.04.43.png

0 Kudos
6 Replies
Giselle_G_Intel
Employee
126 Views

What happens when you change the controller type to single instead of multiple?

Mwesigwa_E_
Beginner
126 Views

 

This is what happens when i choose single. When i bind the objects to the list component, the looping does not happen. Infact even the single list item does not get the data.for example it will remain  as  {{entry.["resource"]["0"]["Description"]}} when previewed in the simulator.

Screenshot 2017-01-05 10.33.34.png

Giselle_G_Intel
Employee
126 Views

We are currently looking into this problem - it is a bug with the data binding. Once there is new information on a workaround or it is fixed, we will post information about it. See this thread for the similar issue > https://software.intel.com/en-us/forums/intel-xdk/topic/703233 < they are doing single data bindings, but it seems to be the same root cause.

Kiriakos_T_
Beginner
126 Views

I have exactly the same problem while using RSS reader from web services. Is there any solution, yet?

PaulF_IntelCorp
Employee
126 Views

There is no resolution, yet. A bug has been issued for engineering.

Odyssefs_E_
Beginner
126 Views

Same here. None of my services works. I am running build 3759 and the new one makes things even worse. It crashes every time I am trying to save the binding.

Reply