Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Maina_W_
Beginner
165 Views

Error Incomplete Crosswalk Project Service

Jump to solution

Hi, i have been working on a project using Intel XDK and it was working fine, even on my phone until the latest build which threw the error on my phone, Error Incomplete Crosswalk Project Service: Please repackage Elimu Asilia, tried a couple of time but the error persist on my phone, it works well on the emulator, the only significant things i did between the successful build and none successful build were:

  1. Tried to remove intel.xdk.cache plugin unsuccessfully
  2. Tried to upgrade from 5.1.1 to 5.4.1 but it refused to build so i reverted back
  3. Made some changes on my code (CSS, JS and HTML

2943db75-2655-4a9b-b049-6b4205f52f4e.png)

Tags (2)
0 Kudos
1 Solution
PaulF_IntelCorp
Employee
165 Views

It sounds like your plugins directory is corrupted. Simplest thing to try is to delete the entire plugins directory inside your project (exit the Intel XDK first). When you restart the XDK and open your app you may be presented with a dialog that says your plugins are out of sync, if you get that message, choose the list of plugins that are in the project file. You project should then reinstall the plugins.

The other problem may be that you have plugins specified in your intelxdk.config.additions.xml, which you should remove.
 

View solution in original post

7 Replies
PaulF_IntelCorp
Employee
166 Views

It sounds like your plugins directory is corrupted. Simplest thing to try is to delete the entire plugins directory inside your project (exit the Intel XDK first). When you restart the XDK and open your app you may be presented with a dialog that says your plugins are out of sync, if you get that message, choose the list of plugins that are in the project file. You project should then reinstall the plugins.

The other problem may be that you have plugins specified in your intelxdk.config.additions.xml, which you should remove.
 

View solution in original post

Maina_W_
Beginner
165 Views

My problem came up when i update my Cordova CLI version from 5.1.1 to 5.4.1, i updated CLI and Plugins, when i did this, it refused to build the application, which has led me to believe that is due to corrupted plugins as Paul F from intel explains above. So i downgraded back from 5.4.1 to 5.1.1 and forgot to update the plugins and CLI, so it threw the above error, the solution was simple, upgrade again and upgrade both CLI and plugins then downgrade back and update the CLI and Plugins, so that it loads the old plugins which worked before, hope this helps you

ghani_g_
Beginner
165 Views

The same here my problem not fixit

Pamela_H_Intel
Moderator
165 Views

@Vitali - you are getting the same error message, after upgrading CLI? Have you been able to re-sync your plugins?

@Ghani - what are your symptoms? The same error message? Which CLI are you using? Have you tried syncing your plugins?

ghani_g_
Beginner
165 Views

@Pamela H. incomplete crosswalk project. How can I update plugins ? I am using 3240 

ghani_g_
Beginner
165 Views
although i tried another project the same problem still existed and emulator not running
Pamela_H_Intel
Moderator
165 Views

@Ghani - to update your plugins, do as Paul says above . . . close XDK and delete the contents of the plugin folder for a project. Restart XDK, open that project, and add the plugins back in. Also, (as Paul says) check your intelxdk.config.additions.xml file. There may be "extra" plugins in there.

Reply