Software Archive
Read-only legacy content
Announcements
Intel Customer Support will be observing the Martin Luther King holiday on Monday, Jan. 17, and will return on Tues. Jan. 18.
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646

Font Awesome Icons disappearing on edit

Nick_F_2
New Contributor III
116 Views

I'm creating a project using Framework 7 and Font Awsome icons.

The Icons are inserted at the <i> tag like this <i class="fa fa-cogs" data-position="icon only">

They display fine until I click the icon to edit function or edit the page in some way, the icon then disappears. When checking the code it the page has changed to <i class="fa " data-position="icon only">.

Not the fa-cogs is missing from the class. This happens on any Font Awesome icon used in the project.


 

0 Kudos
3 Replies
Brian_W_Intel
Employee
116 Views

Hey Nick,

What steps are you using to reproduce this issue? Is it every time you assign a custom script to a button? Does it occur every time or just under a certain set of circumstances? Also, what version # of the XDK are you using?

Thanks,
Brian

Nick_F_2
New Contributor III
116 Views

It's V3400 nothing in terms of scripting. 

Copied the Font Awesome folders to the project. Icons appear fine in the tags when manually added but disappear later during further editing in design.

Brian_W_Intel
Employee
116 Views

Thanks for the info. I'm unable to reproduce the bug at the moment, but we'll file a ticket against this and keep an eye out and fix it in a future release.

Reply