Community
cancel
Showing results for 
Search instead for 
Did you mean: 
FP
Beginner
126 Views

Google Play Warning: Cordova version

Hi there

We have just received a warning from Google Play store asking us to upgrade to Cordova 4.1.1 - Our app was built last November using xdk, which version of Cordova is currently used by xdk builds on CLI 5.1.1? Thanks

Hello Google Play Developer,
Your app(s) listed at the end of this email utilize a version of Apache Cordova, an open-source mobile development framework, that contains one or more security vulnerabilities.
Please migrate your app(s) to Apache Cordova v.4.1.1 or higher as soon as possible and increment the version number of the upgraded APK. Beginning May 9, 2016, Google Play will block publishing of any new apps or updates that use pre-4.1.1 versions of Apache Cordova.
Tags (2)
0 Kudos
13 Replies
Luigi_Cama
Beginner
126 Views

I also received the same email. My test app on Playstore contains Cordova CLI 5.

Please migrate your app(s) to Apache Cordova v.4.1.1 or high...

Very strange.

Amrita_C_Intel
Employee
126 Views

We are deprecating the Intel XDK Cordova CLI 4.1.2 build system. This means that the CLI 4.1.2 build option will be retired at a future date (currently planned for March, 2016). We recommend that you start moving your projects to use the Intel XDK Cordova CLI 5.1.1 build option in preparation for the eventual discontinuation of the CLI 4.1.2 build option. Once CLI 4.1.2 is retired, you will no longer be able to use the Intel XDK to build apps with Cordova CLI 4.1.2.

We are aware that some apps currently require the CLI 4.1.2 option to successfully build. In some cases those are related to using Xcode 6 on our iOS build system, which will be resolved by the time the CLI 4.1.2 build option is retired, at which time we will have an iOS build option that employs Xcode 7. In other cases they are related to specific plugin issues.

If you have some specific issues that prevent you from using CLI 5.1.1, please provide details regarding the reason you must use CLI 4.1.2 as a post to this thread so we can be sure to address those issues before the CLI 4.1.2 build system is retired.

Amrita_C_Intel
Employee
126 Views

So were you trying to upload the app in playstore at that time you got the warning? or just received a warning through email or something?

FP
Beginner
126 Views

Amrita, I think you may be missing the point. We did use CLI 5.1.1, but the actual Cordova version is different to the CLI version, and must have been lower than 4.1.1 back in November. All I need to know is what version of Cordova (not CLI) is currently used by the xdk for new builds with CLI 5.1.1? Thanks
FP
Beginner
126 Views

Amrita C. (Intel) wrote:

So were you trying to upload the app in playstore at that time you got the warning? or just received a warning through email or something?

The app was built and uploaded to play store last November, we just received this email today.
david_m_21
Beginner
126 Views

I have received the warning today as well.

"(Your app is using a version of Apache Cordova containing one or more security vulnerabilities)"

"Please migrate your app(s) to Apache Cordova v.4.1.1 or higher as soon as possible and increment the version number of the upgraded APK. If you are using a 3rd party library that includes Apache Cordova, please notify the 3rd party and work with them to address the issue."

I had uploaded one of my apps 5 days ago. And today appear in the developer console of google play the yellow sign warning in all my 5 apps.

I have built all my 5 apps using CORDOVA CLI VERSION 5.1.1.

I make my games with Construct2 and use XDK to get the apk. So, i don´t know too much about coding and commands.

Could someone explain how to solve this in easy steps?

I have try writing the command: "npm install -g cordova" trying to update. Have this any sense?

 

Rich_S_
Beginner
126 Views

I also got the message today (2/8/2016) on my app built in 11/2015.  The app was built with the Cordova 5 CLI, so the warning message doesn't make sense (to me anyway).  Seems like either 1) the google warning is incorrect or 2) even though it looks like the XDK used 5 CLI, it really (somehow) used CLI 4.

Tadeu_r_
Beginner
126 Views

I also received the same email, and my apps are at Cordova 5 too

Richard_J_
Beginner
126 Views

I received the same email warning for an app created with Intel XDK & Cordova 5.1.1, submitted to Google Play last December.

Google Play will not allow new submissions of apps created with Cordova versions older than 4.1.1 after May 9, 2016. This will be a problem if they are incorrectly flagging our Intel XDK apps created with Cordova 5.1.1.

Thanks for any help.

Amrita_C_Intel
Employee
126 Views

Thank you for the information. We have escalated this issue. Please keep on checking the sticky note to remain updated.

Grant2
Beginner
126 Views

also have this problem. We used cordova 5.1.1 for the build and received the same warning message from google. 

Rob_Welan
New Contributor I
126 Views

My latest app also shows built with Cordova CLI 5.1.1, yet I still received a Google warning on it (and my other apps).

PaulF_IntelCorp
Employee
126 Views

To everyone on this thread, please read this FAQ and forum post, hopefully this will clear things up for you:

Reply