Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
965 Views

HAXM Install Will Not Detect Enabled VT-x

Hello,

Does anybody know how to get the Intel HAXM setup program to detect that my VT-x is enabled? VT-d and VT-x is enabled in my BIOS. I am using a Lenovo T410 running Windows 7 64-bit.

Thanks.

0 Kudos
20 Replies
Highlighted
Beginner
959 Views

Here are more details...
0 Kudos
Highlighted
Employee
959 Views

Hi Matthaniel, let me check what may be going on and I will come back to you.
0 Kudos
Highlighted
Employee
959 Views

Matthaniel, while we get to the bottom of it, a good first step could be to do a full hard power down reboot after changing the BIOS VT settings. Have you tried that?
0 Kudos
Highlighted
Beginner
959 Views

I have the same problem with an X201. I thought it was because of Windows 8, but it happened also in Windows 7
0 Kudos
Highlighted
Employee
959 Views

I have installation error with Intel IT provided laptop Lenovo T520 which has i5-2540M running Win 7 64bit. I verified all the virtualization options are enabled in BIOS and also through the processor identification utility. I get error at install saying "Failed to configure driver: unknown error. Failed to open driver." See attached image.
0 Kudos
Highlighted
Black Belt
959 Views

Hi Uday I sugested to other user on this forum to double check VT-x option setting in Bios,but by reading your post I can see that this will not work.
0 Kudos
Highlighted
959 Views

The best thing you can do to get HAXM detect VT again, is turning the whole Hyper-V "Feature" off. Open "Control Panel -> "Programs" -> "Turn Windows features on or off" (under "Programs and Features") and locate "Hyper-V", uncheck, reboot.Looks like Hyper-V and HAXM are mutually exclusive, which is kind of a nuisance, because you even need to reboot twice to enable or disable either feature.

0 Kudos
Highlighted
Beginner
959 Views

Hello, I use the Lenovo B350. When I tried to install Intel HAXM, it came that my VT-X technology was not enabled. I checked in my BIOS and it was enabled. Then, I saw somewhere that turning off Hyper V might be useful, but mine was already disabled. What do I do now?

Also, it seems that mostly Lenovo devices suffer from HAXM installation problems. Is there any characteristic feature in Lenovo devices which makes this happen?

0 Kudos
Highlighted
Beginner
959 Views

I had exactly the same problems on my G510. Virtualisation enabled in BIOS, Hyper V disabled, Intel Processor Identification utility saying VT-X is enabled... But HAXM still wasn't working. Then I remebered that Avast uses virtualisation for malware handling purposes. I disabled it and HAXM installed without any problems... I hope this helped you :)

0 Kudos
Highlighted
Beginner
959 Views

Mohamed helmi b. wrote:

The best thing you can do to get HAXM detect VT again, is turning the whole Hyper-V "Feature" off. Open "Control Panel -> "Programs" -> "Turn Windows features on or off" (under "Programs and Features") and locate "Hyper-V", uncheck, reboot.Looks like Hyper-V and HAXM are mutually exclusive, which is kind of a nuisance, because you even need to reboot twice to enable or disable either feature.

Works, thank you.

0 Kudos
Highlighted
Beginner
959 Views

My HAXM installation also says that vt-x is disabled even though I double-checked my BIOS, and I don't Hyper-V at all (doesn't appear in the feature list). Does anyone has any other idea?

I also have a Lenovo laptop running Windows 7 32 bit.

Edit: Apparently I only needed to power-down (no just reset) my computer again after changing the BIOS setting.

0 Kudos
Highlighted
Beginner
959 Views

Uninstalling Avaast fixed my problems and let me install HAXM. Thanks!  

0 Kudos
Highlighted
Beginner
959 Views

Solution: 
In my case, for Sony Vaio, Avast, 64 bit Windows 7 OS. 

I had enabled virtualization in BIOS and while installing Intel HAXM independently, it was throwing the error that VT-x is not enabled. Tried many things and finally it worked. Here are the steps I did,

0. Enabled Hardware Virtualization in BIOS. (in advanced tab)
1. in Avast->Settings->Troubleshooting
    Uncheck "Enable hardware-assisted virtualization" & "Enable avast self-defense module"
    Also had unchecked "Enable rootkit scan on system startup" and "Enable raw disk access during Avast boot-time scan", But it may not be required. 

This took some time to figure out. Wasted almost 2 days on it. Hopefully it helps others.

Now the emulator runs on Studio without any hitches. 

0 Kudos
Highlighted
Beginner
959 Views

Thank Ursic U. and Anul S.

Disabling "hardware-assisted virtualization" feature in avast solved my problem.

Regards.

0 Kudos
Highlighted
Beginner
959 Views

I am still having the problem after trying all the options.

My device is a Lenovo s540 and when I try installing haxm-android I get this error: 

"This computer meets the requirements for HAXM, but Intel Virtualization Technology (VT-x) is not turned on. HAXM cannot be installed until VT-x is enabled.
Please refer to the Intel HAXM documentation for more information."

Although the intel software utility says it's enabled. Also Hyper-V is not installed so there is nothing to disable.

Antivirus is eset smart security

0 Kudos
Highlighted
Beginner
959 Views

Did it solve your problem?

0 Kudos
Highlighted
Beginner
959 Views

Anyone give me basics on how to start working with android studio?

0 Kudos
Highlighted
Employee
959 Views

 

Timothy M. wrote:

Anyone give me basics on how to start working with android studio?

Hi Timothy, just to be sure I understand your question properly, are you trying to start the Android emulator (with HAXM) from Android Studio? Or you want to start learning how to use Android Studio?

In the latter case, allow me to guide you to some great tutorials to get you started. First, you may want to read the official overview of Android Studio here: 
http://developer.android.com/tools/studio/index.html
After that, you would want to try out a "Hello World" example. "Hello World" examples are great because you get to try out the basic features of Android Studio and get familiar with programming. Check this link to get started: 
http://code.tutsplus.com/tutorials/getting-started-with-android-studio--mobile-22958

As an additional information, if you want to develop mobile applications for cross-platform, you may wish to check Intel INDE (inde.intel.com). If you have questions about INDE, do not hesitate to ask your question on the Intel INDE forum: 
https://software.intel.com/en-us/forums/intel-integrated-native-developer-experience-intel-inde

I hope that was helpful.

Regards,

Shailen.

0 Kudos
Highlighted
Beginner
959 Views

Anul S. wrote:

Solution: 
In my case, for Sony Vaio, Avast, 64 bit Windows 7 OS. 

I had enabled virtualization in BIOS and while installing Intel HAXM independently, it was throwing the error that VT-x is not enabled. Tried many things and finally it worked. Here are the steps I did,

0. Enabled Hardware Virtualization in BIOS. (in advanced tab)
1. in Avast->Settings->Troubleshooting
    Uncheck "Enable hardware-assisted virtualization" & "Enable avast self-defense module"
    Also had unchecked "Enable rootkit scan on system startup" and "Enable raw disk access during Avast boot-time scan", But it may not be required. 

This took some time to figure out. Wasted almost 2 days on it. Hopefully it helps others.

Now the emulator runs on Studio without any hitches. 

Registered just to say thanks - thanks!

0 Kudos