Software Archive
Read-only legacy content

I can't see my Japanese characters on Intel XDK 1816.

tetsuya
Beginner
3,023 Views

Hi all,

Today, I upgraded my Intel XDK to the version 1816.
When I opened my project, I chosen "update project for intel xdk + cordova" following the instructions.

After that, it become showing troubles on the design parts concerning to character strings in Japanese.
In my experiment, there seems two patterns in the troubles.

Pattern 1 ... Don't show any Japanese characters in the design view on the develop tab, in the properties text area and on the emulator.
   Design parts in the pattern 1 include FORM/TextArea and MEDIA/Text.

Pattern 2 ... Don't show in the properties text area, but it shows in the design view and on the emulator.
   Design parts in the pattern 2 include FORM/SELECT (options) and BUTTON.

What can I do for that?

Regards,
--
tetsuya

0 Kudos
23 Replies
tetsuya
Beginner
389 Views

Thank you, David and Miwako.

I've found an additional procedure to reproduce the problem.

  1. Create a virtual machine on Hyper-V
  2. Download Windows 7 Professional with Service Pack 1 (x86) Japanese, from MSDN subscriber download page
  3. Install it to the virtual machine
    IME=MS-IME, Keyboard=101
  4. Install XDK
  5. Create a new project just like my comment at 03/24/2015 22:16

I tried before no Windows Update is applied.

Regards,
--
tetsuya

0 Kudos
Miwako_T_Intel
Employee
389 Views

Hi, Tetsuya.

Thank you for info! I will pass it to the team.

Miwako

0 Kudos
Chris_P_Intel
Employee
389 Views

As to opening in Design mode (and having the DESIGN|CODE button available), everything seems to be working.

In the case of NewProject.zip  that opens correctly but there is no "last working file", so you have to browse down to www/index.html   Once you do that, the DESIGN|CODE buttons will be available and the design mode works great.

Blank.zip is different because when that project was created 'App Designer' was not elected, so it will never be available.

0 Kudos
Reply