Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Giuseppe_S_1
Beginner
115 Views

INTEL daemon (Fortran compiler) doesn't start

Hello,

I have a cluster where is installed the Intel Fortran Compiler and I'm facing problems with starting  its daemon. I will give all the information I can: 

The flexlm daemon is running correctly:
root 38848 0.0 0.0 17496 1636 pts/8 S 10:23 0:00 /opt/flexlm/lmgrd -c /opt/flexlm/server.lic -l /opt/flexlm/lmgrd.log

Now, If I digit 

./lmutil lmstat -c server.lic

I get: 

lmutil - Copyright (c) 1989-2013 Flexera Software LLC. All Rights Reserved.
Flexible License Manager status on Tue 7/12/2016 11:42

License server status: 28518@controller.cluster
    License file(s) on controller.cluster: /opt/flexlm/server.lic:

controller.cluster: license server UP (MASTER) v11.12.0

Vendor daemon status (on controller.cluster):

     INTEL: The desired vendor daemon is down. (-97,121)

The lmgrd.log is:

10:23:39 (lmgrd) Server's System Date and Time: Tue Jul 12 2016 10:23:39 IST
10:23:39 (lmgrd) SLOG: Summary LOG statistics is enabled.
10:23:39 (lmgrd) The license server manager (lmgrd) running as root:
10:23:39 (lmgrd)        This is a potential security problem
10:23:39 (lmgrd)        and is not recommended.
10:23:39 (lmgrd) FlexNet Licensing (v11.12.0.0 build 136775 x64_lsb) started on controller.cluster (linux) (7/12/2016)
10:23:39 (lmgrd) Copyright (c) 1988-2013 Flexera Software LLC. All Rights Reserved.
10:23:39 (lmgrd) World Wide Web:  http://www.flexerasoftware.com
10:23:39 (lmgrd) License file(s): /opt/flexlm/server.lic
10:23:39 (lmgrd) lmgrd tcp-port 28518
10:23:39 (lmgrd) (@lmgrd-SLOG@) ===============================================
10:23:39 (lmgrd) (@lmgrd-SLOG@) === LMGRD ===
10:23:39 (lmgrd) (@lmgrd-SLOG@) Start-Date: Tue Jul 12 2016 10:23:39 IST
10:23:39 (lmgrd) (@lmgrd-SLOG@) PID: 38848
10:23:39 (lmgrd) (@lmgrd-SLOG@) LMGRD Version: v11.12.0.0 build 136775 x64_lsb ( build 136775 (ipv6))
10:23:39 (lmgrd) (@lmgrd-SLOG@) 
10:23:39 (lmgrd) (@lmgrd-SLOG@) === Network Info ===
10:23:39 (lmgrd) (@lmgrd-SLOG@) Socket interface: IPV6
10:23:39 (lmgrd) (@lmgrd-SLOG@) Listening port: 28518
10:23:39 (lmgrd) (@lmgrd-SLOG@) 
10:23:39 (lmgrd) (@lmgrd-SLOG@) === Startup Info ===
10:23:39 (lmgrd) (@lmgrd-SLOG@) Server Configuration: Single Server
10:23:39 (lmgrd) (@lmgrd-SLOG@) Command-line options used at LS startup: -c /opt/flexlm/server.lic -l /opt/flexlm/lmgrd.log 
10:23:39 (lmgrd) (@lmgrd-SLOG@) License file(s) used:  /opt/flexlm/server.lic
10:23:39 (lmgrd) (@lmgrd-SLOG@) ===============================================
10:23:39 (lmgrd) Starting vendor daemons ... 
10:23:39 (lmgrd) Started INTEL (internet tcp_port 50352 pid 38849)
10:23:39 (INTEL) Unable to initialize access to trusted storage: 2
10:23:39 (INTEL) FlexNet Licensing version v11.12.0.0 build 136775 x64_lsb
10:23:39 (INTEL) SLOG: Summary LOG statistics is enabled.
10:23:39 (INTEL) SLOG: FNPLS-INTERNAL-CKPT1
10:23:39 (INTEL) SLOG: FNPLS-INTERNAL-CKPT2
10:23:39 (INTEL) EXPIRED: I0C64C577
10:23:39 (INTEL) EXPIRED: AdvXEl
10:23:39 (INTEL) EXPIRED: ArBBL
10:23:39 (INTEL) EXPIRED: CCompL
10:23:39 (INTEL) EXPIRED: DbgL
10:23:39 (INTEL) EXPIRED: FCompL
10:23:39 (INTEL) EXPIRED: IClsTktL
10:23:39 (INTEL) EXPIRED: ITrAnlL
10:23:39 (INTEL) EXPIRED: ITrAnlW
10:23:39 (INTEL) EXPIRED: ITrColL
10:23:39 (INTEL) EXPIRED: MKernL
10:23:39 (INTEL) EXPIRED: MPassL
10:23:39 (INTEL) EXPIRED: PerfAnl
10:23:39 (INTEL) EXPIRED: PerfPrimL
10:23:39 (INTEL) EXPIRED: StaticAnlL
10:23:39 (INTEL) EXPIRED: ThreadAnlGui
10:23:39 (INTEL) EXPIRED: ThreadBB
10:23:39 (INTEL) License server system started on controller.cluster
10:23:39 (INTEL) No features to serve, exiting
10:23:39 (INTEL) EXITING DUE TO SIGNAL 36 Exit reason 4
10:23:39 (lmgrd) INTEL exited with status 36 (No features to serve)
10:23:39 (lmgrd) INTEL daemon found no features.  Please correct
10:23:39 (lmgrd) license file and re-start daemons.
10:23:39 (lmgrd) 
10:23:39 (lmgrd) This may be due to the fact that you are using
10:23:39 (lmgrd) a different license file from the one you expect.
10:23:39 (lmgrd) Check to make sure that:
10:23:39 (lmgrd) /opt/flexlm/server.lic 
10:23:39 (lmgrd) is the license file you want to use.

Any ideas for how to solve this issue? 

Thank you.

Kind Regards,
Giuseppe Silletti

0 Kudos
2 Replies
Hubert_H_Intel
Employee
115 Views

Hi Giuseppe,

I do not see any registrations in the Intel(R) Registration Center for the license server shown in the log file.

Besides that, you should update to the newest Intel(R) Software License Manager v2.4 (lmgrd v11.13).
Download: https://registrationcenter.intel.com/download.aspx?ProductID=2841&pass=yes (can be done by the license owner and registered users only).

Could you please upload the server.lic (under 'Send Author A Message').

Regards, Hubert.

Light_Intel
Moderator
115 Views

This issue has been addressed. If you have a similar question please start a new thread to ensure your issue is being addressed in a timely manner.

Reply