Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Mesack_E_
Beginner
44 Views

IOS build not launching on Device

Can someone help me with this please? My app builds without any critical errors and  runs without any issues on an Android device. But I'm having issues with running the app on an IOS device mainly Iphone 6 on OS 9.3. The IOS builds on XDK are successful without any critical errors and will run in app preview mode and in emulator, but when I launch the app from an iPhone 6 device I dont get past the splash screen which fades out. I've tried changing the whitelist intent and navigation rules to wildcards to be sure that I haven't missed anything and setting content policy directives to allow anything from within the app to run but still no change. When I attempt to profile or debug in XDK I get an unknown error or a session timeout error. I can't debug the app in XDK but it will run in App Preview. Looking at the build logs which I've attached I get an error after the command below is initiated on the build server:

Running command: .../cordova_project/platforms/ios/cordova/version 
Command finished with error code 0: .../cordova_project/platforms/ios/cordova/version 

Somehow this error does not affect the the build on the server as it returns as successful, but even so, I don't know what it means or where to begin to find out. I have attached the latest build log. On Android the app can be debugged and profiled without any problems. Any help to solve this would be greatly appreciated.

 

 

Tags (2)
0 Kudos
1 Reply
PaulF_IntelCorp
Employee
44 Views

Please see the response here > https://software.intel.com/en-us/forums/intel-xdk/topic/657821#comment-1877281 < and please refrain from posting the same question on multiple threads.

Reply