Software Archive
Read-only legacy content

IPA hangs

Dan_K_
Beginner
612 Views

My IOS builds successfully. I upload it to Apple's TestFlight. It installs OK on my iPhone. When I run it, I get the message to allow access to current location and use it. Then the app shows the app's icon, and it just hangs. ?? It works fine in the emulator and with App Preview.

Any ideas?

Thanks,

-dk

 

 

0 Kudos
5 Replies
John_H_Intel2
Employee
612 Views

Did you try installing the ipa directly from the build system? Does it install/run there?

0 Kudos
Dan_K_
Beginner
612 Views

I must be missing something - how do I install directly from the build system?

0 Kudos
John_H_Intel2
Employee
612 Views

When you build your app, there is an email that is automatically sent to the registered email account you are logged in. Open that email in the Mail app on iOS device, and there is an OTA(over the air) link to install your app. The device UDID must be included in the provisioning profile you are using.

If you do not have that email account on your iOS device, there is an option to send additional emails at the end of the build. Only the most recent build email is usable to install the IPA.

0 Kudos
Dan_K_
Beginner
612 Views

Thanks. I understand that option. I'm trying to use Apple's TestFlight (it doesn't require UUIDs). You can send an invite to several testers and they can test without sending me their UUIDs.

I'll try the UUID method just to see if I still have the problem.

 

 

 

0 Kudos
Elroy_A_Intel
Employee
612 Views

I recommend testing the application on an iOS device directly via the Build method stated above by John. This option allows you to install the app similar to the installation facilitated by Testflight. I also suggest debugging your application on device via the Debug tab of which requires that your iOS device connected via USB. This process is helpful in determining and evaluating bugs. 

0 Kudos
Reply