Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Thibaut_P_
Beginner
116 Views

Iframe and ios 9.3.1

Jump to solution

Hi,

I use an iframe in a page (intel xdk 3088, cli 5.4.1)

With android there is no problem.

With IOS, since 9.3.1, the iframe don't display anything.

Before ios 9.3.1, it works fine (ios 8 etc...)

It's ok in the emulator.

I don't found anything about this bug... and Apple reject the app because of this problem.

I have tried with http, https, // but nothing works.

Tags (2)
0 Kudos
1 Solution
PaulF_IntelCorp
Employee
116 Views

Thibaut -- this sounds like a whitelist issue. See the whitelist settings in the Build Settings section and follow the (i) links for more details.

View solution in original post

7 Replies
Chris_P_Intel
Employee
116 Views

What is the URL you are trying to bind into the iframe? Is it local to your app or remote?  

What is the HTML of your iframe? Have you enabled any of the sandbox features?

Thibaut_P_
Beginner
116 Views

Hi,

The URL is remote :

For example :

<iframe src="https://www.youtube.com/..."></iframe>

what is it "sandbox features" ?

before ios 9.3.1, i have no problem with the iframe (youtube or other remote url)

PaulF_IntelCorp
Employee
117 Views

Thibaut -- this sounds like a whitelist issue. See the whitelist settings in the Build Settings section and follow the (i) links for more details.

View solution in original post

Thibaut_P_
Beginner
116 Views

Thank you Paul !

It comes from the whitelist indeed!

giuseppe_s_
Beginner
116 Views

 emulator works but of apps installed does not work !!
how you solved iframe with the youtube video on whitelist you added what?
iframe: * ??
thank you
you can explain to me thanks

PaulF_IntelCorp
Employee
116 Views

Giuseppe -- iframes are difficult to work with in this environment, I recommend you use the InAppBrowser plugin, instead. If you are using an iframe, you'll need to whitelist the addresses the iframe accesses, not the iframe itself.

Thibaut_P_
Beginner
116 Views

In the white list, you must have :

http://*/*
and/or
https://*/*

And after that, you have those lines in intelxdk.config.ios.xml :

<allow-navigation href="http://*/*"/>
<allow-navigation href="https://*/*"/>

Reply