Software Archive
Read-only legacy content
17061 Discussions

Installer crashes (Windows 8.1 64)

jasmin_f_
Beginner
778 Views

Hi,

i encountered a kernel panic during first installation, i am not sure which process was causing it.
Nevertheless any further tries to install the Intel System Studio Update 1 failed telling me that VTune
was already fully installed, it wasn't. Also it wasn't listed in Programs and Features, so i just tried
to clean it myself, deleting Files and keys in the Windows registry. Now it fails at initializing, randomly
after loading pre_install.js.
The exception is an access violation calling msi.dll!GetInfo() called from msi.dll!MsiGetProductInfoW().
I can provide a dump file if needed. It seems like the function is called with 0 as each parameter.

I guess there are still remains in the registry, is there a list of all GUID's the installer put into the registry?
Or is there a clean tool available?

Thanks ins advance, cheers fassl

0 Kudos
7 Replies
Noah_C_Intel
Employee
778 Views

Hello Jasmin, thanks for your clear explanation! I have verified your issue and I feel it is a matter of more cleanly extracting all components and reinstalling. We have a great step by step article that can help you do that (I'm looking for the Windows version of it right now). Did you have a previous version of Intel Software Development Tools installed on this Windows 8.1 machine in the past? Maybe Intel Parallel Studio XE, our compiler, libraries, or analysis tools? In the meantime, I am moving your forum post to a group dedicated to solving these kinds of issues to gain some more insight. I will be in touch with you to get this resolved.

0 Kudos
jasmin_f_
Beginner
778 Views

Hi Noah,

thanks for the prompt answer! No, that is the first time i tried to install tools like that on this particular machine. I have Intel Storage Management tools installed but I think this shouldn't be a problem?

0 Kudos
Noah_C_Intel
Employee
778 Views

Could you confirm that the package name is w_cembd_p_2015.1.039?

Could you provide all the steps that you took that led to this problem? (were integrations to Eclipse, NDK, WB chosen)?

Could you provide the logs (please zip and send me folders %TEMP%\pset_tmp_... )?

0 Kudos
jasmin_f_
Beginner
778 Views

Package name is w_cembdw_p_2015.1.017, thats the one i got by registering for the evaluation version.

Hm, i am not quite sure anymore which components i chose, i just wanted the compiler and the integration into MSVS 2013.

Attached is the log.

Thanks

0 Kudos
jasmin_f_
Beginner
778 Views

Noah,

thanks for pointing me to the log files, i also found the *.msi packages and uninstalled
all of them, the SUITE_PROF_SPECIFIC and SUITE_COMMON i had to repair. No crash
anymore ;) Thank you very much for your help, awesome support!

Cheers

0 Kudos
jasmin_f_
Beginner
778 Views

After finishing installation it tries to open lets call it %INSTALL_DIR%/Documentation/en_US/embedded_gsdoc_w.htm. It does not exist with w_cembdw_p_2015.1.017 and installing:

Intel C++ Compiler 15.0 Update1
Intel MKL core libraries for Intel 64 & IA-32
Intel Integrated Performance Primitives 8.2 Update 1 (single-threaded)
Intel Threading Building Blocks 4.3 Update 2

0 Kudos
Noah_C_Intel
Employee
778 Views

Hi, sorry there appears to be a problem with that particular file. You may go here to review the getting started guide online!

https://software.intel.com/en-us/articles/intel-system-studio-release-notes#gettingstarted

Please also go here for a wealth of material. We have written over 100 articles, many of them Windows focused at the beginning of the list.

https://software.intel.com/en-us/articles/intel-system-studio-articles

 

 

0 Kudos
Reply